Loading

LightScythe V2 - Raspberry Pi & OpenBeam version

by Gav, published

LightScythe V2 - Raspberry Pi & OpenBeam version by Gav Jul 16, 2013

Description

This is an updated version of my Lightscythe. Full details and code here:
https://sites.google.com/site/mechatronicsguy/lightscythe-v2

The files are the main plates to hold the openbeam together and act as a handle, as well as the box to hold the raspberry pi in a removable 'shoe'.

Recent Comments

view all
Hi IImchstrss,

Have you got the two button pins hooked up with 1k pullup resistors to the 3v3 line?

Let's see if I can do some ASCII art here:

3.3V ----<1K RESISTOR> --- <switch> ------ GND
|
GPIO pin
Cheers,
Gavin</switch>
Hi Gavin,

I actually got most of the set up completed, but I am running into a problem with button.py: the code doesn't stop at "waiting for button press"...

I ran the python code in the LXTerminal, under root (sudo python /home/pi/http://button.py)
it found and displayed the files (locally, I didnt use the USB yet)
it printed "scything file xxx.png"
it printed "loading..."
it printed the pixels (a 500 x 104px file in my case)
it printed "allocating..."
it printed "Converting..."
It assigned a File number of "0"
...and then it jumps directly to "Displaying..." and then starts loading the next file..and so on.

meanwhile nothing is happening with the LED strip.

I tried the adafruit code as well. Other than the fact that it loops and plays the LEDs forever, it seems to be doing fine...thats why I know the LEDs are working.

If you could give me any pointers on what may be wrong, I'd appreciate it immensely...Thanks so much!

More from Art

view more

Liked By

view all

Give a Shout Out

If you print this Thing and display it in public proudly give attribution by printing and displaying this tag. Print Thing Tag
Hi Gavin,

I actually got most of the set up completed, but I am running into a problem with button.py: the code doesn't stop at "waiting for button press"...

I ran the python code in the LXTerminal, under root (sudo python /home/pi/http://button.py)
it found and displayed the files (locally, I didnt use the USB yet)
it printed "scything file xxx.png"
it printed "loading..."
it printed the pixels (a 500 x 104px file in my case)
it printed "allocating..."
it printed "Converting..."
It assigned a File number of "0"
...and then it jumps directly to "Displaying..." and then starts loading the next file..and so on.

meanwhile nothing is happening with the LED strip.

I tried the adafruit code as well. Other than the fact that it loops and plays the LEDs forever, it seems to be doing fine...thats why I know the LEDs are working.

If you could give me any pointers on what may be wrong, I'd appreciate it immensely...Thanks so much!
Hi IImchstrss,

Have you got the two button pins hooked up with 1k pullup resistors to the 3v3 line?

Let's see if I can do some ASCII art here:

3.3V ----<1K RESISTOR> --- <switch> ------ GND
|
GPIO pin
Cheers,
Gavin</switch>
Top