Loading

Report as inappropriate

That's a build FlashForge did so it's not possible to know what exactly it is beyond being a fork of the 7.8 sources. Should work fine. Shouldn't be any need to upgrade.