Loading

Report as inappropriate

Yes, a RAMPS v1.4 board ought to work just fine. Obviously, you'll need to wire it differently from the diagram I've got for the MKS board, but there shouldn't be any firmware issues.