Loading

Report as inappropriate

I used a teensy 2.0.
the 3.2 is a little shorter, so it should fit. but I had problems finding firmware for teensy v3.2.