Loading

Report as inappropriate

I love this firmware. You did a fantastic job.
I have a question. I have a ffcp with atmega2560 and want to uodate. I checked replicator newest release and it shows that for the ffcp with 2560 7.7 is available version 7.7 r1592, r1416b. Mine shows some generic 012345. Will it hurt to update to the new 7.7 r1592? It is running flashforges mightyboard with atmega2560.