Loading

Mainboard not working after flashing?

Please Login to Comment

Hey, hope you can help me.

I have a Anet A6 but the mainboard is the same as in the A8. I have already installed Skynet 3.2.1 with autoleveling working and everything was fine. There have been some tolerances with the bed leveling so i wanted to try the "Z_MIN_PROBE_REPEATABILITY_TEST" and upload the Sketch to my board as I already did a lot of times. The upload took forever and aborted. Now the Screen of the printer doesent show anything, no LED is lit on the board and only the Fan is running. I cant connect to the board with the Arduino software or avrdude or anything else. I measured the Input voltage for the board (11,8V) and the Output voltage from the 5V regulator, which is 6,8V (too high I think?). Did I kill my board? Any Ideas?

Thanks

Has someone made a video walking through this? That would be great i am having trouble with my board right out of the box.

Hello,

I'm suffering from the exact same initial problem but mine seems more serious now. I wasn't sure also about the tolerances in the bed leveling so I activated the Z_MIN_PROBE_REPEATABILITY_TEST resulting on a non-working board.
I've tried to use an arduino UNO as ISP in order to flash the AnetV1 bootloader that came with the skynet 2.3.2. Althought it apparently went fine, I wasn't being able to upload sketches again via normal way (direct USB and the mkII programmer selected). Trying to upload it with the UNO as ISP, the board was being detected and the code was being written, but it was failing the veryfying part. I tried it several times with and without powering the anet board with 12V, and tried several times writing the bootloader but without success. In despair, I might have tried the "-F" option, and now I can't even write successfully the bootloader.
In more despair, I have bought another board and somehow stupidly repeated the same steps... Now I have two boards that aren't working.

I believe I'm doing everything that is being told here (powering the anet board with 12V, using short cables from UNO to ANET, using a 10uF capacitor between RST and GND, also using a small capacitor between 5v and GND, and I verified the cabling - in a part of the process there were actually some cabling wrong, but now I'm pretty sure they are correct and also tested continuity from the UNO pins up to the pins of the AT1284). I've also used different arduinos as ISP (UNO and Micro PRO) and different computers (windows with the arduino IDE that came with skynet 2.3.2 and ubuntu with the latest arduino 1.8.2 64bits). I also uploaded the arduino as ISP sketch several times to the UNO and Micro - in the micro I had to change the pin definition.

The error I'm getting is the wrong device signature "avrdude: Device signature = 0x000000 (retrying)".

This is my latest setup:
https://drive.google.com/open?id=0BxpTY9c9S_jZb1hDZFo1N09ILXM

I suspect I may have written the wrong fuses and now the AT1284 is not synchronizing correctly. I have searched a lot on line but couldn't find an answer. I'm running out of ideas and would really want to be sure of what I may have done wrong so I don't repeat with a third board :)

Any ideas/suggestions?

Thanks,
Joaoabs

Comments deleted.

Yeah thats why the Arduino franchise is a total piece of shit like I always said.

Because the upload bugged out, you've bricked your Arduino board. No software will help you now.
What you need is an ISP programmer to flash the mircocontroller directly (like every sane person in the industry is always doing it)
http://www.ebay.com/sch/i.html?_from=R40&_trksid=p2050601.m570.l1311.R4.TR8.TRC1.A0.H0.Xusbasp.TRS0&_nkw=usbasp+programmer&_sacat=0

I've also bricked my board while flashing Skynet (which btw is a total buggy and unsusable firmware). Thankfully I have a few ISP programmers lying around so I could revert it.

I have a arduino nano which can be a ISP programmer. Which board do I have to set to flash the bootloader? I selected Anet 1.0 but it doesnt work.

avrdude: Error: Could not find USBtiny device (0x2341/0x49)

  1. Connect the 6 pin programming cable to the 10 pin ISP socket. I'ts over the display socket http://imgur.com/AYH58qt
  2. Pick the right programmer in avrdude. In my case it is USBasp. No idea what you have to pick
  3. Pick the right microcontroller. usually autodetect works fine. If not pick the ATmega1284P.
  4. Burn the hex file to the flash storage
  5. ...
  6. Profit

Thats at least what I did. There is no reason to change the settings in avrdude like the com port or baud rate. Usually Avrdude is taking care of that

I'll be following these instructions when My ISP programmer arrives (just ordered one).
My ANET A8 boards keep developing problems with the extruder temperature, giving readings way higher than possible. So I thought I should try Skynet (very dissapointed) then reverted to ANET firmware and my board became useless, displaying fully lit square accross and down, this was my own fault, I opted for binary with ANET's flash tool and should have stuck with auto.
Never the less the ANET firmware certainly has a problem with the extruder thermistor and I wish I knew what causes it, I'll be on mainboard number three and thermistor seven when I'm up and running again. Anyway thanks Tavero, because I didn't know that these 6 to 10 ISP programmers existed.

I got it! I took ArduinoISP instead of Arduino as ISP. It worked and now Skynet is running again! Thank you so much for leading me in the right direction! Awesome!

How can i make that you get a beer for that? :)

I'm trying to do the same thing with an Arduino Uno, but no luck. Did you disconnect the printer's power supply while you did the procedure? Also, just to make sure, is this the correct pinout (see image) : http://3dtoday.ru/upload/main/233/Anet.jpg
When you say you used ArduinoISP for the programmer, had you previously uploaded the ArduinoISP sketch? And last thing, when uploading the Skynet sketch, you selected Anet 1.0 board?

I powered the Mainboard from its Power supply. Select your arduino as the Board and Upload the ISP Sketch to it. after that select anet v1.0 as Board and "arduino as ISP" as the programmer. The Pin Layout you postet ist the right one but take care that your Mainboard ist upside down in your printer. Now select burn Bootloader from the arduino Menu. If that worked connect your printer via usb and Upload the skynet Sketch as in the instructions (with anet as Board and This av mk2 Thing as programmer)

Ok, finally managed to do it with Arduino Uno! Here is what I did. I uploaded the ArduinoISP sketch to my UNO. I connected the LCD cable in J3 instead of the display port. On the other end of the cable I used some jumper wires to connect to the ICSP connector on the UNO. The reset wire was connected directly to D10 on the arduino uno instead of the ICSP. I also added a 10 microfarad capacitor between GND and Reset. From there I burnt the bootloader (Tools->Burn Bootloader). Once this was done, I disconnected the UNO from the J3 connector. I connected the Anet board to the USB and powered on the printer. I re-upploaded the Skynet sketch from Arduino as I would do normally. I'm back in business! Hope this helps. Thanks everyone for this thread, it was of great help!

Thanks kgagnon, i was having this issue and this solved it for me!

Thank you ! - This helped me out !

great to hear that it also helped you :)

Drink your beer while worshipping me.

Nah just kidding. I'm happy I could help.

if you google for the error

avrdude.exe: stk500_recv(): programmer is not responding anet

you can find lot´s of help
like

https://www.mikrocontroller.net/topic/366198

If the upload was aborted maybe you brick the board because the board hasn't any firmware and when you plug it in to the pc the board don't know what to do.

Probably there is something wrong.. RE upload the original firmware and see what goes on. Arduinos don´t get bricked when the sofware does not run..

This is the message I get:

avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
(...)

I think you refer to Skynet3D 2.3.1?

You could try to get the stock software back: https://www.dropbox.com/s/sh4uyr37ouz6i3a/A6-FirmwareUpdate.zip?dl=0
With these instructions: https://www.dropbox.com/s/sh4uyr37ouz6i3a/A6-FirmwareUpdate.zip?dl=0

Same link for instructions and Firmware file!? :(

Of course 2.3.1! I will try it later today