Loading

Going back to original Anet firmware

Please Login to Comment

Hi, I've installed skynet and a sensor but after many weeks to try to fix the auto bed levelling (by following step by step an excellent video on YT), I must consider to go back to the orginal firmware. So I will be able to print just as the beginning as for the moment I'm not able to print anything...
But I don't know how to install the original firmware available when I bought my Anet A8 printer 4 months ago...
Can someone help me ?
I know already this site : http://anet3d.en.made-in-china.com/custom-detail/xmQExQndGJUQxmQExQndGJUQ/The-Firmware-Links-You-May-Need.html
but the explainations are totally impossible to understand...
Thank you for your help

You could also just re-flash it with Skynet non-auto-levelling version. I find this has quite a few good features over the standard A8 firmware, and you have already gone through the process so shouldn't be too bad to do it again just with the other version?

You're right ! I will wait for a last (?) help to make this auto bed leveling working and if I cannot do it, I will flash the non auto version of skynet (I didn't know this was possible...)
Thank you !!

Why is your auto bed leveling not working? Which sensor are you using?

To go back to the original firmware it is pretty straight forward. Did you download the instructions?
Power up your printer
Plug the USB to the motherboard and to your computer.
Find out which COM port it is using
Opening avrdudess.exe
Under Programmer put Arduino
Set your COM port, then set the baud rate to 57600
Set your MCU to ATmega1284p
Under Flash, browse to firmwareResetV1.hex --> you need to flash this one first before flash A8-L
Click on Write then click on Go under the Flash section.

This will start flashing and once it says done you can close it .

Hi jchau, perharps you could help me to make this auto bed leveling working ?
I have followed the instructions given on that very good video because I've exactly this sensor : https://www.youtube.com/watch?v=uYDOZ9pUQIs
up to step 8, where the nozzle is effectively about 1mm above the bed. When I adjust the offset in order to close the nozzle to the bed, nothing happends.... So the nozzle remains too far from the bed... Of course, if I try to change manually the position of the bed with the screws, I lose all the tunings.
And finally, I don't know how to introduce the G29 code in the slicer (I use CURA...)
Well, if you have the answers, it's great !
Thank you in advance

Which version of skynet? I use 2.3.2 and just follow the tutorial document included in the install files. If you follow it to the exact words and enter your own offset it should work

I use the 1.1 version...
I'll try with the 2.3.2 I've downloaded...
Wait and see :-)

With version 1.1 and that sensor following that video instructions should work without a problem. With 2.3.2 you will need to change the auto level sampling coordinates in the source code or else it will crash into your bed.

For version 1.1 did you follow all the steps especially step 4 where you bring the nozzle down to paper thickness above the bed? Then step 6 did move the sensor to the correct point of activation? If you did all that then Step 8 if you slowly keep adding the offset the nozzle should eventually be lowered enough to paper thickness. Then make sure you store memory after.

If you are using Cura 2.5 then if you go to your Machine Setting you should see Start Code and End GCode. After G28 line, enter and put a G29. If you are using Cura 15 then there is a tab called Start/End G Code

OK... I'll try once again all the steps, step by step and hope it will be OK
I'll tell you the result. Already thank you for your help !
I'm using CURA 2.5.0, french version (I'm french...). I don't see any line of codes and have explored all the menus, but don't find any list of code...

The machine setting page looks something like this https://all3dp.com/app/uploads/2017/01/Cura_Machine_Settings.jpg

You need to enter G29 after the G28 line.

I've done (again...) all the steps from #1...
Everything seemed OK
I've entered the G29 code line as followed :

G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G29 ; Auto Bed Level
G1 Z15.0 F6000 ;move the platform down 15mm
etc...
BUT, when I try to print a basic test cube, the nozzle starts to test the bed just like doing an autolevel process and when arrives at the right edge (after 2 points left and left/center that are OK), the nozzle sinks into the bed and I am forced to stop the process by turning off the machine because it sinks hard !!

Really? Got a picture of your setup? The coordinates for skynet 1.1 should work. 2.3.2 the cooordinate is off so i had to enter new one

If you can have a look on that : https://we.tl/dCqKHCgKQ6

This is my start code:
;Sliced at: {day} {date} {time}
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off

G28 ; Auto Home All AXIS
G29 ; Auto Bed Levelling

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F{travel_speed}
M117 Printing...

I haven't had a chance to turn on my 3D printing computer yesterday. I'll take a look at it tonight and copy and paste my Start Code.

But from what it sounds like the coordinate in your Configuration.h files might be off.

thanks for your accurate answer... I'll try it tonight :-)
I don't know exactly what the Configuration.h is, but I will search for it...

If you are using version 2.3.2 it is Skynet v2.3.2 fix 2\Skynet v2.3.2\SkynetV2.3.2 but you need to copy through the right Configuration profile.

In Version 1.1 it is SkyNet3D V1.1 FIRMWARE ANET A8\SkyNet3D_V1.1alfa\SkyNet3D_V1.1alfa

You might need to modify these numbers (this is from 1.1 --> 2.3.2 my numbers are different)
// set the rectangle in which to probe

define LEFT_PROBE_BED_POSITION 20

#define RIGHT_PROBE_BED_POSITION    160
#define BACK_PROBE_BED_POSITION     160
#define FRONT_PROBE_BED_POSITION    20

Then you need to reflash the firmware and calibrate again.

Comment has been deleted