Loading

Cura 2.4 does not connect to printer

Please Login to Comment

I have been fighting this problem for several days. I have 2 computers in my printing area/shop.
One is 32 bit win 7 home and a just loaded up Win 7 pro 64 bit. I have been printing successfully on my Anet A8 with the 32 bit computer via usb. I added the 64 bit machine as many of the newer CAD/CAM and printing programs are 64 bit only...
The 64 bit machine, running Cura 2.4, does not connect to the printer via usb. Cura 14.07 and 15.04.6 do not connect via usb either...All 3 say printer not connected. I get the audio 'boing' when I plug in the usb cable for the printer, and can see it in device manager, and have set the comm port to 115000. I have installed the CH340 drivers. HELP!
FWIW, I did have Avast antivirus installed, but that was wrecking havoc with the usb wireless, so I have uninstalled it. Wireless connection is stable and reliable now. I thought Avast may have been 'shielding' the printer connection, but that is not the case.
While troubleshooting the weirdness, I tried printing from the SD card, but somehow, the hot end contacted the glass on the printbead and screwed up leveling, so I'll be working on that while I wait for hopefully an answer to the above issues...

Comment has been deleted

You can set baudrate, go to Device manager-Port com (LPT)- right click the connecting com (mine is com 5)- , select property- port setting and then insure the proper baud rate, 8 bits, 1 stop, no parity, no flow control.

Sorry, I didn't remember at first what I did ;-) So here comes the solution.
Edit file C:\Program Files\Cura 2.5\plugins\USBPrinting\USBPrinterOutputDeviceManager.py (or wherever you installed it) and change as follows.
See marks <--- below

Line 83:

def _updateThread(self):
while self._check_updates:
result = self.getSerialPortList(only_list_usb = False) <----------
self._addRemovePorts(result)
time.sleep(5)

Line 254:

def getSerialPortList(self, only_list_usb = False):
base_list = []
if platform.system() == "Windows":
import winreg # type: ignore @UnresolvedImport
try:
key = winreg.OpenKey(winreg.HKEY_LOCAL_MACHINE,"HARDWARE\DEVICEMAP\SERIALCOMM")
i = 0
while True:
values = winreg.EnumValue(key, i)
if not only_list_usb or "USBSER" or "VCP" in values[0]: <----
base_list += [values[1]]
i += 1
except Exception as e:
pass
else:
if only_list_usb:
base_list = base_list + glob.glob("/dev/ttyUSB") + glob.glob("/dev/ttyACM") + glob.glob("/dev/cu.usb") + glob.glob("/dev/tty.wchusb") + glob.glob("/dev/cu.wchusb")
base_list = filter(lambda s: "Bluetooth" not in s, base_list) # Filter because mac sometimes puts them in the list
else:
base_list = base_list + glob.glob("/dev/ttyUSB
") + glob.glob("/dev/ttyACM") + glob.glob("/dev/cu.") + glob.glob("/dev/tty.usb") + glob.glob("/dev/tty.wchusb") + glob.glob("/dev/cu.wchusb") + glob.glob("/dev/rfcomm") + glob.glob("/dev/serial/by-id/*")
return list(base_list)

This fix still works in Cura 4.8 but you only need to change one line.
Open the following file using Notepad++ or any Python code editor :
C:\Program Files\Ultimaker Cura 4.8.0\plugins\USBPrinting\USBPrinterOutputDeviceManager.py
Find this line :
def getSerialPortList(self, only_list_usb = True):
and change it to :
def getSerialPortList(self, only_list_usb = False):
Save the file and relaunch Cura.

I managed to get Cura to control a RAMPS board with an HC-05 / HC-06 bluetooth module.
Thanks to Celphor for the original fix.

If I recall, I saw a posting that the Cura 2.3 version doesn't have a way for users to set the baud rate and it's designed to automatically set the baud by sending a gcode that the Ultamaker line of printers will send a response to. In other words it query's the printer at different baud rates until it receives a valid response.

The person from Ultamaker said that they may bring back the manual setup feature in future revisions. I have version 2.5 and they haven't brought it back yet.

I think that this is a python add-in and could be modified to use gcode other printers would recognize or to just set the baud rate to 115200 but I don't know how to do that.

Just to clarify, I am a retired computer tech. The 64 bit machine in question has a new, clean reinstall of Win7 Pro 64 bit. I have tried Cura 14.07, 15.04, 2.5, 2.4 and the 2.6 beta. None of these versions recognize/connect to the printer. The computer itself does show the printer in device manager under ports.
My 32 bit machine with Cura 14.07 connects fine.

Have you tried to connect with putty? Simply open a serial connection and look if it works there. If yes, it's not a Cura problem...

That is strange as most computers have a 64 bit operating system nowadays. I have no problem connecting Cura 2.5 (64 bit) to the Ultimaker 3e or the A8 with my 64 bit Windows 10. Somehow you must have missed some sort of setting.

The comm port should be configured to 115200, that is what the software will be expecting.

It is. Machine sees printer, Cura does not. works fine on 32 bit machine with Cura 14.07, so using that until I figure it out...

It has to be something to do with usb on the 64 bit box. I am stumped on this one. Been trying to find a bios update for it, but no luck.

You could install RealTerm and look if the connection to the actually works and then select the working parameters in Cura instead of the AUTO settings.

Try 2.6 beta, I couldn't get 2.4 to connect either.

Cura 2.4 uninstalled, downloading 2.6 beta... But, why didn't 14.07 or 15.04 work on the same machine?