Loading

A8 won't mount SD card

Please Login to Comment

I've been trying to get my new printer working. Everything else seems fine, but I don't get the print file option.
I tried selecting SD card -> Mount card, but all I get is a slight whirring from the fans.

Before this I had the stock PSU die on me. I wired an ATX PSU on it's place. Idk if that might have damaged the motherboard or something..

Any ideas?

EDIT: Well, I messaged the company I bought the printer from and they agreed to send me a new motherboard.

I'm was having the same problem with my standard A8, mine has been printing fine for over 3 years and all of the sudden kills the SD card and will not mount any other, i've tried the box set SD card, a 32gb and a 64gb with the same files and none mounted. I've read in the reddit forum that the problem might be a solder joint issue, that may have cracked. https://www.reddit.com/r/AnetA8/comments/6q6od6/sd_card_wont_mount/

But in a reprap forum is said it could be dirt/dust collection in the slot or contacts, try blowing air into the slot, if not that doesn't work, and this is a last resort option, try inserting and ejecting an SD card several times, this worked fine for me but i'm suspicious the SD card slot has lost 50% of its remaining life in the process.https://reprap.org/forum/read.php?406,714699
Don't try shoving non-SD cards objects into the slot, there is the risk of bending one or more of the pins out of alignment and that is game over, new board.
Cheers.

I have the exact same problem, would you care sharing the contact of the company ? I tried the e-mail address on their official website (anet at anet3d.com) but it didn't work, I got a delivery error on gmail

I bought mine from gearbest and used their support center..

I'm a complete novice.
I've built the printer, but cannot get it to print any of the test prints from the SD card. I'm also struggling to link my mac to the printer - although I have downloaded Cura ok. Are there any foolproof simple videos / instructions to help me get started?

Surprisingly there's no tutorials online that I know of. I run windows, but I would imagine you need to install a driver too.
Another thing to make sure is that you're running a version of Cura that supports USB printing. I found out they discontinued the USB support at some point, so I'm running 15.04 on windows.

I think you might need some serial USB drivers for Mac. Did you check in the "software" folder of your SDcard ?

I've installed ch34x from the SD card. Is that ok?

A bit late with info....and I am guessing you have got up and running....if not...install Repetier Host...ignore the request for a donation if you wish...the link is lower down the page. You have installed the driver do it should fire up OK. You can use this with your A8 using Usb....but turn off and energy saving and make sure the Mac will stay awake or the print will fail. You can mount and unmount your Szd card and add or remove files ding the computer connection. Check out youtube for tutorials.

I just finished my A8 a few days ago. My SDcard was pretty much dead on arrival too.

I could barely copy the assembly documentation on it. I tried formatting it, no improvement whatsoever. I then tried again formatting it but with my own card reader, no luck. I ended up using my own SDcard ans shortly after going for USB.

Forget the SDcard, and go for USB ! Or buy a good SDcard because the one included is aweful.

I wouldn't recommend USB at all. Many issues may happen. I'd use a SD card or if you want to print remotely set up Octoprint.

I would choose USB other a poor quality/corrupted SDcard anytime. By all means if you have a good SDcard use it.

But otherwise if the default SDcard is like mine and unmounts randomly which seems to be the case for OP, I say use USB. Plus USB also means using a raspberry pie as a printing host which seems rather reliable from what I have been reading online.

The stock SD card didn't work for me as well. It doesn't get recognized.
But in general a SD card is the safer option over a USB connection.

I have the same problem. But after mount from the box, i plug the sd card for my first print and it doesn't read this. I flashed skynet and nothing, and my two pcs (windows 10) with cura doesn't print: i have a printer and i can't print! Can someone help me please!

In never got the SD to work, but I managed to get it printing through USB and Cura (15, I think). I sent a message to the company I bought the printer from and they agreed to send me a new motherboard. That should hopefully work.

Edit: Cura 15.04 supports USB printing

I had same issue, flashed firmware to Marlin and issue went away. I sort of do like more menu option on the stock firmware. My SD card originally worked and then just stopped recognizing for no reason. Give the onboard reset button a try.

The onboard reset button doesn't help. I can hear the motherboard trying to read the SD (the fans run audibly faster for a second when the card is in) whenever it boots, but no luck yet.

You need to 'unmounted' the previous card before you 'mount' the newly inserted one.
Stick in your SD card, hit 'unmount' first, THEN mount. You should now see the .stl files.
You'll need to do this every time, to clear the previous SD file list in order to see the one you just plugged in.

There's no unmount option available. The SD card hasn't worked once...

If I was stuck with your predicament I would connect my printer via USB using Cura 15 or any other slicer that will make a connection and see if it prints. This way you will be able to ascertain whether it is a SD card issue or a board issue.

Ok, that's another problem then. I can't seem to figure out how to get Cura to recognize this printer
Edit: just needed a driver and cura 15.04

Download an up-to-date version of Cura, not the one from the SD card.

I tried the newest one, but it didn't seem to support USB. An older version worked for me.

It works fine with the latest stable version of CURA over USB. I just installed the USB driver that was on the SDcard and restarted my computer and it recognized the printer immediately.