Loading

[SOLVED] Anet A8 Resetting itself upon Pre-heating/ Starting a p

Please Login to Comment

Hi all I've searched hi and low for a solution to my problem so apologies if this has already been an issue.

I'm new to 3D printing and having never owned one I though it best to buy a kit and build it to learn it so to speak. Everything went fine in the build and I ran into no issues at all, powered on fine and still powers on fine.

However, when I try to start a print or even pre-heat the PLA, the LCD screen flickers quickly and resets back to the "Welcome to Anet A8" Splash screen, the boots into the idle screen.

I've had the multi-meter out and checked for continuity in what I think is the appropriate places but alas I cannot find a reason for why it's resetting. If anyone could point me in the right direction I would be most great full.

I've had no issues leveling the bed (that I know of) and all the axis home fine when I tell it to.

Wiring:
http://imgur.com/a/ubthP
http://imgur.com/a/bGWbd
http://imgur.com/a/zKsS3
http://imgur.com/a/L90Vz
http://imgur.com/a/pn8rH

Cheers.

Edit: I've just cut off the two pin plug and tried using a standard British plug on the end and the problem still persists.

Edit: I've just flashed it to see if it was a firmware issue using SkynetV2.3.2 and the problem still persists.

Edit: The issue has finally been solved and it was thanks to user tsisante00. The power supply was faulty and was voltage sagging like crazy when I pressed print. I purchased this from Amazon:

https://www.amazon.co.uk/dp/B072M7P7QJ/ref=cm_sw_r_cp_apap_ESbgWWFkRq4sY

The printer fired up first time and began heating up when I told it to, so tonight I will finally get a print going. Thanks to everyone here for their input, it was invaluable in learning my new tool.

ik this is an old form but i am having the exact same problem even after upgrading to a beafy 30A 12V power supply. help!

Although this post may be right for some it was not the case for me. I just wanted to let everyone know that I had this exact problem and it was the main board that had fried. The power in to be exact. I did change the power supply to start with but the problem persisted after that I changed the board with another a8 I have and when taking off the board there was a small burn where the 12v goes in. It couldn't pull enough power to heat up but could to power the screen. It was an original board that was a few years old. Ordered a new board and now all of my printers are back up.

I had the same problem , but in my case for some reason the problem was the 20A fuse that is on the positive wire from the PSU to the mainboard , for some reason it wasnt blown but was causing the problem, I changed it after testing everything else ( exept getting a new PSU , still plan too soon but still) and for my very big surprise it worked.

I think I may have found the solution to our rebooting problem during preheat. It appears that there may have been a batch of defective PSU's when set to 110v setting. I found the write up on another forum below:
Http://shop.prusa3d.com/forum/prusa-i3-kit-building-calibrating-first-print-main-f6/heated-bed-causing-system-reboot-t2622-s20.html
I ordered myself a replacement PSU since the vendor was taking too long to research the problem we were having. The forum indicates that the heat elements, I.e heater bed, nozzle, were not the cause of our issues but the inability of our PSU to sustain the required juice to power up the heaters.
I'm asking the electronics experts in this forum as to what could be wrong within our PSU itself, i.e. Capacitors perhaps, etc. to fix it in order to salvage the PSU we have.

Oh thanks for the link! I have ordered a new PSU from Amazon and will be arriving tomorrow, I'll report back tomorrow and let you know once I have fitted it :)

Having the same exact problem with my printer. Did you ever find a solution?

Hi, I'm afraid I haven't yet. I've been in touch with Gearbest.com where I purchased the printer from and they have agreed to send me a new board so I'm currently waiting on it's arrival. Once I have tested it I will report back to here and let you know.

This is the board they are sending me:
https://www.gearbest.com/3d-printer-parts/pp_540286.html

So I've just flashed it to see if it was a firmware issue using SkynetV2.3.2 and the problem still persists. I'm at a loss now :P

Its pretty normal for the A8 to reset itself once in a while, although if its keeping you from absolutely printing anything after its been powered off for a few seconds, then something is wrong. Mine sometimes just keeps resetting every time I send a command to it but its fixed by shutting off all the power. If you are using usb to print with then make sure you dont have any other program other than the slicer open (for now) since the A8 could possibly reset even in the middle of a print if another program sucks up all your computers resources (like antivirus software).

I would try flashing the A8s firmware again (maybe just maybe something is wrong with the one you have right now). You could put Skynet on to it and I believe Skynet includes the original A8s firmware also.

I've just tried flashing firmware using SkynetV2.3.2 which successfully flashed, but hasn't solved the problem the behaviour is still the same which is leading back to believing it is a hardware issue. I'm printing from SD and havent tried from USB as I need to move my desk around (I'm lazy) But as of yet I havent managed to print anything at all, been working trying to fix this for 5 days now :( But I will get there!

Take the SD card out .....unmount to do this....turn the printer off for about 30 seconds...( drains anything in the capaicitors) turn on.....do a reset.
But while it's off....fe Ove the flat cable to the LCD readout and make sure it's reinserted correctly...ditto the same cable on the motherboard in the top right side slot. Do a home all...?then insert and remount the SD card....if you are not using the SD card...alloy the above to the USB cable. At this point you in effect back to first ever start up. I have had three motherboards and each had " exentricities" ! Now set up a print and start the print.....if all is working ok....you can turn off and cancel the print. I use the Anet chess piece...their gCode...as my test piece. If you canceled home all and then try your reset.....and let us know the results :)

I have tried this and I'm sorry to say this didn't do anything to remedy the issue, but thanks for the response.

check the PSU should be 12v

The voltage at the board is 12.58V and the same at the PSU output.

Just a shot in the dark, make sure your LCD connector is plugged in all the way. Mine acted funny because it was loose on the back of the display itself. My fault for not pushing it into the header all the way.

I've been back over the connections this morning and haven't found anything loose or shorting anything.

Sounds like you are having a problem with the power, either you aren't getting enough or it is not getting to your mainboard with enough power to keep everything running. Check all you wired connections to make sure they are secure, and maybe try a different power outlet? I personally haven't run into this problem but I've been seeing a lot of it in this group lately, give and update when you find the problem!

I've just tried a different power outlet and still have the same problem. I've wired a standard British plug on it this morning instead of using the two pin one and an adapter which it ships with.

Are you printing from the SD card and/or is it hooked up to a computer? I'm assuming you had ~12v at the board?

Printing from SD card yes, and yes 12.5V at the PSU output and at the board, when the machine resets itself, the voltage drops to around 12.2V.

All problems are coming from PSU . Plz replace it and buy a PSU of 12v 30A or 40A.