Loading

Autolevel with marlin crash

Please Login to Comment

Have my A8 running Marlin, and all is well and good. Configured for bilinear bed leveling. Most of the time, it runs perfect, However, sometimes it will be in the middle of the G29, and not at the same point, the head will just keep heading down. you can see the light in the sensor come on, but it keeps going. have to power it off to stop it. When I power it back up, I relevel the X, relevel the bed, redo the Z offset, and all is fine. It may do it the next part, or not until after 5 or 6 more.
Running Octoprint on a Pi 3
Sensor is the 18mm inductive.
Firmware is Marlin from the Skynet github, 1.1.3 (Latest there). I have even re-pulled the firmware, re-compiled and re-flashed the board.
Any ideas?

I have same problem! Today the sensor was making the levelling routine and for some reason failed last making a hole in the magnetic mat. The trigger light went on but nozzle hit the bed anyway! What solution did you find?

I upgraded to Marlin 1.1.9 and haven't had the issue since

Oh my goodness, I'm running Marlin 1.1.6 and I have this issue!!!! Most of the time it's great without issues. Sometimes my auto leveling sensor triggers (light on) but the nozzle keeps heading into the bed, warping it LOL.

I thought I was the only one!!!!!!!!!!!!!!!

I had initially assumed because I'm running a 6v sensor off of 5v. I'm using a 12mm inductive sensor. Are you using proper voltages for yours?

mine is the 6-36V 18mm sensor. Running it off 12v with the 5v zener diode across the signal output

Thanks Guys! Will load that this afternoon!

As olehs said go to the latest official Marlin. I used Skynet and got (only a few) random bed crashes during the bed levelling phase, never had one since going to the newer Marlin.

Had to convert the old configuration.h with "Marlin3dprintertool". now it fails execution at:

In file included from /home/pi/marlintool/build/sketch/pins.h:61:0,
from /home/pi/marlintool/build/sketch/MarlinConfig.h:34,
from /home/pi/marlintool/Marlin/Marlin/Marlin.ino:31:
pins_RAMPS.h:48: error: #error "Oops! Make sure you have 'Arduino Mega' selected from the 'Tools -> Boards' menu."

error "Oops! Make sure you have 'Arduino Mega' selected from the 'Tools -> Boards' menu."

^

exit status 1
this is with compiling (./marlintool.sh -v) on the pi.
Any suggestions?

found a fudge in the Configuration.h file...
Now, having the stock LCD display, it says to use "Zonestar LCD".
When I enable that and compile, I get this:

/home/pi/marlintool/arduino/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld: ./build/Marlin.ino.elf section .text' will not fit in regiontext'
/home/pi/marlintool/arduino/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld: region `text' overflowed by 4382 bytes
collect2: error: ld returned 1 exit status
Using library LiquidCrystal at version 1.0.7 in folder: /home/pi/marlintool/arduino/libraries/LiquidCrystal
exit status 1

Think I can live for a bit without the display... anyone else having this issue with Marlin 1.1.7 on the Anet board?

Nevermind... it was running out of program space... Disabled the SD card support and now compiles and runs fine