Loading

AnetA8 Stock MainBoard v1.5 to MARLIN upgrade

Mainboard marlin_firmware

Please Login to Comment

Hi;
I have had my Anet A8 for a year now and have just started to install an E3D V6 Hot End and Titan Bowden Extruder (TriangleLabs Copies). I have also purchased with these a BL Touch Sensor.
I have been looking at some upgrade blogs and would like to upgrade the software to MARLIN (I think I need to anyway for the Sensor).

After searching for some info on upgrading to MARLIN I found this video tutorial:
https://www.youtube.com/watch?v=5xeo9G3kXEQ
Seemed like an easy task until I started looking into it a bit more and it seems that for people (like me) with v1.5 board, it is a little bit trickier and may need some additional parts?

The link regarding these issues does not seem to provide a clear solution, so my question is this. Can anyone provide me with a decent guide on installing the latest MARLIN on the v1.5 mainboard?

Many thanks

Installing Marlin is a piece of cake on that board. Just take care not too select all options in Marlin because the stock mainboard cpu has not enough space for a large firmware file. It will corrupt the bootloader if you exceed +- 125000bytes.
For connecting a BL touch, you will need to cut one of the wires of the stock LCD or to solder a wire direct on the mainboard. At least, this worked for me. This link helps: https://www.youtube.com/watch?v=6aofhlAooUE

Go on this youtube channel
https://www.youtube.com/user/Conesbbkg
Called Nexi
I've followed and learned a lot from him when I started.

Well I have been following a couple of guides and think I have managed to burn a Bootloader to the Anet Mainboard using an Arduino UNO, but now I cannot upload the MARLIN firmware. I tried doing it the same way as the BootLoader using an Arduino UNO and also by connecting my Macbook directly to the Anet via its USB connector.
So I now have an Anet that does not work.
Any help would be great.

Here are the guides I been using:
https://www.instructables.com/id/HOW-TO-FIX-ANET-BRICKED-BOARD-USING-AN-ARDUINO-UNO/
http://www.vslcreations.com/2018/08/how-to-upgrade-anet-a8a6-3d-printer.html

When I flashed all I had to do was install the Arduino IDE and plug into it via USB then it came up in my Arduino IDE.. I can no longer offer support because this seems to have gone far from the normal path. Why are you burning bootloaders it comes with?

Did you get the Arduino IDE from official sources? https://www.arduino.cc/en/Main/Software

Did you get the special drivers for mac because they suck and nothing works right? https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

Did you follow the directions to install the Anet board def in arduino? https://github.com/SkyNet3D/anet-board

Also you should look at Skynet for stock Anet board : https://github.com/thijsk/Skynet3d

At this point it might be easier to replace your board seeing as we don't know what bootloader you flashed onto it.

Looks like the Bootloader flashed OK. And once I installed the Mac and have just successfully uploaded MARLIN :-)

Now to find a guide on using and customising MARLIN for my setup :-)

Thanks for all your help on here guys. Great stuff.

Link incoming, if you read my guides and need additional help let me know.

These are all my own design and I wrote the guides. There's nothing really changed between the 1.4, 1.5, and 1.6 boards excet the 1.5 and 1.6 use surface mount components that offer better cooling. I have 3 Printers, and all 3 RAMPS boards between them. The biggest issue is the chinese all in one boards use JST connectors on the wires and RAMPS uses Dupont style like other Arduino products. You can buy new wires and stuff cheap or do what I did and buy connectors and crimpers.

How To Wire a RAMPS 1.x
Marlin 1.1.x or 2.x on Anet A8 Guide
Lion Mount Front BLTouch Sensor Bowden Carriage for Anet A8 & Prusa i3!
Raspberry Pi 2 & 3 Case with Many Fan Options / No Fan and Space for Wires! Octoprint Ready!
Bowden Inlet Tube Filiment Guide 8mm Mount