Loading

Layershits...

Help

Please Login to Comment

I am trying to upgrade Anet A8 to a new board, BTT SKR 1.4 Turbo with TMC2209. I have tried both UART and stand alone mode, and still get the same shitty result.
I have followed different guides, i have tune my steppers, It worked good with the old original Anet board, so its no hardware fault. Could it be something in my Marlin code that fails???

I don't mean to ask the obvious stupid question, but have you made sure your pulleys are tight to the stepper shafts. Your speed is nominal for the Anet A8, so I don't think it is a speed issue. I had this issue once, and after pulling out lots of hair and practically eliminating my fingernails, I found a loose pulley.....
Just askin...

Comment has been deleted

I had a pita problem with random skipped steps for a long time. I eventually found it was just a bad motor wire dupont connector on the ramps, but went through a bunch of different driver boards and troubleshooting steps before I found the problem wire.

However, those are some crazy looking missed steps. Usually it's not so organic, twisty, and flowing like that... more often they look like otherwise normal prints but like someone sliced it horizontally with a sword here and there, leaving upper layers displaced relative to lowers, but otherwise OK. Your printer is acting like it's shifting linearly as it goes up... can't explain that with anything I understand TBH... other than some g-code tom fullery, some oddly functional/damaged micro controllers, somehow coasting between layers...?

I thing this is what causing it my layershifts... Junk TMC steppdrivers... I hope i get new ones this or next week from BIGTREETECH

https://youtu.be/fkH-u1QMGfs

Comment has been deleted

Wow, damn... Looks like it's skipping steps. Should be in UART mode with current about 600 16 microsteps and define HYBRID_THRESHOLD enabled at about 45... Try that.

There's also my guide on the subject and the Morninglion Industries Discord Server with a bunch of us hanging out arguing over the same things, if you wanna get some quicker help.

SKR 1.3 or 1.4 & MKS SGEN L Board Setup Tutorial with TMC2208 UART

thank you for the help. but unfortingly it didnt help.. it still look the same. ;(

Whats the speed you're trying to run at? It's definitely missing steps. Also on Marlin's website "Nightly Bugfix" is NOT production, so if you downloaded that build you likely have a bug, that needs fixed.

Speed about 35mm/s, with original board i got as high as 85mm/s

Maybe I should try an older version of Marlin, or try nightly build. Could it be something wrong with My SKR?

Avoid the nighty builds, but the new Marlin works fine on all my machines, however they are different. I dont have any machines with belts.

That speed should be fine, is the machine binding? Do you hear any skipped steps, like popping or clicking sounds?

No sound at all... The tmc2209 works very well, and the printer head and bed runs very smooth. It all started when i changed to skr and stepdrivers... As I said before, the printer worked well berofe the boad change, but it was very noisy.

Can you get on discord? I can try to compile a test marlin for you when I'm off work later

Absolutly. I may have found a sollution....https://youtu.be/fkH-u1QMGfs

New steppers ariving tomorrow. But i Will login on discord a Little later.

Wow replacing the motors? I'm curious never had a motor outright die but did have a bearing in one locking up making it skip but you could hear it making those skipping sounds. Tried to watch the video but not into jt
You'll have to let me know what his solution is

Sorry, not the motors, the step drivers.. tmc2209. Probably cheap junk i ordered from Amazon... I Think i get better ones tomorrow, I let you know.