Loading

Pinned

STICKY

by BETLOG

General information collated into the most often asked questions and answers.
NOT an official Anycubic-operated forum; just customers discussing their machines.



View Comment

Anycubic Mega random freezes - denouement

by supik

Hi,
Here I write topic about my printer.
https://www.thingiverse.com/groups/anycubic-i3-mega/forums/general/topic:54802

After disconnecting SDCard reader, and understandig the printer without reader do not operate, I contact Anycubic support and decsribed my problem. They agreed, the problem is probably in reader, and send me link to order new.

After few days I will still sad, but assembly printer to original state. I try after that print small model (18 mins) and .. printer works.
I try print more then ten models from this time ( yesterday I print over 5 hours) and all models were finished...

In the meantime, I received a package from Anycubic, but reader lies in a drawer..

I do not understand where was problem ( original reader was connected firmly ). Maybe in the future problem occurs again.
Maybe this will help other peoples.
Bye :)

View Comment

A4988 VREF

by Jellybean57

I got asked to take a look at a Mega Pro for my local library (no upgrades), what is the recommended VREF for the stock A4988 stepper drivers? The extruder motor vibrates but does not turn, even with a replacement motor from Anycubic. Thanks

View Comment

Is it normal to need to re-level the bed after every print?

by Caedo

If I level the bed afresh before printing, then I always get a good print. If I don't level the bed, then the print will always fail on the first layer. Time between prints doesn't matter. iI can be two minutes, or several days. If I don't re-level the bed, the print will always fail.

View Comment

Some files on SD card not recognised

by cannon3d

I started recently to see more and more often that some of the gcode files on my SD card (and tried several) are not recognised, or at least not displayed in the 'Print' menu of my AI3MU. If I insert the SD card into my Macbook I can list the files, and their contents look fine. Tried several versions of Cura as well. Any thoughts?

Anycubic_I3_Mega sd_card
View Comment

Burnt hotend heater cable and PCB slot plug. What to do?

by Mckinky

Hello everyone.
I started a print today and almost immediately noticed a burnt smell as the hotend was heating up. I quickly turned off the printer and saw the PCB slot had browned. As you can see on the first 3 pictures, the white cable is browned and burned in both ends and has taken the PCB plug with it. The other wire for the hotend heater does not seem to be affected, as that side or cable is not burnt. The motherboard electricity cable for the heater does not seem to be affected aswell as you can see on the fourth picture.
Is this just a bad wire that needs changing or is there more to this, and if so, is there anything I can do to hopefully prevent this again?

Best regards mckinky

View Comment

Definitive TMC2208 Vref settings

by cannon3d

I've upgraded my Anycubic I3 Mega (Trigorilla) "S" to the TMC2208 drivers. I've found on forums various guidelines for the reference voltages: 0.85V, 1.06V, 1.2V, with someone saying 1.5V needed on E0.

After installing the TMC2208's and with the motors removed, I've checked the reference voltages and found them to be (X,Y,Z,E0, E1)= (1.11, 1.11, 1.09, 1.18, 1.11)V and left them like that.

Now, when fast extrusion or retraction occurs, there's a nasty noise from my extruder motor. Can it be that 1.18V is too low for E0?

Note that I have the newer/upgraded "S" extruder from Anycubic.

Is there any generally agreed opinion on what the Vref's should be for TMC2208's in Anycubic I3 Mega (Trigorilla)?

View Comment

FIRMWARE

by BETLOG

Thread to document and discuss the various i3 mega's firmware.

This thread will almost certainly occasionally overlap with the HARDWARE thread:
https://www.thingiverse.com/groups/anycubic-i3-mega/topic:26118


Marlin 1.1.6 with original Anycubic i3 Mega display support
https://www.thingiverse.com/groups/anycubic-i3-mega/forums/general/topic:25471

Official firmware release
https://github.com/ANYCUBIC-3D/I3-MEGA/tree/master/Marlin_TFT_CR_V1.1.1
Usefulness unverified.

Everything else under this line was written before functional firmware was available, so is likely to be incorrect.





"I just got my printer and I want to flash the firmware to be sure it's the latest"
No. Flashing the i3 mega is not as easy as it should be. Just go and print stuff.

Why?

  • YES. The official sourcecode is "available" and you can modify it.

    • However simple things like the age of the files means that syntax will conflict with newer IDE's. Simple anomalies like trigorilla.h being referenced when the file is actually called Trigorilla.h (uppercase/lowercase discrepancy), and Configuration.h still using the standard LCD2004 (REPRAP_DISCOUNT_SMART_CONTROLLER) do not inspire confidence that it is actually the source. It almost certainly is not, but rather a hobbled-together collection of old code from previous printers that omits any reference to the i3 megas TFT.
    • Unofficial sourcecode is available. See note #1 at bottom
  • NO. The official source will not compile as-is.

    • It will give variable name errors unless you
    • 1) use the old Arduino IDE (at the time of writing this may no longer be possible)
    • or 2) you make some copy/paste edits to the source code to update the variable names to the new IDE requirements.
    • or 3) Manually go through a copy of the new code and intelligently insert values relevant from the old code, or that you know to be correct. This method is not difficult, but it does require an understanding of what you are doing. Comparing the 'official' mega sourcecode from Configuration.h against the new Marlin Configuration.h will help you to begin understanding.
  • YES. A compiled .hex is available for the i3 mega and i3 ultrabase.

    • So if you should manage to kill your firmware you "should* be able to reflash it from the pre-compiled hex.
    • One of these .hex files includes the dual z-endstop modification. So if your levels are always mysteriously wrong, and nozzle crashing into he bed on first print of the day, then you should consider this.
  • NO. We do not have access to the firmware for the touchscreen. (which is separate to the printer firmware)

    • In theory you can modify Marlin and not alter the touchscreen at all. However there is no known option for the anycubic TFT in marlin firmware, so you therefore cannot select a compatible display option in marlin, and therefore eithe rlose the display entirely, or need to (physically and in firmware) substitute another known display type.
    • REQUEST: Someone please try all of the other available Marlin options for LCD screens, to test if the anycubic screen is in any way functional under a similar driver.
  • YES. You can use a LCD2004 or 12864, or any commercial TFT like the MKS32

  • YES. If you are working on accessing or reverse engineering the TFT operations then you are our hero and we love you. Please keep us updated on any progress or task delegation requests.

  • NOTE: Anycubic seem to neglect to adjust the version number on their hex releases, so don't be surprised if the 'new' hex you flash has the same version number as the original one.
    • The above assumption needs confirmation, but I have seen it mentioned a couple of times now, so to the best of my knowledge it is correct.
    • REQUEST: Someome please test and confirm:
    • hex [list it's filename and where it came from]
    • has what purpose [list it's supposed functionality ie: dual-z-sensor, ultrabase version, original inductive sensor version, etc]
    • displays what version numbers

RELEVANT RESEARCH:
Bought to my attention by Matej Zubčić on Facebook:
https://github.com/DIYElectronicsZA/Anycubic_i3_Mega?files=1


Basic firmware info:


Anycubic
official:
http://www.anycubic3d.com/en/col.jsp?id=158&fref=gc
https://drive.google.com/drive/folders/0B8VIB533cgdMMmJyb3hTNThuZFU
https://github.com/ANYCUBIC-3D/I3-MEGA

pkochubey's host of the hex:
https://yadi.sk/d/k95QGu9O3JXuk6

Arduino IDE (compile the sourcecode and upload the hex to printer):
https://www.arduino.cc/en/Guide/HomePage

  • How do I compile sourcecode:

    • get the Arduino IDE
    • get the source code (but becasue there is no really definitive package, and you will have to edit whatever you get anyway, you may as well just get the latest Marlin source and - using logic - modify it to be similar to whatever source code appears to be most like the i3 mega. The previous 'anycubic prusa i3' model's soure is probably most appropriate and available.
    • open the .ino file found within the source code with Arduino IDE
    • plug your computer into your arduino board via USB
    • check that the iDE is set to a mega 2560 type board
    • check that the iDE is set to the correct com port (the printer wil appear as one when it's connected)
    • Ctrl U
  • How do I decompile/edit the .hex? :
    • You don't.

NOTES:

  • 1 : If you know how to modify firmware code, and are prepared to use your brain to figure out if this is entirely appropriate or not there is this:
    https://github.com/duisenberg/AnyCubic-I3/tree/master/Firmware
    The standard machine does not use one driver for the two Z nemas - so there are some obvious modifications, but this source is likely to be about as close to standard with improvements as any.
View Comment

TO sensor abnormal

by sd2017

Just bought my i3 Mega and assembled it. When i switched it on i got "TO sensor abnormal". book says check plug on hot end which I've done. Any other suggestions?

View Comment