General information collated into the most often asked questions and answers.
NOT an official Anycubic-operated forum; just customers discussing their machines.

View Comment

Strange pattern on bottom layers

by cannon3d

Lately, I see a strange pattern on bottom print layers (please see attached photo). Any idea why this happens?

View Comment

i3 mega seeing card but not seeing files

by cam2363

My mega sees that an sd card is inserted, but doesnt see any files on the card.

I tried:
Formatting card
having only 1 file on
changing to a different card
restarting it
Re seating sd card cable

and I get nothing. It was working earlier today, but it just quit seeing files. Any ideas or thing to check?

View Comment

Definitive TMC2208 Vref settings

by cannon3d

I've upgraded my Anycubic I3 Mega (Trigorilla) "S" to the TMC2208 drivers. I've found on forums various guidelines for the reference voltages: 0.85V, 1.06V, 1.2V, with someone saying 1.5V needed on E0.

After installing the TMC2208's and with the motors removed, I've checked the reference voltages and found them to be (X,Y,Z,E0, E1)= (1.11, 1.11, 1.09, 1.18, 1.11)V and left them like that.

Now, when fast extrusion or retraction occurs, there's a nasty noise from my extruder motor. Can it be that 1.18V is too low for E0?

Note that I have the newer/upgraded "S" extruder from Anycubic.

Is there any generally agreed opinion on what the Vref's should be for TMC2208's in Anycubic I3 Mega (Trigorilla)?

View Comment

TO sensor abnormal

by sd2017

Just bought my i3 Mega and assembled it. When i switched it on i got "TO sensor abnormal". book says check plug on hot end which I've done. Any other suggestions?

View Comment

Issues with linear advance on my i3 Mega

by AxlNam

Hey Guys,

since few days I try to run Linear Advance on my printer. I have Marlin 2.1.X with TMC2208 (FW from Knutwurst)
It works so far but after the first print all other prints will be not completed due to the extruder stepper is stop working.
I restart the print and after a few layer the extruder stepper stop working again.
All other stepper working normal?

In most cases I need to reset the FW and turn off the printer for a restart. The only chance to get a complete print.

I like linear advance but do not understand this issue. Is this happen because my eeprom is full
I also had replaced the driver but result is the same. The motherboard is like new (trigorilla v0.02)

May there is a hint what goes wrong.
thank you.

View Comment



Thread to document and discuss the various i3 mega's firmware.

This thread will almost certainly occasionally overlap with the HARDWARE thread:

Marlin 1.1.6 with original Anycubic i3 Mega display support

Official firmware release
Usefulness unverified.

Everything else under this line was written before functional firmware was available, so is likely to be incorrect.

"I just got my printer and I want to flash the firmware to be sure it's the latest"
No. Flashing the i3 mega is not as easy as it should be. Just go and print stuff.


  • YES. The official sourcecode is "available" and you can modify it.

    • However simple things like the age of the files means that syntax will conflict with newer IDE's. Simple anomalies like trigorilla.h being referenced when the file is actually called Trigorilla.h (uppercase/lowercase discrepancy), and Configuration.h still using the standard LCD2004 (REPRAP_DISCOUNT_SMART_CONTROLLER) do not inspire confidence that it is actually the source. It almost certainly is not, but rather a hobbled-together collection of old code from previous printers that omits any reference to the i3 megas TFT.
    • Unofficial sourcecode is available. See note #1 at bottom
  • NO. The official source will not compile as-is.

    • It will give variable name errors unless you
    • 1) use the old Arduino IDE (at the time of writing this may no longer be possible)
    • or 2) you make some copy/paste edits to the source code to update the variable names to the new IDE requirements.
    • or 3) Manually go through a copy of the new code and intelligently insert values relevant from the old code, or that you know to be correct. This method is not difficult, but it does require an understanding of what you are doing. Comparing the 'official' mega sourcecode from Configuration.h against the new Marlin Configuration.h will help you to begin understanding.
  • YES. A compiled .hex is available for the i3 mega and i3 ultrabase.

    • So if you should manage to kill your firmware you "should* be able to reflash it from the pre-compiled hex.
    • One of these .hex files includes the dual z-endstop modification. So if your levels are always mysteriously wrong, and nozzle crashing into he bed on first print of the day, then you should consider this.
  • NO. We do not have access to the firmware for the touchscreen. (which is separate to the printer firmware)

    • In theory you can modify Marlin and not alter the touchscreen at all. However there is no known option for the anycubic TFT in marlin firmware, so you therefore cannot select a compatible display option in marlin, and therefore eithe rlose the display entirely, or need to (physically and in firmware) substitute another known display type.
    • REQUEST: Someone please try all of the other available Marlin options for LCD screens, to test if the anycubic screen is in any way functional under a similar driver.
  • YES. You can use a LCD2004 or 12864, or any commercial TFT like the MKS32

  • YES. If you are working on accessing or reverse engineering the TFT operations then you are our hero and we love you. Please keep us updated on any progress or task delegation requests.

  • NOTE: Anycubic seem to neglect to adjust the version number on their hex releases, so don't be surprised if the 'new' hex you flash has the same version number as the original one.
    • The above assumption needs confirmation, but I have seen it mentioned a couple of times now, so to the best of my knowledge it is correct.
    • REQUEST: Someome please test and confirm:
    • hex [list it's filename and where it came from]
    • has what purpose [list it's supposed functionality ie: dual-z-sensor, ultrabase version, original inductive sensor version, etc]
    • displays what version numbers

Bought to my attention by Matej Zubčić on Facebook:

Basic firmware info:

Anycubic official:

pkochubey's host of the hex:

Arduino IDE (compile the sourcecode and upload the hex to printer):

  • How do I compile sourcecode:

    • get the Arduino IDE
    • get the source code (but becasue there is no really definitive package, and you will have to edit whatever you get anyway, you may as well just get the latest Marlin source and - using logic - modify it to be similar to whatever source code appears to be most like the i3 mega. The previous 'anycubic prusa i3' model's soure is probably most appropriate and available.
    • open the .ino file found within the source code with Arduino IDE
    • plug your computer into your arduino board via USB
    • check that the iDE is set to a mega 2560 type board
    • check that the iDE is set to the correct com port (the printer wil appear as one when it's connected)
    • Ctrl U
  • How do I decompile/edit the .hex? :
    • You don't.


  • 1 : If you know how to modify firmware code, and are prepared to use your brain to figure out if this is entirely appropriate or not there is this:
    The standard machine does not use one driver for the two Z nemas - so there are some obvious modifications, but this source is likely to be about as close to standard with improvements as any.
View Comment

Printer stopped working when heating

by mpirklbauer

Hi at all.
I've a big problme.
When my printer starts to heat up the heatbed there is a "click" and it stopped working.
Does anyone else has/splved the same issue?
Is my board broken?

I checked all cables and connections, but can't find a fault.

Thank you.

View Comment

looking for a preset file for prusa slicer 2.5.0

by eternity575

looking for a preset for 0.4 head, for anycubic i3 mega that will work with the new slicer 2.5.0 from prusa. slic3er wont work for me anymore :(

View Comment

Mega S lower layers compressed

by Paradieshenne

Hi, after being frustrated by my i3 Mega S for the last 4 days and trying everything I found online, I no longer know what to do.

Anycubic i3 Mega S (bought in Dezember 2020, always didn't work properly, had no time and came back to it every few month)
Currently running Marlin (precompiled Knutwurst 1.4.4 DGUS version)
Connecting via OctoPrint to Cura (if that matters)

The first ever prints worked fine, after just a few more I didn't get anything usable. Back then I tried arround but didn't find a solution (nor the problem)
A year later, after I moved the printer, I could see across the plate when going up the stairs. The bed was completly warped (by millimeters in the middle).
Replaced the bed and at least got actual prints out of the printer, but never good enough to actually use the printer.
This weekend I finaly came arround to trying my luck with the printer again.
After the installation of Marlin and a mesh level, I finaly got usable results.
In the meantime (after two days of basically non-stop printing) the bowden tube gave up and, as I didn't know what was wrong at the time, I changed the hotend to the replacement one.

The problem thats persistent is that the first layers (~2mm) are much wider (and some times material is even squished out), above that point the print is totaly normal.
The print (20mm XYZ cube) is also ~0.5mm to short.
Whats weird about this is, that, above the defective region, the noozle is at the right height relative to the previous layer.
After doing the mesh calibration many times now, the only way I can get the first layer to be correct is to apply a huge Z offset in Cura, but for the following layers, the noozle just plows through the previous ones.
It is as if the Z axis doesn't lift as much as it is supposed to, but fine after a certain, consistent, height.
I've checked the worm screw and guiding rods for anything odd and also didn't feel a difference when turning the steppers by hand.

What is the next step to check? I don't know how to continue.

View Comment