Loading

Lots of problems with the i3 Mega

Please Login to Comment

Hi,

I bought a i3 Mega from Anycubic on aliexpress about 3 months ago. This is my first 3d printer.
When i got it it worked like a charm, perfect prints, no problem what so ever. Then after about 10 hours of printing the power button failed and there was no way to turn the printer off, just pul the plug was the only option. Contacted anicubic support and then the long list of mails started, at the end i received a new power button.
then a few hours of printing later the fan in the power supply made a sound if it is going to the moon like a rocket. contact Anycubic again, now 4 weeks later still emailing with them but still no new fan or power supply. The printer is working but have to wait a few minutes and then the noise stops and the fan is working.

but now the part where i need some help with. I contacted Anycubic but the mailing is just begone so that will take a few weeks I think.

first there is the temp problem. I start a print and all temps start to rise, first the bed and then the nozzle, so far so good. Then the printing starts and after a few layers the temp setting goes from 205 to 0 and the the fan cools the nozzle, the bed has no problem.
If i'm close to the printer I pause it and manually set the temp back to 205, and resume the print. When i'm not close the printer keeps on printing without filament because the nozzle is cold. hope some one knows what to do.

then there is the second problem. when I start a print all heats up and then the printer goes to home. then the printing starts and then one site goes up faster then the other side, result is that the printer starts printing in the air or the nozzle slams on the bed. both happen and you never know when and how. when I stop the print and level every thing I restart the print and most of the times it goes OK, next print will some time go OK but i'm never sure.

hope some one can help, If Anycubic likes to help I let you know what was wrong but I think this will take a few weeks.

Had the same problem and not sure why but this worked but I modified the first segment of my gcode (just cut and pasted in Notepad) and now the printer no longer crashes into the bed. This is the code I used.

;Set Temperature
M190 S60 ;wait for bed temperature
M109 S200 ;wait for hotend temperature
;Initialization
G21 ;metric values millimeters
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
;Move to Home
G28 ;move extruder to min endstops
;Position Extruder Head
G90 ;absolute positioning
M82 ;set extruder to absolute mode
G1 Z15 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E6 ;extrude 6mm of feed stock
G92 E0 ;zero the extruded length again
G1 F3600 ;set maximum feedrate
M117 Printing… ;set LCD message
G5 ;set Bezier cubic spline

Hope this helps

A small update, after a month of mailing to and from anycubic support i contacted them again and told them im really disappointed in the service. at the end they told me they send me a new motor, a new main-board, a new SD kit and a new PSU. this is all in shipping now so i hope i can fix the printer when its in.

as soon as i have news i let you know

a small update, the support of Anycubic is not very good. the fan problem i have to fix myself, they dont send a new fan.
the other problem is still there after some testing. now all findings are back to Anycubic and the waiting is started again.

it printed fine for about 3 months now its not working anymore......not happy with this printer and will make a complain with aliexpress if the dont solve the problem soon.

Flip the machine over and remove the bottom plate then heat the hot end, check the voltage measurement at the terminal for the hot end see if it stays the same. Mine had a problem here and software was unable to detect this until the cold extrusion prevention is triggered.

This would indicate a problem with the board, the chip controlling the hot end should be providing 12 volts and pulsing on or off, not having a voltage in between.

As for the Z axis, have you tried flashing a different firmware? Also is the endstop switch connection good? I was setting up the dual Z motor and limit switch for the TEVO Tarantula a while back and the second Z motor would react like this. When the second limit switch was held closed (shorting the wires) when the command was given to home, the gantry moved up together, but the second stepper motor doesn’t move back down. You know what I mean? Since it thinks it’s already hit the homing switch.

I would check your limit switch and test its connections, an intermittent connection could make homing unrepeatable.

As for one motor rising faster than the other, I don’t have any explanation for this except maybe try reflashing the firmware.

I have the same problem, except I don’t have the z axis misalignment. I bought my printer in the first few days of September. So it’s been two months.

Here’s what I tried to do to fix it, by the way I’ve wasted more than two full 1kg spools of PLA trying to figure out what’s wrong with this cold extrusion error.

https://www.thingiverse.com/groups/anycubic-i3-mega/forums/general/topic:21406#comment-1588917

Also, I’ve had some non-repeatable issues which happens but are rare instances I cannot prove to the Anycubic support. One of which was the touch screen become black during print, like no power no response. But the printer seems fine it continues.

Another is the main board mos chip for the hot end it fried and I had to use the spare E1 to heat my hot end.

I have since swapped the PSU with the one from my tevo Tarantula, and it did not eliminate the cold extrusion error. The TEVO on the other hand worked fine with the Anycubic PSU.

I’ve given up and can only await for the PSU Anycubic support sent me, and then take more pictures and send them off and wait and see....

Thanks for the answer, don't know where my post is gone to :-(
I mailing with support for two days now, no answer to my questions but more questions from them. I ordered my printer in august or so, could it be the same badge ?

please let me know if the PSU fixed the problem.

Could the moderator please repost or fix the main post, it’s silly to have a reply to something nobody can see...