Loading

i3 mega seeing card but not seeing files

Please Login to Comment

My mega sees that an sd card is inserted, but doesnt see any files on the card.

I tried:
Formatting card
having only 1 file on
changing to a different card
restarting it
Re seating sd card cable

and I get nothing. It was working earlier today, but it just quit seeing files. Any ideas or thing to check?

Das Problem Tritt bei mir nur bei Umlauten auf Ä Ö Ü usw. im Dateinamen auf.
Ich benenne die Datei einfach um.

I have more or less the same problem, but my printer didnt recognise any file. i also installed now marlin 1.4.6 and i cant even enter to the main menu. in fact if no sd card is inside it didnt appere, and when i plug it it works. did someone had the same problem?

I have also experienced this, and I found out that it is caused by the last file I tried to print. The printer does not want the file name "End Bar 1 Print.gcode", once I renamed the file the contents of the sdcard can be read by the anycubic again. I think the word "End" at the beginning of the filename has something to do with it.

I came across this problem over the last few days, I was making an 'end-cap' during a project and then everything alphabetically after this file was missing from the SD card.
I didn't realise this, so I was re-formatting, downloading tools and all-sorts before coming across this post.
If I had not turned off the option in Cura to add the machine name as a prefix (so I could read more of the filename on the screen), I probably would never had known it was a thing!

Thanks again!

I have also tried those things before I realized what was wrong.

Thank you so mutch about this post! after formating cards and trying differnet cards i found this post

Had same thing on my i3 mega - files starting with "End" at begining of file not shown in list

I also noticed that's reading it becouse using simplify 3d connecting to the Any it does read the files in the sd, but does not show them on the printer screen

How big is the card? I found that some 64gb cards have been too big to recognize, even when formatted correctly. I was able to format it to only 32gb and then it worked.

Hi,
I have the same problems with the Anycubic SD-Cards. It begans after a view weeks.
I´ve bought several other SD-cards - all of this new SD-Cards works yet without problems and without datalosing.
You can also use the Anycubic SD-Cards for other things, but be carefull - losing data is possible.
greetings symbadisch

Hi cam2363,
do you use the "original" sd card (delivered with your printer)? Many users in different groups have troubles with it. Buy another sd card from any computer store and most of the troubles are over.

I tried with a few cards. The computer reads them all fine. But when I was messing around, trying different adapters and cards it worked again, and the original card read too. So their might be something wrong with the adapter, or the sd card slot on the printer itself. Not sure which but it works again.

Beyond what Sith said .. I have to have 1 file with the ending extension of '.gco'.

While I almost exclusively have files that are .gcode files, if I dont have 1 named .gco I get the same situation as you have. No files showing up. So may as well add that to your pile of potential solutions.

Others had also problems with the length of the filenames stored on the SD. Also some special chars seems to be causing some problems. The recommendation was always to try it by using something like ABC.gcode as file name .

Ahh, and another point was that the card can't be read by some any's when it's inserted completeley. Just try to put it into the slot till it's recognized by the printer and not deeper. I know that sounds strange, but I had the same problem with my Any.

That last tip solved it for me. I habitually inserted the card all the way, and probably with this the contacts get loose over time. Just inserting it "enough", and the card was read again. Thanks for that!