Loading

BLTOUCH z-offset not working?

Please Login to Comment

so I set up my bltouch and when i try to print it's slightly high so layers don't stick to the bed. I tried to set the offset using "M851 Zx" but the printer still prints above the bed. I even used -4 with no change to the distance.

am I missing something? I run M500 and M501 afterwards

I had to guess the numbers since I have seperate n stops and I can't make my nozzle stop using the bl touch

Did you ever resolve this?

Yeah. Turns out offsets don’t work unless you relevel the bed, You have to do another probe to “apply” it

A better solution is turning on baby stepping and making it be the same as z probe offset :)

I have been fiddling to get mine to work for two days, and going mad as to why the z-offset wasn't taking affect. Looking over code and where I went wrong, and then I read your post about the settings not taking effect until a relevel. I was way overthinking things. Thank you!!

Just curious, what happens if you adjust the bed height, raise it with the height screws?

considering the nozzle is almost sitting on the base with the knobs I'm worried it'd crash when homing

Really Amy ?
And thats why it won´t work !
You have to be lower than the base to get it to work LOL !

sorry but i'm talking about the Z-OFFSET having no effect! the value. regarless of that considering my printer does pay attention to my probing the n stops won't matter or shouldn't afaik.

Do a normal bed leveling first without the BLtouch. Make sure the nozzle is just at the bed (thin paper in between).

When that is done run the BLtouch setup using all the GCODE instructions from here:
https://github.com/MNieddu91/Marlin-AI3M-BLTouch/wiki/Adjust-configuration

Note the important M211 S0 and what it does during setting up. Follow every GCODE instruction step by step.

This will never work when end stops are hit before the BL-Touch can do its thing...

Hence level bed first. Works perfectly on my Anycubic.

And of course the BLtouch is mounted corrrectly according to the BLTouch instructions...

The nozzle does not have to be below the bed at any time when setting things up. Check out the guide I linked to why that is so.

Yes thats true, but you can do it the hard way... or
get the nozzle below the bed and let the BL-Touch endstop kick in...
much easier than trying to get the sensor to absolut 0,00mm "above" the bed with the endstops hit...

My sensor is mounted according to the BLtouch instructions a couple of mm above the nozzle tip in it's upper state (can't remember if it's 3-4mm or so). It drops down a handful of mm below the nozzle tip in it's lower state. The exact height when it detects the bed and switches from lower to pulled in upper state is of course some mm below the nozzle tip too.

No need for super precision 0,00 mm with endstops.

To set up just level the bed so you are correctly close for the two mechanical endstops. Then run the gcode step by step at the link to set z-offfset correctly.

I know there are more than one way of doing this. You are doing it one way, I'm another.

Yes, i did it your way and it always kissed the endstops.
And thats why she won´t get it to work...

I added a washer so it never hits the N stops when probing. if I disable mesh bed leveling it prints fine because my bed is already leveled but if I enable the mesh bed leveling (make my gcode use it) it starts printing int he air.

= raising the bed slightly by doing a normal leveling without the BLtouch activated should solve it.

I agree with you, the bed is hitting the endstops to early preventing the BLtouch to do antyhing, makes the z-offset changes do nothing and printing fails.

but I see my couplings rotate as it's jsut moving around the bed. (not retracting just printing) by a slight amount. it's working everything expect it's printing above the bed. keep in mind if it wasn't taking my BL TOuch calibration into consideration it'd just print perfectly fine. but since my bl touch isn't EXACTLY the same height as my nozzle (0.5mm?!) it prints up in the air. the issue I have is the z offset not changing anything. I mean i disabled the mesh bed leveling (removed the 2 gcodes that tells the printer to use the mesh bed leveling) and it prints just fine. once i tell it to use the mesh bed leveling again it prints high up (without the gcode the couplings don't rotate unless it's doing a layer change)

Print this first and install:
https://www.thingiverse.com/thing:3560606

Anycubic i3 MEGA X-Endstop Holder For BL-Touch

but the offset has no effect! tho this is very useful once I figure that out thanks :)

i evne made it 4 but it stayed the same place during my print 0_0

That won´t work because you hit the z-stops first and you won´t get further down !
Your Nozzle has to be BELOW the Heatbed when homed, so PRINT AND INSTALL ;P
Do it the hard way - or the easy way.... ;P

I'm talking about the offset. It doesn't care about the n stops. not having n stops would help determine the value I set it to. but when I set it to +4mm and re run my print and it's the same it means something else is wrong!

i did a mesh bed leveling and then after seeing it's high with the additional washer I set offset to 4 to see if it even works (after seeing no difference from anything between -0.1 to -3

Is this ok on your side ?
If not do so...

I'm not sure. but I'm a little confused. isn't the offset just something that the software can take into consideration? as long as the retracted state is behind and the released state is ahead of the nozzle. hard to measure accurately but looks like it.

maybe I should just stop caring. my bl touch has 0.175 deviation :| I'm looking for a refund tomarrow. it's so bad that if I remove one washer the probing will always fail at one random point due the huge inaccuracy making it hit the n stops therefore stopping the probing for safety reasons (not crashing into the bed)

Sorry it looks like you got a Royal Fizzbin - i can´t beat that !

i don't know what that means.

Google it and think...

I did I didn't get it. oh well. lets see if reddit knows why my offset has no effect

Thats your problem, you dont get it , because you are in full "Don Quijote" mode!
Do the two things i told you to do and i can help - but not like this !

0_0 I'll try once the replacement arrives. even after googling I have no idea what that means.....

but I don't get why the z stops matter. keep in mind I have lowered my bltouch using washers so it hits everything before the n stops. so no n stops being triggered. and I can clearly see it's using the values the bl touch offered. but considering the bl touch is high up it prints a bit (1mm?) above the nozzle. I wanted to fix that with an offset but it has no effect.

Again:
Thats your problem, you dont get it , because you are in full "Don Quijote" mode!

Edit:
Better ?
"Don Quixote Windmill"

I'm attacking imaginary enemies?! 0_0 oh well it doesn't matter for now. I hope they accept a refund cause the deviation was 0.175 anyway which is almost two 0.1 layers.... after that i can worry about this. I hope they accept a refund cause they were blaming it on electrostatics and mishandling :|

No you don´t listen, you just go blind into disaster ...

disaster? how am I going into blind disaster! i'm doing nothing currently :P
there's no disaster happening atm. just a bad bltouch and a z offset that has no effects. I'm sure the offset can be fixed. if they don't refund it however, I'm gonna wait a month to buy another clone (this time from geetech) hoping it works or just save for 2-3 months and import the real thing. or just settle on manual leveling and make my stupid self remember to level the bed... (I can't tell you how many times I've forgotten to level it after moving it to another place or putting a new surface on it etc...

Just one last thing, buy the real one...

I'll see I guess 0_0 I mean i spent all I had on this printer. 50-60$ is a LOT for me. it also takes 1 month to arrive but I guess I can't go on like this and hope I find a good one can I? saving makes more sense... tho this geetech one has nice reviews sweating anyways I'll se what happens :D

oof. I guess I gotta save 0_0
Rip wallet. gonna take a month or two :P meh I guess it's not such a crucial thing, right? just a bit easier

This is just pure luxury...

i keep forgetting to level my bed or not do it right that's the issue. tho lately i've gotten good at remembering and doing it good :)

One of my BL-Touches quit working today, its glowing blue and doesn´t do nothing...
But i think its just a loose cabel :)

One of two or was it 7 of 9 ;P

oof you must be both very rich and very unlucky xD

have you ever solved your problem?

Fixed - was just a loose plug and yes i´m filthy RICH - in a pigs eye...