Loading

I3 Mega TriGorilla with T0 failing on the board

Please Login to Comment

So I've had two I3 Mega's for a while. Couple of years ago I remember have T0 errors that I couldn't resolve and ended up getting another TriGorilla board that fixed the issue. Both Machines are using the newest Marlin firmware. Standard steppers but upgraded v6 hotends and using the X-Carriage [MK4].

Fast forward till recent. I had a print fail when the print head went hyperbolic after the sensor failed. I'm a bit shocked that the thermal runaway didnt shut it down but luckily I was close and noticed the smell. love burnt plastic... yummy.

Ok, fine. I need a new print head/sensor... ordered another china v6 clone like I always use. clipped the ends, re-soldered the connections and put the new one in... fire it up and am greeted with 0/0 for the hotend. I assumed the temp sensor is bad.

I whip out a spare and solder it to a connector and plug it in... still 0 degs, not registering.... maybe the spare is bad as well... I plug that into my running I3 Mega and it works fine... press my finger on the sensor and the temp goes up like expected.

This is the SAME issue I had years ago with the other board.

For a sanity check I rip apart my running I3 Mega and yank its board out, putting it in the "bad" I3 Mega... works like a champ so its not a connector issue or the little daughterboard that brings the T0 connection to the board.

What now? Has anyone else had the T0 sensor fail on the board itself? is there a way I can use T2/T3? do I need to buy another board?
I've tried to re-flash the board but it still doesn't work. All the forums I search with T0 issues are usually related to the sensor itself or the wiring and I know in my case that is not the issue.

Any thoughts?

If you're sure it's a problem on the mainboard, there's no reason why you couldn't assign different pins for the task if you have the knowhow. In short you'd download the source code for some firmware that works with your printer (I've used and modified this one quite a bit: https://www.thingiverse.com/thing:4431052) then you'd change the definition for TEMP_0_PIN to the new pins you intend to use, compile, flash, move the wires inside, and you should be good to go.

Anycubic i3 Mega M/S/P/X Chiron Marlin 2.0 Custom Firmware with Mesh Leveling and BLTOUCH BL Touch

Excellent response! I was hoping not to get "check your cables" :)
I've done this last night and got it working on T2. I couldn't find where to put the offsets for the bltouch, however. I'll have to get that sorted.

Another thread discussing the same topic: https://www.thingiverse.com/groups/anycubic-i3-mega/forums/general/topic:44051

Is the version you linked the recommended Marlin version for the I3 Mega?

I've used: https://www.thingiverse.com/thing:4358979

Anycubic Marlin 2 (i3 Mega or i3 Mega S) Marlin 2.0.6.1 Custom Firmware mesh Leveling & BL Touch

The one I linked is just the one I found that has been working well for me on my Mega S, and it gets updated very regularly. I haven't tried the one you linked, so I'm not sure how they compare.