Clicky

Loading

Printing about 2mm larger on xy only

by Tymkoijn1

hi everyone, I can't find if anyone else has had this problem. I updated my linear plus to marlin 2.0 can't remember the version using the firmware that everybody seems to be using by lukas pomykal. edited it to make sure it works with my printer. My z height is good on prints but my x and y measurements are off by about 2mm. remeasured the rods to make sure, and edited the XYZ skew to make sure that wasn't the issue. tightened the belts(I haven't replaced them yet, but that's my next step). haven't checked stepping but figured that should be good or it wouldn't get the height right. I am not sure what else to check. any help would be appreciated. I know its not much but I want to make stuff that's might need tighter tolerances. using standard pla so shouldn't be a warping issue.

View Comment

Anycubic printing above bed after leveling

by migelraton

I purchased my Anycubic Kossel pulley version with the heated bed and put it together in between work and family time over the course of a few days. Only second delta printer i have ever purchased, the other one being a DAGOMA. The only things missing from the kit were the instructions and the bed level sensor so I started looking for one and found this one. https://www.thingiverse.com/thing:1976680 I downloaded the files and read the files on its use then started downloading marlin firmware for the printer. Tried several and finally settled on the recommended version from the bed level sensor documentation. https://github.com/jam3sward/Marlin/tree/1.1.5-Anycubic-Linear. I have Arduino 1.8.5 and have successfully pushed the firmware and leveled the bed with the sensor but no matter what settings I try, it will stil print about 20-30 mm above the bed (have not measured it out exactly). I have undone all the changes to the firmware and am now trying to see if anyone has any ideas. Oh and I am usung the Cura 15.04.6 specifucally for anycubic. I have been told to use terminal commands but cannot find where in the software to input them.

Disclaimer; You will have to forgive me. i can build and troubleshoot nearly any 3d printer but when it comes to the firware, if it is not a simple upload and print, I am unable to wrap my head around it. That being said, I can make minor changes and with help find the proper way to upload it but that is it. So please make explanations as simple as possible when talking about the firmware and its changes.

Removable Bed Levelling Probes for Anycubic Kossel Linear
View Comment

Marlin 1.1.6 for Anycubic kossel pulley version

by brotherchris

I have tailored Marlin 1.1.6 for my Anycubic Kossel pulley version. It works great on my machine. I am not guaranteeing it will work for you, but you are welcome to give it a try. You will probably need to adjust your Delta Height. I have the heated bed version. Mine is currently set to 334.1.

https://drive.google.com/open?id=1Z9qXm_bZNOeblTwviqBPnEVhJ-Hqnxek

Also, I use some pretty slow speeds for troubleshooting purposes. You might want to increase them if everything goes well.

You can go back to the Anycubic defaults if you need to here: https://drive.google.com/drive/folders/0B8VIB533cgdMa1czMW5hNWlXYW8

Please feel free to post if you need help with anything.

Chris
http://www.youtube.com/chrisriley

Marlin
View Comment

Help replacing the RODS

by GospodinJean

Hello Kossel community. You are my only hope.
I bought this old used kossel a while ago, and after buying realized that one of the rods is damaged

my kossel has linear rails,
and I am trying to find some replacement rods to buy.

what is the real size of the rods?
i measured around 267 cm,
but in aliexpress I find only 220, 250 and 270 rods

nevermind that mine has 267 mm rod lenght,
what is the real, rod lenght for an out of box Anycubic Kossel?

If anyone would also indicate any facebook group or telegram or whatsapp group, for kossel owners
i would be really thankful too!
the problem is that the community of Kossel users seems to be really small, so . no much information online about it

View Comment

Anycbic Kossel Linear Plus and Marlin 2.0.0 problem

by OilBrush

Hey guys and gals. I upgraded my FW to Marlin 2.0.0 (https://www.lpomykal.cz/kossel-marlin-firmware/), but there is a small problem. When I abort the print from Cura the printer starts homing the rod pairs individually and not at the same time. If I wouldn't shut down the printer the rod pair or the carrier would crash to one of the aluminium extrusions. Any idea why this is happening? Also, I downloaded the original FW, but adjusting the Z offset doesn't change anything, so I'm kind of stuck. And grumpy.

View Comment

Marlin Firmware

by slingshots-1

So for creating and uploading I took the firmware I found online from LPomykal and uploaded that. I was scared I would mess up the firmware and not be able to recover it. I just got a Linear plus last night and the auto bed leveling wouldn't work, which brought me to the marlin firmware.

I have since uploaded marlin and it seems to be working well. But, in my experience, I'm not happy with just uploading some else's firmware. I want to know how it works so I can play around and mess with it. So for creating my own firmware, all I need is the Marlin.ino file and the config.h and adv_config.h files correct?

When I see a youtube video from someone who is uploading marlin they have 30 .h tabs open and mine never show up. And it's never straightforward, at least to what I have found accessible to download for marlin on Github.

Can I take a Marlin.ino file from an older marlin version, and then add the two .h files?

Also, I was browsing the marlin code, and for a custom boot screen, how would I go about that? I know I have to uncomment a bit, but what must be done for the bitmap file?

Thanks,

View Comment

Kossel restored

by nonaak

Hi everybody,

Me and my son (12 years old) refurbished an old anycubic Kossel plus. It has become very beautiful. It has turned black with yellow.
I changed the motherboard to a bigtreetech skr V 1.3 with three TMC2208 for the axles and a DRV8825 for the extruder.
And a BigTreeTech TFT24 v1.1 display to top it off.
Now I have started working on the firmware and am having some trouble getting it all right.

First of all, it is true that the BigTreeTech TFT24 v1.1 display cannot operate in two modes (original display mode and the TFT mode). Is there a solution for that yet? or is it choosing what default it will be for me.

In the Configuration.h I can't manage to set the "Step_per_mm" on 40 steps. after loading the firmware it is 80 steps. (I now change that in the display).

When I click on "Auto Calibration" in the display. Then the printer probes off center. about 20mm right towards you.

I tried to print despite everything. A flat round disc of 80 mm dia and 1 mm high. But after everything was heated up and the print started I didn't see a nice disk but a thick lump of PLA (center-right- away from you).

a bit of a shame, it went so well.

Maybe someone is kind enough to look through my Configuration.h and my Configuration_adv.h, and maybe see something that's not right.
you would do a great job with that.

View Comment

Fried Trigorilla Board

by thadjenkins

So I fried my board. I saw a small spark when I went to plug in my Pi to the usb port (Did a bad job of resoldering the heated bed fuse, corrected it). A quick inspection leads me to believe that it's the part highlighted below. Does anybody know what this is and if it's worth buying another and resoldering?

edit: Added actual photo of the board.

View Comment

spare belt and upper wheel, which size and type for linear plus

by marcottt

Hi all, i think to buy some spare with time, someone can tell me about size of belt and the upper wheel ? My printer is a anycubc kossel linear plus

Any other spare useful (not extruder) ?
thanks
marco

View Comment