Loading

Firmware

Please Login to Comment

I was wondering how to check the installed Marlin Version or Firmware ? How to Update ?

Using the Printer now for 2 days... experimenting with some cura profiles now... first prints were OK... now they are way better.... but still i guess modifying firmware will make it better....

Thank you

Hi,
I managed to compile and upload Marlin 1.1.5 with the configurations from https://github.com/duisenberg/AnyCubic-I3/tree/master/Firmware/Marlin_1.1.5.

Everything works fine, it even added baby-stepping when auto-homing.

Thanks for sharing, I will get some inspiration :-)

Also good to mention, that you have upgraded your Anycubic i3 with bed leveling probe. And its configured in firmware.

Hello Christizzz,
Its not the Easiest way. Anycubic Trigorilla board is combination of Arduino Mega + RAMPS 1.4. So it can be flashed like other Arduinos.

1) You have to have Arduino IDE installed (download at arduino.cc)
2) Than download latest Marlin (http://marlinfw.org/)
3) Edit configuration.h and configuration_adv.h to fit your needs
3) Upload Marlin to your printer
4) Test that all works well

I am running latest Marlin 1.1.8. on my Anycubic i3 prusa. I can share configuration.h and configuration_adv.h if you want, but its my setup, so that can be some issues. But im printing without problem.

Thanks and sorry for my last reply.... i am a bit scared of uploading a whole new firmware... i mean if something goes wrong can i go back to my previous FIrmware ???

When using my own Firmware from github.... how can i know what to choose for thermistores ? motors ? bed ? i mean we have no data sheets from anycubic wahtsoever

Hi,
as posted before, you can get the correct headers file (Configuration.h, Configuration_adv.h) for Marlin 1.1.5 on the Anycubic Prusa i3 from https://github.com/duisenberg/AnyCubic-I3/tree/master/Firmware/Marlin_1.1.5.

Works fine for me :).

Thanks i downloaded the files but i have several questions:

1) is that for the PRUSA DIY kit with the Ultrabase Version ?
2) I see that the PID for the Bed is not activated... can i activate it if i want to PID autotune the BED
3) is Linear Advance Implemented ?
4) can i create my new Configuration.h based on yours but with Marlin 1.1.8 ?

Thanks ?

4) Yes, you can. I did it from older anycubic firmware (that one without ultrabase).
http://www.anycubic3d.com/support/show/594036.html

Here's my config files for Marlin 1.1.8.
https://gist.github.com/PavelTajdus/872e24cc8ed6139bee7960548db73bd1
https://gist.github.com/PavelTajdus/f7ddcbf51b24cae373f3c1a95d9eea54

You can try my settings, or just get inspired. It should work (its working great for me), but be carefull. Without warranty.

I have a Problem. I want to install Marlin 1.1.8 on my anycubic prusa i3. I used your configs and set invertxdir false because it was running in the wrong direction. Now its homing correctly, but when I start a print at the beginning the endstops are triggered but the motors do not stop. What do I have to Change?

Thank you for sharing your configurations, work great for me! Although I can't get mesh bed leveling to work from the LCD menu but everything else is great.

Stupid question:
how do i get that firmware up on my printer?
under cura 3.3. nothing happens 0o

You have to download full marlin firmware, open it in Arduino IDE - change configuration.h and configuration_adv.h to these posted here, and then upload it to printer (via Arduino IDE). Its not hard if you know Arduino IDE. If not, try to find some tutorial.

Thank you very much for sharing your files. Tried to configure Marlin 1.1.8 from standard firmware but had problems with Z stepper. Yours works very nice. Just had to invert X axis and modified some speeds. Also added support for BLTouch sensor.
These are my config files in case anyone is interested.

Hi,
I'm a beginner in 3D printing. I have a Anycubic i3 and bought a BLTouch. Can you share the STL file for fixing it to the extruder and where to connect the BLTouch to the trigorilla board. Thanks.
Lucas

Hi.
I used this one : https://www.thingiverse.com/thing:2887389

The sensor has two wires. You should connect the 2 pin wire to the Zmin socket in the board (where your Z axis downstop is connected right now). The 3 pin wire should go in the "servo" socket in the board. Check for polarity: Brown (-, GND) Red (+5V) Orange (control signal).
Regards

Adjustable BLTOUCH/3DTOUCH support for Anycubic I3 Prusa
by Josillo

i uploaded it...it is working...the X axis was inverted... other than that it is working... i have the feeling the extruder fan ( not the print fan ) is slower or quiteter...is that normal ???

This is set to be slower. I dont wanted to run it on full speed.

For extruder fan - set 255 for full speed here:
https://gist.github.com/PavelTajdus/f7ddcbf51b24cae373f3c1a95d9eea54#file-configuration_adv-h-L223

Ahhh that explains it.. and how about the Print fan ? only in the slicer ?

Another question.... when i was building the printer i broke 1 blade of the extruder fan...i know... it is working.... but i want to change it someday.... any suggestions ?

thanks

You can even remove extruder fan and PID Tune extruder temp. And I will work fine. MK8 is not so heavily dependable on extruder fan as for example V6 and others.

Thanks...now i activated the PID tune for the bed....the curve is way better...but the bed LED keeps blinking...is this normal ?

Its normal. Light is on when power is suplied to bed. And its blinking because bed is not powered continuosly, but by pulses.

Hi, thanks for the config files for Marlin.
Yesterday I upgraded my Anycubic to the latest 1.1.8 :).

everything is working ? can you post picture of some of ur prints pls ? thanks

You're welcome. Glad to see that.

Thank you i ll give it a try this weekend.. if something goes wrong i can always flash the .hex from anycubic right ?

I did that, and that was very bad idea...

But you can flash firmware from non ultrabase version. This worked for me well.

hehe...why is it a bad idea ?

Well, prints went totally bad. Layers didnt stick together. It was so bad, that I thought firmware is for different printer.

1) No, it's for the "vanilla" version (I added an ultrabase glass bed after, though)
2) Yes, you can trigger PID tuning with the M303 gcode command
3) I'm not sure it is in Marlin 1.1.5
4) the configuration headers are not mine (courtesy of duisenberg), I tried to compile Marlin 1.1.8 with them but the configuration parameters were refactored since Marlin 1.1.6.
I guess you could do a diff between the default headers in Marlin 1.1.8 sources and duisenberg's to derive which values were changed.