Loading

Flashing an Anet A8 v1.5 motherboard,

Please Login to Comment

Hello. I need help. I have an Anet A8 motherboard v1.5.I have the USBasp and the new board . I cannot get the
Arduino programmer, to unlock the com port. I also have a v1.7.7

Yesterday literally I solved this problem to myself, I've got an Anet A4, with the motherboard V1-5 as well. I tried uploading the marlin to an arduino mega with the ramps and it uploaded it without problems, but when I tried to upload it into the Anet A4 motherboard it didnt let me.

I think it has to do with the windows version, I've got a pc with Windows 10 in which was impossible to upload, and then I tried with another one with Windows 7 and no idea why but it worked. It also happens on Cura and Repetier, I don't know why but it doesnt recognise my printer (Marlin Firmware). Hope this can help you.

I also tried changing the baudrate of the Marlin and of the COM port as well, but the only thing that worked was changing the Windows version from W10 into W7.

No. The Windows version is but one of the problems people run into. Glad you got your board working so all is good.

There are too many pieces/links in the process and each of them can cause grief. The really cheap parts on the Anet board along with the cheap parts in the computers combined with a crappy operating system along with poor drivers make for a very unstable combination. That things mostly work is actually a miracle, IMO.

Strongly Agree Bliksemdoner :o)

o You only see users having these issues issues on Windows.
o For all you PI users out there, if you build an OctoPrint (Raspbian OS), you can install Arduino 1.8.5 on the PI and avoid these Windows issues all together (wink-wink).
o Once your firmware + OctoPrint are all working, you can just use the Terminal tab within OctoPrint to send G/M codes outside of Ardunio completly.

Yep, due to crappy hardware and lousy drivers. I don't use PI but have a number of older laptops that work just fine. Maybe better hardware, IDK. As I do a lot of work in the field I "need" to use hardware that gets the job done, not rely on junk that "might" work. Shiny and new too often does not work, almost as if the USB ports are only good for a pointing device, not solid communication as required for firmware uploads.

BTW - a economical way for good field performance and utility are netbooks with SSD upgrades. Convenient and cheap.

usbasp doesn't have a com port

The board may need a boot loader flashed to it. Anet boards are often shipped without boot loaders.

I have found that using USB for programming fails too often so I just use a USBASP to load firmware. Easy to use and boot loader can also be flashed.

I have a USBASP, but the problem is that ardunio 1.8.5's com is greyed out.

Here are some screen shots I just took of what it looks like when I have an USBASP set up ready to use to program an Anet board.

Note: when using a programmer you do not use the right arrow to upload the firmware, use the menu option.

Edited: added pic of USBASP connector to the board.

When using the USBASP the com port is irrelevant. You upload using the programmer from the drop-down menu, not by clicking the right arrow.

A lot of people have issues with the serial driver. I'm assuming your using Windows 7, Ardunio 1.8.5 and that you set your COM port and board correctly. This usually has to do with the serial/COM driver/chipset used on non-Ardunio boards. Check that you have a good serial driver for this chipset from the Device Manager-Serial Ports before proceeding further.

Hello ElectroFluSS. I am using Windows 10 and Ardunio 1.8.5. I have a USBASP board. The ardunio com port is greyed out.

USBasp and Windows 10 is no fun...
Read this thread for some possible solutions.
https://forum.arduino.cc/index.php?topic=403107.0

Hi monkja03,

So I've never used a USBasp, however I have used a spare Arduino Uno (or clone) as a programmer. You basically used the COM port on the UNO and choose 'Arudino as ISP' instead of 'USBasp' as the Programmer. You also need a simple sketch uploaded to the UNO (I think it's in the samples already). If you use any non-genuine Arduino boards (clones) or some MKS boards, you might need to load the driver for the serial port, for example CH340G, CP2012, FTDI F232R, etc.

Good luck...sounds like you might need it using USBasp based on onmeow's comment above - LOL.

Oh...I've successfully used that UNO method to revive dead MKS 1.5 boards by uploading the bootloader to these "broken" boards. The COM port on these boards were not working until fuses reset and the bootloader reloaded. The MKS board (which is basically like Ardunio chips) was workiing and while uploading firmware with a LONG USB cable "fried this way", and was resolved using this method.