Loading

Cura Measurement Conversion Problem

Please Login to Comment

When I create something in Inventor in inches I have to make something, for example, 25 inches long for it to be 25 millimeters in Cura. Is there any way I can make something in millimeters, in Inventor, and it come out in the same amount of millimeters in Cura?

I know that this question was asked few months ago, but while exporting STL file, while in saving window, on bottom of that window you have options, where you can change export units. And be sure to select milimeters, not centimeters

You can switch to mm in Inventor and make your model in metric or convert the STL model from imperial to metric by scaling it 25.4 in Cura. STL format is unit-less format.

Thank you, but how do I make my model in metric?

You can change units in document settings for the part or select a metric template when creating a new part.

I tried both, but neither will work I put it in Cura and it is super tiny. I can put 45 inches in Inventor and it will be 45 millimeters in Cura which is what I want, but I want to make something in millimeters in Inventor and have it be the same amount of millimeters in Cura.

Hi, this is an export problem in the stl export settings in Inventor from Version 2018 on. Just select the options button in the file dialog at the export of the stl and then switch the unit to whatever you did your object with. Then it should appear in the right size in you slicer.
Hope that helps you.

Didn't know of the problems with STL export in 2018 version (using 2016). Thank you for the info!

Thank you so much!

You can always make an uniform scale in Cure by 2540% to convert from Inches to mm.

In Inventor select template for metric (mm) when creating a new part . or change Tools->Document Settings, Units tab to mm for existing part.
When exporting the model to STL (Save As), select the button "Options...". This will give you the the "STL File Save As Options" dialog - make sure Units is millimeter here.
The STL should now be in millimeters and load correctly in Cura.

Hope this helps :)

Thank you so much!