Binder clip size for CR10

by supercowpoopman

I lost the binder clips in a move and i am wondering if anyone by chance knows what size clips come on the CR10 with glass? I am guessing small but not sure. Thanks

View Comment

TH3D EZABL not levelling, if anything making it worse.

by cypher007

i have an old EZABL that doesnt seem to be working on my CR10 mini with Melzie board
running latest firmware and start gcode. it probes ok and deviation is very low but after it does a G29 and starts printing the test stl it is ok at the front of the bed, trying to inject into the glass in the middle, and seems as much as 1mm out at the back of the glass. its almost like it needs to invert the numbers its using
im using 4mm float glass from a local window shop
ive got solid mounts and doing a bed tram i found the bed is very level. maybe 0.2-0.3mm front to back
the gantry for the extruder is within 0.1mm level
i think if i didnt use the G29 and just manually levelled it would probably print better.

View Comment

CR-10 Mini mainboard fried?

by Tripwire999

I've been away from home for 8 months, printer was doing fine before I left. I can't do anything anymore with the printer as of now. I'm running Marlin with a BLTouch sensor.Basically what happens when I try to do anything the screen goes blank and nothing happens. Or the printer restarts with the screen displaying:
Homing failed:
PRINTER halted
Please Reset

The only thing that happened is the printer has been moved to a different location in the room. Would this be a motherboard issue? I do have a RAMPS v1.3 lying around which I can use but I don't know if it's better to get the SK3 Mini E3 or something

CR-10 Creality
View Comment

Cr10s can't update marlin

by haloremi


I tried to update my printer (CR10S) from Marlin 1.1.9 to 2.1.x with octoprint (from usb) and the firmware updater.
But I can't do it, it keep to fail when verifying the memory.
The log shows:

avrdude: reading on-chip flash data:

avrdude: verifying ...

avrdude: verification error, first mismatch at byte 0x0002

0xda != 0x42

avrdude: verification error; content mismatch

avrdude done. Thank you.

Did anyone have encountered this error ? I have scroll all website i could find but can't find a solution.

Have a great day !

View Comment

Creality CR 10 S with version 2.1 mainboard, installing BL Touch

by 3DDesigners

Avoiding the many pitfalls when adding a BL Touch V3.1 to your CR10S with V2.1 mainboard.

Frankly, if you think this BLTouch addition will be an easy improvement, think again. Be prepared for confusing instructions, missing and incorrect information, dead website links and no technical support (not from Creality support), above all a lot of frustration and this is definitely not a Plug and Play device by any means.

I bought a genuine BLT from Creality being very careful to select the correct version suited to my machine, this despite the confusing BLT versions shown on their website, namely the option for CR10S V2/3 alongside a version for CR/Ender Series. When Creality use V2/3 are they talking about the Printer version or the Mainboard? I guessed they were talking about the printer version, but it is not clear and unless you have taken the lid off your control box prior to ordering, you would be none the wiser. Anyhow what arrived was for a Creality V1 board with both the instructions and the parts, and mine is a 2.1 board. To fit this to a V2.1 board It turns out you do not need the enclosed "Pinboard A", "Burner" or "ISP Pinboard" or the instructions, apart from that you have everything you need!

Now, I have every respect for the Chinese presenters on the Creality YouTube channel (speaking English), but when it comes to physically connecting the BL Touch to the mainboard the video offered is sadly lacking. The presenter actually shows the differences between the V1 and V2 series of boards and roughly where to place the two connectors on the board, but suggests you look at other, non- Creality, YouTube videos if you want to know exact details. Of course, I want to know exact details! because if you don’t get it right you are in for hours of frustration. There is a block of connection pins set out in a four by three grid on the mainboard and without the exact positioning detail, by my calculation you can connect the 3-pin connector in one of 8 positions! (4 positions within the connector one way round and four with the plug reversed). I ended up going through them all, just about.

Okay, having spent the first paragraphs moaning about things I’ll skip all that (It needs addressing Creality!), and explain how I eventually solved the installation and got the thing working. I hope it helps anyone contemplating adding one to their machine and avoids 16 hours of frustration.

CR10S (machine version 1), with a V2.1 mainboard and a BL touch version 3.1 supplied, Cura software.

1) Update the Firmware. Don’t get dragged into Bootloaders, Burners, Baud Rates and Binary files or modifying G codes, just get a USB lead that has a plug one end to fit the printer control box (USB B mini) and your computer at the other (USB A). Disconnect the control box from the mains (240 ac) then plug in the USB lead both ends thereby connecting the computer to the box. The Control Box LCD will light up and display the usual menu (receiving power from your computer).

You need to then download a copy of the new Firmware which incorporates the addition of the BL touch code. Go to the Creality website:



You will need to “unzip” it and save the extracted file somewhere on your computer, use the “desktop” location if that is easiest.

This is a .HEX file.

In Cura go to "Settings", "Printer", " Manage Printers". Select Creality CR-10S and Update Firmware. Cura handles all the connection protocols, although you might need to wait a few seconds for it to connect. Click on the Upload custom Firmware button. Navigate to the .HEX file (on your desktop if that is where you saved it) and upload, easy. Wait until it is finished. Then still in Cura and while still in the “Manage Printers” section go to the button that says “Machine Settings” and click on it. The window shows the printer settings and at the lower left “Start G-Code" scroll down the code until you reach the first of the G codes.

I.e. after M221 S100 ;Reset Flowrate and between G9 2E0 ;Reset Extruder

Insert the following code

G28 X0 Y0

G29 Z0 ;Home

Note: there will be a G28;Home there before you start inserting, just modify it.

This bit of code will now precede any model sliced in Cura.

You are now committed to the install! Disconnect the USB lead.

2) Mechanical Install of BL Touch. For this bit you can actually use the supplied instructions. The version of the BL Touch and the mini connector are both on the same side of the device. Before you attach it to your machine just jot down which version you have from the label and secure the 5 pin (5wire) connector to it because once you have fixed it to your machine you can't do either. At this stage you can also remove the “Z” stop connector from its socket followed by removal of the Micro Switch assembly bracket (3 Screws) from the printer. Ie the original method of stopping the machine at Z zero

3) Connecting it up. Hopefully you have the mains electric disconnected still, if not do so. Turn the control box over (upside down) and remove 5 screws from the base plate, ensuring you keep them safe, to expose the Power supply unit. This is held in by 4 screws on the side of the box, remove them and put these to one side. You now have to remove the Power Supply box from the main box to expose the Main board, you do not need to remove any connectors or wires. Balance the Power Supply on some books next to the Control Box so as not to have it dangling and straining the wires.

Next look at this. https://dl.kamilake.com/3D%20Printer/Creality/BLTouch%20Guide%20book%20for%20Creality%20V2.1%20mainboard.pdf

(Try finding this on the Creality Site ! This being the most important document you need. The QR code just takes you to the front page of their website)

Anyhow, look at the picture and identify, before you connect anything, where the connector wires go.

Feed the wires from the BL touch into the case through the rubber grommet at the back of the machine. If you prize it to one side you can get the two connectors through with relative ease.

Connect the Yellow Blue Red connector to the correct row of pins (as show above Link) ensuring it is the correct way round. Must be as image shows.

You will be left with the Black and White wired connector. This goes in the Z end stop socket and to do this you need to remove the, now redundant Z limit plug and place the BL Touch in the same hole.

At this point you can double check the connections are secure, the right way round and to the correct set of pins.

Put the Power Supply back in the main box with the screws then do the same with the base plate.

IMPORTANT: The black and white (Z socket) connector has to be connected the right way round and, in my case, I had to swap the black and white wires around by removing the delicate pins from the plug and swapping them over. You will only know if this need doing when you fire it up for the first time. i.e., when the print head crashes into the table. Hopefully yours is correct.

Nearly there (famous last words).

4) Commissioning. Re-connect the mains power supply and turn on your machine. First thing you will notice is the LCD displays a slightly different menu. If all is working and your Z height is not too close to the bed the BL Touch will go through a routine where the probe part operates 3 times, 2 quickly and the third a bit of a delay. So far so good.

Now, the easiest way to do the next bit, setting the Z offset, is to follow the method shown on the instructions. "Auto Home" first from "Prepare" menu, hopefully the printhead behaves itself and doesn't crash (see note below about reversing Black and White wires if it does) .What this offset process is doing is setting the difference between the nozzle tip and the BL touch trigger point. Make sure you do the A plus B calculation right, the -/+ can get confusing when you are adding two numbers together. C should be around –2.1/-2.8.

Make sure you “Store Settings” once you have set the offset.

I think you are done!

Do a “BL Touch test”, which you can do from the control box menu, and then a “bed level” when your machine will probe the surface 9 times.

Do a test print from your SD card sliced and saved in Cura so that it has the extra Gcode at the start.

If the print head crashes, check the offset again as this is the most likely cause, if the head was going to crash you would have found out by now when carrying out the "Auto Home" instruction. if not you probably need to reverse the black and white (Z) wires. (pain in the backside)

This is a long document, but I hope it makes the installation clearer and avoids you having to spend the hours researching fixes as I did. Is the BL touch worth it? Without a doubt. One day there will be a Plug and Play version, I hope.

Oh.... Remember to do an auto-home before printing to establish the X Y Z start positions

View Comment

CR-10 mini not using full X axis

by Mikekioul

Hi, first time posting here, I have a weird issue with both my CR-10 minis.
The X axis moves fine and before I home it goes all the way to the right using all 300mm of space.
After I home and hit the limit switch it only goes 70-80% there and then refuses to go any further right.
In the picture you can see my red printer in the maximum position.
I tried with repetier host to change the values but it didn't do anything.
I tried resetting everything but still the same issue.
I was trying to update the firmware but this board seems to need a bootloader Arduino cable setup.
I was able to update the firmware on my ender 3 without that, but maybe the boards are too different.
Has anyone seen this before?
It seems like software since my zeroing is perfect, and the motor does move there when it's not aware of its position.

CR10mini movement
View Comment

Weird noises and other stuff

by rodriln

Hi everyone,
I made a video of my CR-10S right after I started a print. It makes this weird sound and won't begin at the correct position on the table. I'm using Cura 4.13 and haven't changed any of my settings. The really weird thing is I can turn the printer off & turn it back on and usually it will print perfectly. Kind of like a hard reset on a computer (Dell or HP) Is this a firmware issue? I bought a CR-Touch I was just getting ready to install, but I'd rather put it in my Ender 3Pro than waste it on a printer on it's way out. Any suggestions? I'm relatively new to all this. I haven't edited code in Cura or anything, but I'm an accomplished computer geek. I can fix most things with good instructions. ;-)
Here is the link to my video:

View Comment

Cr10 stops extruding after base layer

by bobbyjames597

I have a standard CR-10 model using PLA. I have had an ongoing issue where my first layer and 10-30 minutes will print perfectly and then after that, the printer will stop extruding filament and continue “printing” over negative space. The extruded gear slowly grinds down the PLA after it is unable to continue through the nozzle. I have most recently changed out my tubing, fittings, and given it a new 4mm nozzle.

My retraction and print settings are as follows:

Print speed: 50
Temperature: 215
Bed temp: 65
Layer height: 0.1

Minimal extrusion before retracting: 0.0
Z-hop when retracting: 0.0
Combing: All
Retraction speed: 60
Retraction distance: 3.0
Travel speed: 60
Minimum travel: 1.5

Any assistance is appreciated!

View Comment


by Hammez

hi all just doing some temperature calibration and i am confused. when doing a temperature tower do i use the cooling fans or not?
and also what would be a good retraction distance for a direct drive extruder.
Many Thanks

View Comment