CR-10S with Mainboard V2.2 BL Touch

by davehuber312

I have a CR-10S with mainboard V2.2.
I purchased a BLTouch kit which includes various USB programming cables and adapters to fit on a Creality V 1 board.
I'm not getting much assistance from the Ebay seller i purchased from.
Question is, I found a diagram for installing BLTouch on what appears to be a V2 mainboard on a Youtube Video by user First Layer. Should I just install according to the diagram?
Has anyone seen a kit for install on V2 mainboard? What is the difference?
I'm up for a challenge hooking up as in diagram, but want to confirm that will be sufficient.
Procedure for Marlin upgrade appears to be similar for both boards, as far as I can determine.
What experiences should I know about before embarking?

View Comment

Is my board toast?

by kkinney

The X & Y axis move and home normally. Positive Z moves the gantry downward. Negative Z moves the gantry downward.
While the gantry is moving downward, I hit the Z limit switch and it keeps moving.
Is my board toast?

View Comment

Please help a newbie, your time would be appreciated.

by Chiphil200

I have a CR10 smart pro and I trying print the silver surfer but his board just does not slicer correctly, its like its missing a couple of top layers. I have attached the file. I slicer with creality slicer 4.8.2, tried cura, setting on super quality 0.12, 10% infill and raft. Once in preview mode you can see its not sliced correctly and the prints I have done are true to the incorrect slice. I new to this game any advice would be really appreciated.


View Comment

CR10 not seemingly following Cura start code after BLT install

by 3DDesigners

My CR10S has been modified and improved over the years, the addition of the BLTouch probably making the biggest improvement in quality. Since installing it, with the BLT Marlin Firmaware direct from the Creality website, and this is about two years ago. I have noticed the Cura Start Code seems to be ignored after bed levelling. Instead of two test stripes prior to printing as the Start Code suggests it should do, the print head does a diagonal stripe followed by 1 test stripe in the wrong direction. It ignores the Cura G01 lines of code.
The video demonstrates the problem and the PDF shows the Cura Start Code annotated.
Any Suggestion on how to re-establish the proper pre-print stripes would be gratefully recieved.

Edit Looks Like attachments are missing

View Comment

Filament block?

by ThomasRomundstad

I`ve encountered this issue a few times lately that i cant seem to find any direct info on. I linked a short clip here since its kind of hard to explain in the proper terms and words.

View Comment

Cr-10s Direct drive conversion using stock parts + BL Touch

by Venomouse

HI All,

I'm going to take the leap and convert my CR-10s to direct drive. I mainly print with PLA+ and have been getting stringing issues of late that no amount of troubleshooting seems to correct (I have 2 CR-10s machines and it happens with both). I figured at the same time I may as well install the BL Touch I have had sitting in my storage bins. I have looked around and can't seem to find anything that is designed for stock parts and includes BL Touch mounting.

Does anyone have any suggestions / links to something that will do the job?

Thank you

cr10s direct drive
View Comment

FIXED Retraction settings don't seem to be applying Cura Cr-10s

by Venomouse

EDIT - For future me when I inevitably google this issue again.... It was the PTFE tube being slightly clogged at the very end. I hadn't checked it because I had only recently replaced and figure the Capricorn tubing was the best in show. Maybe I bought a dodgy copy... anyway.. sliced off the last 2mm of ptfe, refit..solved.

Hi All,

I am having horrible stringing issues with eSun PLA+ and it has only started happening since switching to CURA from Simplify 3D.

I have been using the below:

Hot End Temp: 195

Bed: 60

Retraction distance: 2mm

Retraction speed: 40 mm/s

Print Speed 60 mm/s
Travel speed 200 mm/s

After posting a series of stringing tests like the attached this, with different settings (starting at 1mm @ 40mm/s going to extreme of 12mm @ 60mm) Most looked the same. One member commented that it almost looks like the results one would expect when retraction is off.

I'm starting to think it is Gcode related:

Here are my start and end Gcodes and I have attached an example of the one file sliced in Cura and one in S3D (which I don't have the stringing issue with)

If anyone can see the issue It would be greatly appreciated. Thank you


M420 S1 Z5
G1 Y35 Z0.4 F1000
G92 E0
M205 X8 Y8 Z0.4 E5.0
M204 P400 R1000 T1000
M117 Cleaning...
G1 X4 Y39 E5 F500
G1 X8 Y35 E10 F500
G1 X12 Y39 E15 F500
G1 X16 Y35 E15 F500
G1 X20 Y39 E15 F500
G1 X24 Y35 E15 F500
G92 E0
G1 E-0.2 F500
G1 X80 F4000
M117 Printing..."


G91 ; sets to relative (where head is)
G1 F1800 E-3
G1 F3000 Z10
G90 ; sets to absolute
G28 X0; home x
M106 S0 ; turn off cooling fan
M104 S0 ; turn off extruder
M140 S0 ; turn off bed
G1 Y300 F3600 ; move Y forward
M84 ; disable motors

View Comment

CR-10 Smart Pro.

by Ikarusran

When I start a print from home, the extruder raises about 2mm, moves to the print area, and starts to print in the air. I pushed the "reset all" on the LCD screen, but this has not fixed the issue, I'm also new'ish to 3D printing so any suggestions would be appreciated. I see it an issue that seems to pot it's ugly head up from time to time with other CR10's.

View Comment