Loading

Creality CR 10 S with version 2.1 mainboard, installing BL Touch

Please Login to Comment

Avoiding the many pitfalls when adding a BL Touch V3.1 to your CR10S with V2.1 mainboard.

Frankly, if you think this BLTouch addition will be an easy improvement, think again. Be prepared for confusing instructions, missing and incorrect information, dead website links and no technical support (not from Creality support), above all a lot of frustration and this is definitely not a Plug and Play device by any means.

I bought a genuine BLT from Creality being very careful to select the correct version suited to my machine, this despite the confusing BLT versions shown on their website, namely the option for CR10S V2/3 alongside a version for CR/Ender Series. When Creality use V2/3 are they talking about the Printer version or the Mainboard? I guessed they were talking about the printer version, but it is not clear and unless you have taken the lid off your control box prior to ordering, you would be none the wiser. Anyhow what arrived was for a Creality V1 board with both the instructions and the parts, and mine is a 2.1 board. To fit this to a V2.1 board It turns out you do not need the enclosed "Pinboard A", "Burner" or "ISP Pinboard" or the instructions, apart from that you have everything you need!

Now, I have every respect for the Chinese presenters on the Creality YouTube channel (speaking English), but when it comes to physically connecting the BL Touch to the mainboard the video offered is sadly lacking. The presenter actually shows the differences between the V1 and V2 series of boards and roughly where to place the two connectors on the board, but suggests you look at other, non- Creality, YouTube videos if you want to know exact details. Of course, I want to know exact details! because if you don’t get it right you are in for hours of frustration. There is a block of connection pins set out in a four by three grid on the mainboard and without the exact positioning detail, by my calculation you can connect the 3-pin connector in one of 8 positions! (4 positions within the connector one way round and four with the plug reversed). I ended up going through them all, just about.

Okay, having spent the first paragraphs moaning about things I’ll skip all that (It needs addressing Creality!), and explain how I eventually solved the installation and got the thing working. I hope it helps anyone contemplating adding one to their machine and avoids 16 hours of frustration.

CR10S (machine version 1), with a V2.1 mainboard and a BL touch version 3.1 supplied, Cura software.

1) Update the Firmware. Don’t get dragged into Bootloaders, Burners, Baud Rates and Binary files or modifying G codes, just get a USB lead that has a plug one end to fit the printer control box (USB B mini) and your computer at the other (USB A). Disconnect the control box from the mains (240 ac) then plug in the USB lead both ends thereby connecting the computer to the box. The Control Box LCD will light up and display the usual menu (receiving power from your computer).

You need to then download a copy of the new Firmware which incorporates the addition of the BL touch code. Go to the Creality website:

https://forums.creality3dofficial.com/cr10s/

(CR-10S_1.1.6_BLTouch_V3.1_Power-Loss-Continue-Filament-Check-English).

You will need to “unzip” it and save the extracted file somewhere on your computer, use the “desktop” location if that is easiest.

This is a .HEX file.

In Cura go to "Settings", "Printer", " Manage Printers". Select Creality CR-10S and Update Firmware. Cura handles all the connection protocols, although you might need to wait a few seconds for it to connect. Click on the Upload custom Firmware button. Navigate to the .HEX file (on your desktop if that is where you saved it) and upload, easy. Wait until it is finished. Then still in Cura and while still in the “Manage Printers” section go to the button that says “Machine Settings” and click on it. The window shows the printer settings and at the lower left “Start G-Code" scroll down the code until you reach the first of the G codes.

I.e. after M221 S100 ;Reset Flowrate and between G9 2E0 ;Reset Extruder

Insert the following code

G28 X0 Y0

G29 Z0 ;Home

Note: there will be a G28;Home there before you start inserting, just modify it.

This bit of code will now precede any model sliced in Cura.

You are now committed to the install! Disconnect the USB lead.

2) Mechanical Install of BL Touch. For this bit you can actually use the supplied instructions. The version of the BL Touch and the mini connector are both on the same side of the device. Before you attach it to your machine just jot down which version you have from the label and secure the 5 pin (5wire) connector to it because once you have fixed it to your machine you can't do either. At this stage you can also remove the “Z” stop connector from its socket followed by removal of the Micro Switch assembly bracket (3 Screws) from the printer. Ie the original method of stopping the machine at Z zero

3) Connecting it up. Hopefully you have the mains electric disconnected still, if not do so. Turn the control box over (upside down) and remove 5 screws from the base plate, ensuring you keep them safe, to expose the Power supply unit. This is held in by 4 screws on the side of the box, remove them and put these to one side. You now have to remove the Power Supply box from the main box to expose the Main board, you do not need to remove any connectors or wires. Balance the Power Supply on some books next to the Control Box so as not to have it dangling and straining the wires.

Next look at this. https://dl.kamilake.com/3D%20Printer/Creality/BLTouch%20Guide%20book%20for%20Creality%20V2.1%20mainboard.pdf

(Try finding this on the Creality Site ! This being the most important document you need. The QR code just takes you to the front page of their website)

Anyhow, look at the picture and identify, before you connect anything, where the connector wires go.

Feed the wires from the BL touch into the case through the rubber grommet at the back of the machine. If you prize it to one side you can get the two connectors through with relative ease.

Connect the Yellow Blue Red connector to the correct row of pins (as show above Link) ensuring it is the correct way round. Must be as image shows.

You will be left with the Black and White wired connector. This goes in the Z end stop socket and to do this you need to remove the, now redundant Z limit plug and place the BL Touch in the same hole.

At this point you can double check the connections are secure, the right way round and to the correct set of pins.

Put the Power Supply back in the main box with the screws then do the same with the base plate.

IMPORTANT: The black and white (Z socket) connector has to be connected the right way round and, in my case, I had to swap the black and white wires around by removing the delicate pins from the plug and swapping them over. You will only know if this need doing when you fire it up for the first time. i.e., when the print head crashes into the table. Hopefully yours is correct.

Nearly there (famous last words).

4) Commissioning. Re-connect the mains power supply and turn on your machine. First thing you will notice is the LCD displays a slightly different menu. If all is working and your Z height is not too close to the bed the BL Touch will go through a routine where the probe part operates 3 times, 2 quickly and the third a bit of a delay. So far so good.

Now, the easiest way to do the next bit, setting the Z offset, is to follow the method shown on the instructions. "Auto Home" first from "Prepare" menu, hopefully the printhead behaves itself and doesn't crash (see note below about reversing Black and White wires if it does) .What this offset process is doing is setting the difference between the nozzle tip and the BL touch trigger point. Make sure you do the A plus B calculation right, the -/+ can get confusing when you are adding two numbers together. C should be around –2.1/-2.8.

Make sure you “Store Settings” once you have set the offset.

I think you are done!

Do a “BL Touch test”, which you can do from the control box menu, and then a “bed level” when your machine will probe the surface 9 times.

Do a test print from your SD card sliced and saved in Cura so that it has the extra Gcode at the start.

If the print head crashes, check the offset again as this is the most likely cause, if the head was going to crash you would have found out by now when carrying out the "Auto Home" instruction. if not you probably need to reverse the black and white (Z) wires. (pain in the backside)

This is a long document, but I hope it makes the installation clearer and avoids you having to spend the hours researching fixes as I did. Is the BL touch worth it? Without a doubt. One day there will be a Plug and Play version, I hope.

Oh.... Remember to do an auto-home before printing to establish the X Y Z start positions

FIrst of all, thank you so much.
When I found your guide I felt better cause I did't want to change the printer but sincerly I need a BL touch to make it works better.

BTW I have an issues... the nozzle crushes constatly against the bed. even if I change the black n white wires as u suggested and even if I push with my finger the bl touch it still goes down... sincerly, no ideas....

Sounds like you have a bad connection somewhere. Double check EVERY connection, the one on the BLT itself, the black and white wires especially if you have swapped them (check particularly at the pin connector), go back and check the other connector is in the correct position.
On power up the device performs a pre-check by operating in and out twice, the pin comes out pauses, retracts then pause then repeats. If these things are checked it should stop crashing when it hits the bed (or you press the pin with your finger). Otherwise you have a defective unit, let me know how you get on

OK....need help .... xD
I followed yhour guide.
v2.1 control board
v3.1 creality bl touch
hex file,
connections
etc.

It seems that no current comes into the BL touch. Actually, no lights and very hot bl touch.
LCD screen has no light. everything else works.

If I unplugged the BL touch, LCD starts.

wtf? xD

Unfortunately this is beyond me. When you are uploading the hex file the control box must be disconnected from the mains supply. If things are getting hot I can only suggest you re check your wiring. Don’t move any wires in the four way block, just make sure it is plugged onto the correct set of pins(as per my instructions)

Actually I ordered the wrong BL touch. I returned it and today arrived the Creality 3.1 version.

Hope it will work!

BTW It has a Blue Red Yellow Black White wires. I've seen the pdf guide you quoted and I think I'll have to reverse red wire with the blue one. Let you know! :)

Easily done especially when it is none too clear whether the version required is for the version of board or machine.

Mate, good work!!!

I had a hell of a time and ended up just removing it and going back to manual mesh levelling.

Glad my instructions are still relevant 2 years after publishing them

Are you able to try and answer a question that I am unable to solve? I have the Creality CR10-4S with the BL-touch which seems to be working fine now, but when I run the 'bed level' function, the print head travels too far to the right and starts grinding on the side bar. It's as though the printer doesn't know where the actual boundaries of the print bed are. How do I set the boundaries? Thanks for your help with the wiring!

HOLY CR_P Mate, THANK YOU THANK YOU THANK YOU! You just saved me $450 on a new printer. I've been trying for 24 months to get my printer to work with the BL Touch and I could never find the older firmware with the manual bed level option, so my printer has basically been bricked for two years. The issue I had with the touch was that my print head kept crashing into the deck and no matter what I did or where I looked, I couldn't find a solution until I came across your post today. I switched those two wired and boom, it works. An hour ago, I had purchased a new $450 printer on Amazon. I just cancelled that order, so thank you so much!

HI!
I've tried this way, but in the beginning of the process, an interuption of com occured and stop the update. Now my printer only show a blank screen. I tried many things to re install the origin fiwmware using the usb isp provided with my bltouch, but nothing seems to work.
I dont know what to do anymore, I will buy an arduino uno re3, but Iknow i'm suposed to be able to rewrite my firmware with the usb isp.
I'm new to that kind of programming (arduino and other).

p.s. excuse my english, it is not my primary langage.

Hello fellows! I'm looking on Amazon and I don't know which model I have to buy to follow your guide and install bltouch on my creative cr-10s with 2.1 motherboard. There are many brands and models but they all say it is for 32 bit boards. I'm not sure and I don't want to buy something that doesn't work for me.Please give me a link to the product on amazon (amazon spain). I have been wondering about this for a long time. Thank you very much.

Just wanted to add to this thread. I recently purchased the BL Touch V3.1. We had major problems with getting anything to work after wiring up as directed. Found out that the problem was in the 4' extention cable is wired BACKWARDS!! The wire only plugs into the bl touch in one direction. As you look at the sensor, the color of the wires are backwards from the pictures you get on the websites. With it being 5 wires, we cut and switched the blue and white, and also cut and switched the red and black, leaving the middle yellow wire alone. Once this one done, everything else you explained worked perfectly. Thank you. (This was a Creality BL Touch purchased on Amazon connecting to a CR-10S)

Thank you so much for taking the time to post this! I spent way too many hours troubleshooting, watching youtube tutorials, and trying to decide if it was software or hardware problems before I saw your post. I was about to give up until I saw your note about backwards wires. Reversing the wires did the trick and I am now up and running again. Thanks again!

Glad to be of help. There is a lot of conflicting information out there and as you experienced many other ways to set up the BL Touch, but this method worked for me, and now you !

Please, can you help me? There are many brands and models but they all say it is for 32 bit boards. I'm not sure and I don't want to buy something that doesn't work for me. Can you send me the Amazon link of the bltouch I have to buy? Thank you very much.

So basically you can make almost any probe work on any mainboard (doesn't matter if 8 or 32bit,...) as long as that board has either:

-a dedicated Probe port like on the BTT SKR boards for example
-you can use a so called PIN27 adapter board (which uses the beeper pin on the lcd screen connector to activate the probe (servo) and uses the zmin endstop port for reading the signal from the probe) but will need to find a working firmware for the setup you are running, so that the board knows to actually use the beeper pin to deploy the probe instead of using it for activating the beeper

As the manufacturer of the BlTouch is a company called ANTCLABS, it would be best to get their official kit which you can find here: https://www.amazon.com/ANTCLABS-BLTouch-Leveling-Premium-Extension/dp/B076PQG1FF/


Creality as a brand is not too much focused on following official wiring schemes or standards and don't seem to be all about their printers being an open source project (only precompiled .hex files are available for firmware updates (for their 8bit printers and boards) instead of providing full documentation including preconfigured Marlin files! After all they are more about the profit from selling new printers I guess).
Therefore they seem to like to just create their own wire color coding schemes, which can break your machine if you try to follow official wiring schemes/color coding for stuff like the BlTouch which you can find here: https://www.antclabs.com/bltouch-v3

Hi!
I wonder if you have tried to use a later version of Marlin (say 2.0.x) with this setup?

Reason for me asking is because I have a version 2.0 of the motherborad and a BLTouch 3.1 and it works fine with the precompiled firmware provided by Creality (Marlin 1.1.6) but I can't get the 2.0.x to work properly with the BLTouch and I want more probe points than 3x3 grid (and some other stuff as well).

Thanks in advance.