Loading

z homing error after update cr10s with skr mini e3 v3

Please Login to Comment

Hi all!

I install a skr mini e3 v3 on my Creality CR-10s replacing the old creality board. I have in my printer a 3d touch sensor (bltouch clone).

I configure an compile the skr mini e3 v3 TH3 unified firmware for CR-10s printer here.

On z-homing or auto home, it seems that the probe does not detect when it touches the bed and the z axis advances inexorably until the nozzle crash with the bed and does not stop until I unplug the power supply.

Steps to reproduce:

1.Replaced the old original board with the new SKR mini E3 V3.0
2.Installed the 3d Touch
3.Removed the original Z-EndStop switch.
4.Installed the unified firmware
5.Press Auto-Home

3d touch is correctly connected to 5 pin connector.

I have also tried to connect the black and white cables in the two possible positions to the z-endstop port with the same result.

I'm desperate, please help me.

On which port did you actually install the probe and what port have you configured in your firmware? Normally you could choose to have the black and white cable either plugged into the z min endstop port (which requires #define Z_MIN_PROBE_USES_ZMIN_ENDSTOP_PIN) or into the probe port which requires the probe pin to be defined and match the exact probe pin number used on the mainboard. For testing you can also use the M119 command (https://marlinfw.org/docs/gcode/M119.html) to show all current sensor states (including endstops, probe, filament sensor,...).