Loading

CR-10 mini not using full X axis

CR10mini movement

Please Login to Comment

Hi, first time posting here, I have a weird issue with both my CR-10 minis.
The X axis moves fine and before I home it goes all the way to the right using all 300mm of space.
After I home and hit the limit switch it only goes 70-80% there and then refuses to go any further right.
In the picture you can see my red printer in the maximum position.
I tried with repetier host to change the values but it didn't do anything.
I tried resetting everything but still the same issue.
I was trying to update the firmware but this board seems to need a bootloader Arduino cable setup.
I was able to update the firmware on my ender 3 without that, but maybe the boards are too different.
Has anyone seen this before?
It seems like software since my zeroing is perfect, and the motor does move there when it's not aware of its position.

Might be that something went wrong when trying to update the firmware. There are basically two types of mainboards: 8-bit or 32-bit.
8-bit boards (often referred to as Creality Melzi boards) often come in this light green color and need a USB ISP programmer like this one (https://www.amazon.com/dp/B07ZVN1QCL).
32-bit boards (often referred to as silent or upgraded boards) often come in a more dark color scheme like black or dark blue and should have a bootloader preinstalled. They use a firmware.bin file located on the sd card for firmware updates.