Loading

Cura settings

Please Login to Comment

Anyone have working cura settings? Get get my cr-x to print anything good besides the test prints. Cant find anything on what to changed to get a decent print from cura.

Sorry, I replied to the wrong message below, anyway here it is again. I received this file from the Creality R&D Team, it worked fine on 3.4.1, I am trialing it on 3.6 at the moment. Yes the instructions are in Chinese but you really only need to follow the images in the Word document. Hope this helps you all. I have actually started using Cura as my main slicer now because it seems more intuitive to me than S3D.

Thanks for sharing this. I have been able to start making single-extruder prints but had no joy slicing my own two-colour models. Did you get that working? There are a couple of oddities.

When I create a new printer in Cura as a CR-X using them, it does not carry through the extruder defaults from these files correctly. The filament diameter is set to 2.85mm instead of 1.75mm, the diameter is 0.2mm instead of 0.4mm and there is no per-extruder G-code. It's easy to overtype the obvious omissions, but suggests the files might not quite be compatible and I wonder if other profile settings have been missed too. It's the same issue with both 3.4.1 and 3.6 (on Mac).

The other problem I have is with the per-extruder G-code specifically. It seems that if you add more than two lines of code, that whole section fails to be included when the extruder switches.

The Chinese document shows that extruder 1 start should be set to:

T0
G92 E0
G1 F2400 E80
G92 E0

If I enter this exactly, none of it comes through in the .gcode. If I trim it down to one or two lines, those lines are included. Feels like a bug in Cura, but I would have thought something like that would already be reported. Seems like if I could get that working correctly, dual-extruder printing is within grasp!

Without these instructions and only using the nozzle switch retraction settings, it does not feed correctly. It retracts on nozzle switch, but doesn't feed far enough to begin with.

Maybe I've missed something obvious. And of course, if I figure it out in the meantime I'll share my settings here.

I've encountered this bug and I have a work around.
You have to add two post-processing scripts:
Extensions> Post-processing > Modify G-code
Add two "Search and Replace" scripts with REGEXP turned on in both.
They're identical except for T0 or T1
Script 1:
SEARCH: G92 E0\nT1\nG92 E0
REPLACE: G92 E0\nG1 F2400 X15 Y15 E-80 ;Retract 80mm while homing\nG92 E0\nT1\nG92 E0\nG1 F2400 E80 ;Feed 80mm\nG92 E0

Script 2:
SEARCH: G92 E0\nT0\nG92 E0
REPLACE: G92 E0\nG1 F2400 X15 Y15 E-80 ;Retract 80mm while homing\nG92 E0\nT0\nG92 E0\nG1 F2400 E80 ;Feed 80mm\nG92 E0

This properly retracts and loads filament. Make sure to do T1 BEFORE T0.
Through trial and error I figured out you need to retract and load > 60mm of filament for the CR-X so 80 is fine.

The original Creality recommendation is just "G1 F2400 E80", but I changed it to "G1 F2400 X15 Y15 E-80" to home the head while retracting, because CURA pauses in place if you have to heat or cool the hot-end for the two different filaments and this pause leaves melt-holes in the object.

Finally, if you're using TPU (e.g. Ninjaflex ) or other filament you need to go slow; you'll need to change the F2400 (40 mm/s) to something slow like F800 (13 mm/s) because TPU doesn't like to be retracted/loaded quickly. I was able to do a hybrid TPU/PLA dual print using this method.

I've reported this as a bug : https://github.com/Ultimaker/Cura/issues/5311

Using the above RAR and the above post-processing scripts. I can get results like this:

Thank you. I will try this over the weekend and report back!

Thank you again. I made a successful two-color test print, and then moved on to trying PVA supports, which didn't make it - stringing everywhere and then the prime tower failed. I guess that might benefit from the slower retraction too though, and I'll keep trying.

Great to have the dual extruders behaving!

print with a brim. Your part may not need it but the tower does or it'll get knocked over. I wish there was a tower-brim flag. I use a large circular radius tower (>30), use a prime tower volume > 80 on each extruder and turn on wipe-inactive-nozzle-on-prime-tower.

I just bought some PVA but haven't tried it yet. I have used dual PLA & TPU(ninjaflex) but I had to use a replacement extruder (https://www.thingiverse.com/thing:3072475) , turn off retraction, and set the speeds really low. I had lots of stringing, but easily cleaned up.

Improved Flexible Filament Extruder Upgrade CR10, CR10 Mini, Ender 3

Chris, spent the last couple of days playing with PVA with my dual settings. It was an ugly mess™.
I could reduce the stringing to a tolerable level, but my PVA just didn't want to stick well to the PLA (or vice-versa) and I had a ton of failures due to delamination of the prime tower between the transitions between the filaments. I managed to get a print to finally go by:
reducing PVA speeds down to <25 mm/s base , turning the fan to 100% whenever printing PVA , raising the bed temperature to 70°C , increasing the prime tower line width to 125% , and choosing a support pattern that maximized long runs and minimized small changes in direction .
After doing some reading online, it seems like PVA and PLA don't adhere very well and lots of folks recommended designed supports that all touched each other so that the support went to the bed as much as possible and the PLA just had to rest on top. Unfortunately, this is hard to do for the prime tower, which is already inherently a blended mix of filaments to begin with. This might be a case for individual prime towers, one for each filament. There is discussion about that here: https://github.com/Ultimaker/Cura/issues/2608

Thanks for sharing your settings. I should be able to give this another try on Sunday, but it did feel like the prime tower was going to be such a Frankenstein-y mess that it was unlikely to survive. It did appear to be (mostly) printing PLA on the outside and PVA on the inside (I could simply pushed the core of the tube out with my finger) but I assumed the transitions were the weak points, and two distinct towers would surely help. Do you know if other software allows for this?

Simplify3D uses multiple square prime towers. I'm going to experiment with it. (see pic)
My mileage has varied with the CR-X and S3D.

Maybe I'm wrong but I don't think Slic3r has a prime tower by default.

Hey, I'm curious how you got on on with Simplify3D's prime towers. I haven't dared return to PVA yet as I'm still struggling to get 2-colour prints with PLA working correctly. I can get some results with a combination of cunning and luck, but there's something screwy in Cura that doesn't do things quite right.

Firstly, I found it does not seem to prime at all when changing colour on the bottom layer - it just does a solid first layer with extruder 1. As the rest of the tower is hollow, this helps with adhesion but the first transition between colours ends up smurgy. In this case I was printing a keyring design face-down on mirror, so that the first layer would be the front surface - it was the only layer where the colour transition really mattered.

First image attached shows extruder 2 (purple) was not primed on the bottom layer, even though both colours were printed. I believe, though, after this everything works as expected.

So I flipped things over and put a single-colour layer on the base. Not entirely sure how well that first transition went, but it ended up hidden inside the model so it was unimportant. But this way, it only primes on the layers where both colours are used. Extruder 1 is rings (or squares) around the outside of the tower and extruder 2 is a concentric pattern just inside that. So when you don't use extruder 2 to start with, the first time it tries to dump onto the prime tower, it just dumps into thin air.

Picture attached of two consecutive layers hopefully shows what I mean if I didn't explain that well. And a photo of the result for good measure - for this print extruder 2 was only used for the top few layers, so I got away with it.

The sample models that came with the CR-X used a square prime tower that deposited an entire layer of each colour - not just a perimeter. I have not been able to reproduce this, even though it seems like a foolproof (if a little wasteful) approach. I believe the behaviour has changed through various Cura versions, but certainly with the latest (3.6.1) I have these issues. The printer's manual did recommend a much older version, and I wonder if this is why.

Wondering if Simplify3d is worth the investment. Separate prime towers - assuming it prints both on every layer - could be the answer.

BTW, they found the bug in Cura which prevents the Extruder_G-code from loading, but I haven't had a chance to git clone and recompile yet.

So I don't experience what you're seeing using Cura 4.0.0 Beta and the CR-X. My first layers include both filaments, regardless of whether I start with Extruder 0 or 1. I do see a slight bit of underpriming if I use Extruder 1 as my raft/skirt/support extruder unless I manually prime Extruder 1 before I print.

I do notice your PrimeTower is still substantially hollow. What I found through trial and error is that you need to set the Prime_Volume on BOTH extruders to >80 mm3. I typically use a 34 circular tower with a 90 or 91 prime volume. When you do that, there's none or nearly no hollow interior.

Just a guess, but are you using Extruder 1 as your support Extruder but also using a small prime volume?

Regarding S3D, it works if you use the Tools> dual extrusion wizard. I had purchased S3D long ago; I'm no longer convinced it's worth the money compared to more modern Cura version. HOWEVER, it might be the right thing for PVA/PLA dual print. I just haven't experimented enough yet to tell you. ( My CR-X is layer shifting and I need to tune the belts before I test software)

Thanks. I tried making json files because I was having trouble with the 15.04.6. I had four parts and had made four stls instead one stl per extruder.. They added a feature in 3.x I didn't like. I wrote an issue on github and later asked to ignore it.when I got 15.04.6 working. They made it possible to have different temperature settings for the extruders because the new version has a filament setting for each extruder. There were hundreds of temperatures changes it the gcode. From designing with incandescent bulbs, I know that temperature changes cause the element shape to change and causes metal fatigue failures.

Thanks for putting this out here, I have been trying to use S3D with not much more luck. I am going to go back and try to get Cura to work. For someone like me who is not a whiz with computers, how do you get this into the cura profile list? I am stuck on the .rar part where my computer wont open it. Any help would be appreciated. Thanks

Hmmm, they usually just open up for me, maybe try a RAR file opener such as https://www.microsoft.com/en-au/p/rar-opener/9wzdncrdhktr?activetab=pivot:overviewtab or WinZip.

My Settings for running single extruder is good, but still struggling with dual extruder. The Idea was to run ABS+ through Extruder 1 at 235 deg and 110 deg on bed, and running HIPS through Extruder 2 for supports same temps, but retraction is confusing me. It extrudes no 1 perfectly with tower and all, but no 2 just never seems to reach the nozzle. My setting for both extruders are the same.
I'll attach my setting and a screen shot.

It's because the EXTRUDER START/END G-CODE isn't getting loaded for the CR-X. You can use post-processing scripts. (See above)

I received this file from the Creality R&D Team, it worked fine on 3.4.1, I am trialing it on 3.6 at the moment. Yes the instructions are in Chinese but you really only need to follow the images in the Word document. Hope this helps you all. I have actually started using Cura as my main slicer now because it seems more intuitive to me than S3D.

Have you found any settings that work for you yet? If not, I think I have most of it worked out. I still have one or two things to figure out yet, but minor stuff. Let me know. If you did come across anything, could we compare?

I'm using Repetier Host to control the printer, and using the CuraEngine in there to slice. I can only get dual extrusion to work properly in Simplify 3D after I emailed the guys at Simplify3d for a profile - so if you have Simplify I can send you the profile.

Can you give me more info on what your printer settings are?

I am thinking about getting simplify 3d for Christmas so if you could sent that profile that would be great. In terms of setting i use, i am a noob to 3d printing and do not know what settings you need to see to figure out the problems.

Tbh, the cr-x is not a great beginner's printer. Watch a lot of videos on youtube (by for example Maker's Muse, 3D printing nerd, Tomas Sanladerer, Tom Stanton, etc.) and you will get a hang of it. I'll send you the profile soon, but if I forget by the time you get S3D, then please reply here or pm me.

Check out Aazule post!

Good day all, So I too have all of the good problems and am trying to use Cura. I am also new to the 3d printing thing although I do have the Ender 3 also and have just about no problems with it. I thought the CR-x would have the bugs worked out of it... not so. Getting the mechanical issues worked out wasn't too bad but the firmware side is a whole different story. I am not all that great with the stuff that you all seem to whiz through (I think my brain is wired more for the building by hand side) but I would really appreciate any help. Thanks, Dave
P.S. for what it's worth, I have figured out the two STL file part from Fusion.

Yeah, I am deffo not impressed with the printer and the amount of time you can spend trying to fix something. The build quality is great, but software wise, it's retarded. It takes basic stl files nicely, but the dual extrusion part is where it struggles - it may work fine, but you need the settings exactly right, something I have not yet achieved with Cura. I'm going to create a new thread in this group with the profile to Simplify3D and I will update it whenever I get something to work better, or if I get it to work nicely with Cura. Please do ask questions, maybe make a new thread instead of commenting on this one :)

Another thing, I am considering gutting the printer and changing it out with a Raspberry Pi or Arduino, I expect to have much better results and controlability after that.

Doing a Raspberry Pi would resolve all of the firmware issues I imagine. That's an awesome idea. Does yours lock up in the 1mm jog motor setting? I think I have the Cura thing pretty much figured out.when I left off last night, I had a good two color print but still just a little bit of color bleed from darker to lighter colors. I did some more tweaking so I will see if it worked this morning. I have both printers set up out in my shed so I have to get some heat going out there and try it out. There are still a few mechanical issues to take care of too but a little time on the lathe this morning is going to resolve (I hope) them.
As I said, I am not the most computer savvy person so I am not sure how, short of typing it all out, that I could post settings on here. Can you put pictures on here?

I've found that the prime tower "Prime Tower Minimum Volume" needs to be no less than 80 mm3 to purge the hot-end.
I use a Circular, 30 mm, 80 mm3 volume prime tower with a brim, and that seems to work adequately. Cura doesn't link the "Prime Tower Minimum Volume" for the two extruders, so you need to set >80 mm3 in both.