Loading

Need help. Brick

Please Login to Comment

I have tried everything listed under the hack tutorial. Watched all videos. Looked at all forum posts. I'm pretty sure I have done everything right and can't get the hack to work or upload. It verifies just fine. Says upload successfull. Then nothing. Using windows 10 as that's all I have. Printer is a da Vinci 1.0a

Fix. Moved varient file as well as USB.cpp

what slicer you using ?

might need to configure start and end script to get printer to print.

This is what i run in S3D, have posted this several times before for people who have just flashed printer and it got their printer working

start script
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
G28 ; Home extruder
G1 Z15.0 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E5 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
M100
G4 P2
;Indiana
M300 S1318 P240
M300 S0 P120
M300 S1396 P120
M300 S1567 P120
M300 S0 P120
M300 S2093 P960
M300 S0 P120
M300 S1174 P240
M300 S0 P120
M300 S1318 P120
M300 S1396 P960
M300 S0 P240
M300 S1567 P240
M300 S0 P120
M300 S880 P120
M300 S987 P120
M300 S0 P120
M300 S2793 P960
M300 S0 P240
M300 S880 P240
M300 S0 P120
M300 S987 P120
M300 S2093 P480
M300 S2349 P480
M300 S2637 P480

end script
G91 ;relative positioning
G1 E-1 F300 ;retract the filament a bit before lifting the nozzle to release some of the pressure
G1 Z+0.5 E-5 X-20 Y-20 F150 ;move Z up a bit and retract filament even more
G28 X0 Y0 ;move X/Y to min endstops so the head is out of the way
M84 ;steppers off
G90 ;absolute positioning
G1 Z190 ; Lower bed
M104 S0 T0 ;extruder heater off
M104 S0 T1 ;extruder heater off
M140 S0 ;heated bed heater off (if you have it)
;FunkyTown
M300 S2093 P240
M300 S2093 P240
M300 S932 P240
M300 S2093 P240
M300 S0 P240
M300 S1567 P240
M300 S0 P240
M300 S1567 P240
M300 S2093 P240
M300 S2793 P240
M300 S2637 P240
M300 S2093 P240
M300 S0 P960
M117 Remove Print

Along somewhat similar lines, I'd see if I can connect with a terminal emulator to the printer, and then see if it prints any diagnostic messages on startup and responses to any commands like G28.

did you remove the jumper?

You mean the wire you short the eeprom with? Yes. Just held it there for like 20sec then tried to flash

If you are using the hack from https://github.com/luc-github/Repetier-Firmware-0.92 you must ensure the variant.cpp file is in the right place or the hack will not work.
In my case the variant.cpp is stored here: C:\Users\Sally\AppData\Local\Arduino15\packages\arduino\hardware\sam\1.6.9\variants\arduino_due_x.
In your case you will have to change 'Sally' (as that is my user name) to whatever your user name is. Once the variant.cpp file is in the right place, rebuild and upload.

Once you have uploaded and you have something readable on the printers LCD; you also need to do a 'Load failsafe' followed by 'Store EEPROM' in the settings menu. Alternatively do an M502 M500 sequence from your host software to initialise the EEPROM.

Hi TechGirl_Mods,
Could you help me with my 2.0a flashing of firmware, The flashing seems to work with repetier verify and upload,but still have black lines on the LCD screen once it says 'verify successful'. I am using repitier 1.6.9, or should I be using the latest 1.8.1?
I have put all the files in the correct place but still nothing.

As I've already written if you have black bars you haven't followed the intructions on Github properly.

According to the instructions on Github

If you have black bars and printer is not detected properly, it means you did not do the point 4 properly check: https://github.com/luc-github/Repetier-Firmware-0.92/issues/172

This is not working, every time I try, I use a jumper wire to reset the printer, uninstall everything and start fresh but still no luck, Just to clarify what do you mean by 'you did not do the point 4 properly', what is point 4?

Thanks for your fast reply, mmmm.....will have to go though it all again, (for the 5th time ha ha) I'm sure everything is in the right place, but obviously not if I'm getting black bars.

Make sure to copy the USB.cpp as well as the variant.cpp file.

This is what is confusing me I have copied those two over. Just to clarify when I go to say variants I get arduino_due_x , do I copy that over? or do I click on it and I get the variant.cpp or do a copy just this over?
Then is it the same fore cores-arduino-USB-USBCorr.cpp
So do I copy the cpp file only or the file folder? Mmmmm...... thanks so much!

Just copy and overwrite cpp files into the relevant directories

Still no luck, now the USB port on my PC not even recognizing the printer now, no matter what I do It wont recognize it!! any ideas!
I think the davinci is fingered!! ha ha

Check if variant.cpp is same as fw one to be sure copy the correct version.

what port are you using on PC , it prefers USB 2

Installation

With the machine off remove the back panel and short the jumper JP1 or J37 depending on model. Some Boards do not have jumper pins exposed but can still be shorted with a conductive wire.
Turn the machine on and wait a few seconds then turn it off again. The machine will have been flashed removing the current stock firmware and allowing it to be detected as a normal arduino DUE. NOTE: Windows users may need to install drivers to detect the board. Consult the Voltivo forums.
Note : points 1 and 2 are only needed to wipe the stock fw or a corrupted fw, for update they are not necessary. Note 2: remove the jumper before flashing if still there
Use an arduino IDE supporting arduino DUE, 1.8.0 with Due 1.6.8 module from board manager FAQ#166.
Do not use 1.5.8 it is not supported and will give compilation error: FAQ#201

Update variants.cpp/USBCore.cpp arduino files with the ones present in src\ArduinoDUE\AdditionalArduinoFile according your IDE version.
NOTE: You do not need to compile arduino from source these files are in the arduino directory structure FAQ#114.
Open the project file named repetier.ino located in src\ArduinoDUE\Repetier directory in the arduino IDE.
Modify the DAVINCI define in Configuration.h file to match your targeted Da Vinci. See below.
Under the tools menu select the board type as Arduino DUE (Native USB Port) and the proper port you have connected to the printer. NOTE: You can usually find this out by looking at the tools -> port menu both before and after plugging in the printer to your computer's USB.
Press the usual arduino compile and upload button. If done correctly you will see the arduino sketch compile successfully and output in the log showing the upload status.
Once flash is done : restart printer
If you have black bars and printer is not detected properly, it means you did not do the point 4 properly check: FAQ#172

so go back to point 4. 10. After printer restarted do not forget to send G-Code M502 then M500 from repetier's Print Panel tab or from the printer menu "Settings/Load Fail-Safe" and accept to save the new eeprom settings. 11. When update is complete you must calibrate your bed height!Use manual bed leveling in menu 12. Next you can calibrate your filament as usual, and second extruder offset if you have.
For information on upgrading from or reverting to stock FW and other procedures please check Da Vinci Voltivo forum.

⚠️There is no known way to revert to stock FW on 1.0A/2.0A/AiO until today.

Do not forget to modify the configuration.h to match your targeted Da Vinci: 1.0, 2.0 SF or 2.0.
for basic installation just change :
'#define DAVINCI 1 // "1" For DAVINCI 1.0, "2" For DAVINCI 2.0 with 1 FAN, "3" For DAVINCI 2.0 with 2 FANS, 4 For AiO (no scanner)'
0 for not Davinci board (like DUE/RADDS)
1 for DaVinci 1.0 (1Fan, 1 Extruder)
2 for DaVinci 2.0 SF (1Fan, 2 Extruders)
3 for DaVinci 2.0 (2Fans, 2 Extruders)
4 for DaVinci AiO

Thank you for your reply :), but have followed all that to the letter, no luck
Just have noticed that my print bed is like red hot? so have now turned it of. (this might be for good!! ha ha)
Have tried all ports on my PC doesn't read on any, I was using port 2, I have tried the J37 jumper several times and plunging back in, but.....nothing.
Would the SD card have anything to do with this USB port issue? I did take it out and found it didn't have all the files on it. do you have the original files for the davinci 2.0a duo micro SD card?

I have already done that. What do you mean by rebuild? I know for sure that the varient file has been copied to the correct place. I have been working on this for days now. Can't try anything new till tonight as I am out of town till tonight.

Sorry, I've been using other complilers for a while, where I have to build (compile) the firmware and then upload to the device. In Arduino just press the Upload button (it does the same thing in 1 step instead of 2).

I hit the upload and it says successfull. Then nothing. Still black bars.

According to the instructions on Github

If you have black bars and printer is not detected properly, it means you did not do the point 4 properly check: FAQ#172

Is there a different hack I can do other then repetier? I will double check that when I get home.

Sorry, I don't know of any other hack. When I hacked my DaVinci Duo 2.0A, I just followed Luc's instructions to the letter and it worked first time. Having the variant.cpp in the correct place is the most important step of the whole procedure. If it's not there you get black bars.

I finally got it! I found on the link you shared about also moving the USB.cpp file. Did that and bam! Saved to failsafe as well. Now what to use as a print program/slicer. Any setting that I need to chang? Tried to print a sample off the menu first thing and the bed didn't raise, printer head moved around like it was printing but no filament came out.

Which hack? The Repetier one?

Using arduino 1.6.9

check the surface mount fuses in the back havent popped