Loading

Pinned

Thingiverse Developer Portal is live!

by glitchpudding

The new Thingiverse Developer Portal is now available, providing documentation, resources, and enrollment for developers. The Developer Portal includes instructions on how to develop apps for Thingiverse, how to submit apps to MakerBot, and a new sandbox that allows developers to test their apps. The Developer Portal also outlines developer guidelines and lets developers manage their apps and view analytics such as app usage, views, download numbers, and payments. If you have the idea for Thingiverse’s next killer app, go to the Thingiverse Developer Portal to get started today.

View Comment

Design does not appear

by Elballesta3D

Hello
It had a "Shopping List" design which a few days ago was no longer available, I can only see it when I log in with my profile.
What could have happened?
https://www.thingiverse.com/elballesta3d/designs

View Comment

"Save & View" doesn't save and show summary edits

by Nico_mmie

I've been trying to post a Thing for several weeks. But before publishing it, I would like to save the information filled in and see it as it will be displayed when published. Obviously, the pictures, the files, and the printing parameters are saved correctly. But the summary is not saved. I specify that I edit the summary in Markdown language that I just copy/paste via the Markdown Monster software.

Until a few weeks ago, Thingiverse had no problem saving my Things in this language. Of course, I tried to fill in the summary without any formatting, but the problem remains.I've tried editing Things with other browsers (Firefox, Chrome, Edge) and using several different computers and operating systems (Windows 10 and iOS) but nothing works.

Do you have a tip to help me overcome this problem please?

View Comment

Thing not showing up

by egzi

https://www.thingiverse.com/thing:4820154

It doesn't show up on my page and I can't find it on thingiverse.

TTGO LoRa V2.1 case
by egzi
View Comment

Updating thing description / summary returns "null"

by Chrismettal

Hey,

currently writing an automatic project deployment script, but getting hold up on the thing description patching.

I am able to upload most of the data specified in the API reference (name, license, category, is_wip and tags) as well as upload and delete files of all kinds, but uploading the description does not work, as the description always gets set to "null" after patching.

I am using the following params block for patching. All types are strings except "is_wip" which is bool, as defined in the API reference.

params = {
"name": thingdata["name"],
"license": thingdata["license"],
"category": thingdata["category"],
"description": thingdata["description"],
"is_wip": thingdata["is_wip"],
"tags": thingdata["tags"]
}

thingdata["description"] is meant to hold a markdown string, but for now I am just using the string "Autodeploy" for testing, which still isn't accepted, so my description will be "null" again.

Did the implementation of the description object change and is not just a bare string, or are there new, undocumented API objects for the new summary blocks etc. that I need to write instead?

View Comment

REST API: how to upload and update a Thing to my own profile

by smurfx

I'd like to upload and update projects on my profile, using a custom code that could do this via REST API.

I created an app on Thingiverse and I got a client id, a client secret and an access token.

Using access token I can browse projects without problems but I can't understand the syntax for update my own projects.

In this API reference https://www.thingiverse.com/developers/rest-api-reference I can't see how to use client id and/or client secret.

Is there some example on how to use the REST calls?

View Comment

Authentication for App

by SohaibSdq

Hello All,

hopefully I got answer back, when I try to to hit auth link with that params

"https://www.thingiverse.com/login/oauth/authorize?client_id=bc25dbae30c9f0a80a&redirect_uri=https://thingiworlds.page.link"

Thingiverse login page open after enter email password it did not show me the app authorisation page, its show instead homepage and the url address as below

"https://www.thingiverse.com/?redirect=ytoyontzojq6inr5cguio3m6odoicmvkaxjly3qio3m6ndoizgf0ysi7czoxmjq6imh0dhbzoi8vd3d3lnroaw5naxzlcnnllmnvbs9sb2dpbi9vyxv0ac9hdxrob3jpemu/y2xpzw50x2lkpwjjmjvkymflmzbjowywytgwyti0jnjlzglyzwn0x3vyat1odhrwczovl3roaw5naxdvcmxkcy5wywdllmxpbmsio30="

but if i again run the auth url it shows authorisation page for app and redirect to my call back url.

I do not its a bug or regular process, it seems like user already login in browse before authentication, Kindly help me out as I want to build an iOS app.

Kind Regards.

View Comment

Loops? What are loops?

by palenoue

I know this is a stupid question, made even more stupid with the fact that I've been 3D printing for eight years, but what does "loop" and "No Loop" mean? Ever since I got the first Replicator I've been doing my own thing without following the forums because they were focused mostly on the technical aspects of 3D printing, which I didn't need at the time. Now I'm downloading files from Thingiverse to print out stuff for friend's kids (to get them hooked on 3D printing) and many of the files have a "Loop" version and a "No Loop" version which I've never heard about before.

View Comment

Uploading file to s3 bucket with Thingiverse API

by netixtest

Hi!
I am trying to upload a .stl file using the Thingiverse API.
This API described on the link below:

https://www.thingiverse.com/developers/upload-guide

I tried it with Python and curl script, but none of them seem to work. Can you confirm that description of API is still actual. Also can you add to this API description page a sample of working script in Python or Shell script with curl?

===========================Below is an example of curl parameters that I tried==============================================

source_file='/home/test.stl'
bucket=thingiverse-production-new
key='uploads/ac/4d/dd/5b/ff/cube_part.STL'
policy=eyJleHBpcmF0aW9uIjoiMjAyMS0wMi0xOVQxMzowNjozM1oiLCJjb25kaXRpb25zIjpbeyJhY2wiOiJwdWJsaWMtcmVhZCJ9LHsiYnVja2V0IjoidGhpbmdpdmVyc2UtcHJvZHVjdLCIkQ29udGVudC1EaXNwb3NpdGlvbiIsIiJdLFsiY29udGVudC1sZW5ndGgtcmFuZ2UiLDEsMjYyMTQ0MDAwXSx7InN1Y2Nlc3NfYWN0aW9uX3JlZGlyZWN0IjoiaHR0cHM6XC9cL2FwaS50aGluZ2l2ZXJzZS5jb21cL2ZpbGVzXC8zMTYxNjc1MFwvZmluYWxpemUifV19
signature='xxxxxxxxxxxxx'
redirect='https://api.thingiverse.com/files/31559687/finalize'
contentType='application/sla'

-H "Host: ${bucket}.s3.amazonaws.com" \

curl -v --http1.1 -A 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.150 Safari/537.36' -X PUT -T "${source_file}" \
-H "AWSAccessKeyId: xxxxxxxxxxxxxxxx" \
-H "bucket: ${bucket}" \
-H "key: ${key}" \
-H "acl: public-read" \
-H "success_action_redirect: ${redirect}" \
-H "policy: ${policy}" \
-H "signature: ${signature}" \
-H "Content-Type: ${contentType}" \
-H "Content-Disposition: " https://thingiverse-production-new.s3.amazonaws.com/thingiverse-production-new/${key}

View Comment

page numbers less than 1

by spool2kool

when a certain page is opened on a thing search I get pages -1 0 1 2 at the bottom and it goes back to the beginning of the search.

bug page search
View Comment