Loading

BIGTREETECH SKR Mini E3 V2.0

Please Login to Comment

Hi,

I just ordered the BIGTREETECH SKR Mini E3 V2.0 to replace the Creality 1.1.5 board that I toasted the other day. This SKR version (2.0) seems to be fairly new so I was wondering if anyone has had any experience setting this up with Octoprint and BLTouch.

Thanks.

I know this is a year old, but I too am having a heck of a time with the bltouch and this board. I had to reverse the wiring of the plug JUST to get it to to the clicky clicky when booted. But any of the leveling commands pup up errors that it's UNKNOWN COMMAND. Very frustrating. Hope you got it to work. Playing with this, I had each and every issue that has been mentioned here.

Not sure if you got it working correctly or not but this is what i found that really helped me
https://linsomniac.gitlab.io/post/2020-06-20-ender3-pro-skr-v2_0-bltouch-upgrade/

Thanks for the link, I'll take a look.

So I got my SKR Mini E3 V2.0 and installed it yesterday. Currently I just swapped the mainboard. Because I use Octoprint I didn't bought a new display. Octoprint was working immediately. I didn't have to change anything and first prints were successful.

Today I compiled the firmware from the Github bugfix.2.0.x branch, made some minor changes (PID tuning etc.) and flashed it. Again no problems. I'm very excited about this board.

Hopefully soon the cable extension for the BL-Touch will arrive.

Lucky you my SKR E3 V2.0 board does not work with octoprint

You have to go into the firmware and make it look at the USB first, and then the SD to get octoprint going.

Yesterday the cable extension arrived and I installed the BL-Touch. At first I tried to plug the two z endstop cables of the BL-Touch to the probe port. But I couldn't get this to work. Finally I gave up and plugged it to the port of the removed z endstop. Now it's running without problems. I'm using a self build firmware (branch bugfix 2.0.x).

Good stuff! I have a suspicion that the dedicated probe port on the board is a problem.

Awesome!

I'm running the board now using the stock firmware that came with the board, the BLT is still mounted however I have it disconnected as I was spending way too much time getting it to work and not enough time doing some actual printing.

i recived my V2.0 board earlier this week, and got it working with both Octoprint and BLTouch. it took a few days of fiddling - but the difference from stock is amazing! I used the pre-compiled firmware from Bigtree that uses the BLTouch as the Z end stop, rather than using the BLTouch as a probe only, and it worked like a champ. There was some fiddling with the BLTouch - but it is working fine.

I did get a board that had the connectors for the stepper motors mounted 180 degrees out. I assume this is a manufacturing issue while Bigtree figures out the process. When i first went to home the machine - everything was backward. I swapped the pins in the connectors and got everything working as expected.

Comment has been deleted

Awesome, glad it's working for you. So I'm guessing you used firmware-bltouch-for-z-homing.bin from GitHub? If so, did you remove the Z endstop switch from the printer?

Yes, that is the firmware that i used, and so far the endstop is still in place, but yes i will eventually take it off the printer.

Comment has been deleted

I never did get the BLT working well so I have disconnected it, I was spending too much time and effort and wanted to get back to printing. I have reverted back to the firmware that came with the board, Marlin bufix 2.0. The github firmware never worked for me.

I got the BLT working with my own compiled copy of Marlin 2.0. The firmware that BTT supplies for BLT gives me a lot of issues. Been using the BLT for 3 days. It's definitely not a perfect thing but it works pretty well. Setting the Z offset is the most challenging cause even when I follow the videos perfectly to set it, the first layer was way off so I just printed a test print and found my z offset by babysteps while printing. Once I saved that into EEPROM, it works like a champ. .

Crap, forgot to ask, your BLT connection on the motherboard, did you use the z-probe port onboard for all 5 pins from the BLT?

I have the three pin bundle in the probe connector and the black/white connector replaced ny z-probe. I saw on teaching tech that if you do this you can swap between build surfaces without adjusting your z-offset. Haven’t tried it yet, but looking at bed visualizer in octoprint it looks like it will work like a champ.

I'm having an issue where I have the BLT connected to the native Z stop port and using the "firmware-bltouch-for-z-homing.bin". I have adjusted the z-offset several times, but after the initial probing of the bed, the head drags along the bed during the first layer of printing. Any suggestions on how to fix this?

Are you using a Big Tree Tech display or the stock Ender3 display?

Standard display - I use octoprint so I don’t need a touchscreen.

Thanks for your replies. I connected the BLT with a modded JST 5 pin connector to fit in the board's z-probe port. I too use Octoprint however I like to tinker so I picked up the BTT TFT35-E3 and a generic ESP8266 to play around with, nifty stuff, it was only $35 so now I have a spare LCD if I ever need it. For the board's firmware configuration, I followed the guide at the following link: https://www.reddit.com/r/ender3/comments/h8y1ia/marlin_20x_guide_skr_mini_e3_v20_ender_3/

The person that wrote this article on installing the Mini-E3 v2.0 firmware is very helpful and seems to know his stuff.

Got Ocotprint working, haven't printed yet but I'm connected with Octoprint, so that's a good start. Still fiddling with the BLTouch and will test the Neopixels soon.

hello, i order it to , it is plug and play or you need to do sam firmeware improvements to get ir work?

This board in fact is very new. Haven't found any reviews so far. I'm very interested because it's hardware (EEPROM i.e.) is better than the old one.

So I've got the new board in, BLTouch (BLT) hooked up, firmware updated with BLT support....just fiddling with Octoprint now.

May I ask how it's going? Have you got it to work with the BLT?

I've been having all sorts of issues with the BLTouch so I decided to disconnect it however now I'm having nozzle temp errors, not sure if it's related to the BLT. Re-flashed the firmware with a non-BLT configuration however still getting nozzle temp errors. I've ordered a new board and a new hot end so I won't know how well this works until I start again with the replacement parts and without the BLT...it's not worth the money or effort. I did come across a good reddit post on how to setup this board, so if you have any questions, the guy that posted this is awesome and knows his stuff: https://www.reddit.com/r/ender3/comments/h8y1ia/marlin_20x_guide_skr_mini_e3_v20_ender_3/

Thank you for the update - and the link! Much appriciated! Hope you get your problems solved.

Update, got the TFT35 v3.0 touch screen working now, not what I'm used to but I'll get the hang of it.

I'm about to take the plunge and update the board and display as well to the SKR mini v2, and the TFT35 V3(?). I'm running octoprint and klipper, but since I never got my BLT working properly, it's disconnected. Did you have to do anything special to integrate octoprint?

No I did not have to do anything special to integrate Octoprint, it works as it did with the stock board; you may have to fiddle with the port settings in Octoprint, but that's about it. I'm using the Marlin 2.0 bugfix that came with the board on an SD card. I tried modded and vendor versions of the OS that integrated the BLT, but couldn't get the BLT working, so as you did, I disconnected it. I then went back to the OS version that came with the board and everything works great (except the BLT).

Just added the SKR mini e3 v2.0 and the TFT35 v3.0. I was able to get my existing octoprint box to connect to it and control the printer. Did you spring for the wfif module for the TFT35? Have you gotten it going yet?

Yes, I bought an ESP8266-01S, very cheap part. I tried an ESP8266-01 however it didn't work but the S model does. This won't replace Octoprint but it is kinda nifty. The only problem is that the ESP8266-01S loads a web page that is not secure, no login required so I've got it on the shelf for now until I can secure it.

Never mind. Nothing works now. Octoprint initiated a print, but it was about an inch off the print surface, and the TFT won't read any USB or SD cards. I'll be working on this for a while I suppose.

Are you using the firmware that came with the board? I found that it worked right away with no configuring and no BLT. This is the second SKR board I have purchased, the first one seemed to have a bad nozzle sensor port, it would trigger alarms whenever it was heating up; a new hot end and thermistor did not solve the problem so I got another new board. My Raspeberry Pi 3 also took a dive so I'm setting things up again using a new Pi 4. This machine is keeping me busy.

I had to update the firmware on the TFT to get the card readers working, but octoprint is still very much a no go. The printer also runs a lot faster now, which is cool except when printing PETG. I thought I was losing my mind for about a week before I stopped and looked at how fast the printer was going. I sliced the print in cura at 30mm/sec, and the printer bumped that up to 116mm/sec for some reason. Had to manually adjust it down while it was printing, but now I have it working. This has been quite the journey.