Clicky

Loading

I MESSED UP MY DISPLAY

Please Login to Comment

Hello everyone,

I am going to try and explain as best I can and I hope someone can help. I recently bought an Ender-3 pro along with a CRTouch auto bed leveling sensor. I installed the firmware for the CRTouch but now my screen is all out of wack. The screen is no longer a nice clear description of things. its almost as if there is TV static all over the screen. I cannot think of the right way to word it but the display no longer reads clear words. PLEASE HELP!!!!

Later models of the Ender-3 Pro ship with a controller board populated with a GD32F303 instead of a STM32 MCU due to chip shortages and/or export restrictions. Strange that the Creality web site does not have new firmwares for the zillions of users with this.
Factory firmware nuked my display too. Had to compile Marlin myself.
Look under the hood of your Ender, and tell me, does the big chip have "GD" or "STM" printed on it?
There are pre-cooked firmwares for the new chip on Github and elsewhere.
Horrifying that you find no help here. This problem is common as dirt.

I had a similar issue when I last updated my Marlin firmware after I installed my Swiss Micro direct drive (It needs some X and Y Presets changed because the dimensions are a bit different), After F*ing around for hours I finally installed the latest and greates software with all the modifications I have (Bigtreetech SKR mini, BL-Touch, Direct Drive, full metal Hot end (Higher temps possible) ) Everything worked fine and even my screen was normal until I needed to change the filament on my stock display, the whole menu item was just friggin gone, after some searching they told me the stock screen was no longer supported in the SKR marlin software, (Everything worked except filament change) I could spend some time reprogramming it in there OR spend 35€ on a BigTreeTech TFT35-E3 which was certainly supported. So I chose the latter (Nice marketing scheme BTT), but hck now I have color touch etc except.....Regular filament change gives me an error of unknown command, up until now I have been too lazy to put the right commands in and solve it by going to movement and unload and load there (Somehow the commands are correct there like WTF), I have spoken to BTT since and they did send me the latest firmware but then I would have to change Evry other MOD aswell, I fing hate doing that. But hey

TLDR upgrade your firmware, and either reprogram the stock screen or buy another new one it looks very similar to my problem, not the static but just something wrong after a firmware upgrade,
Or maybe just look for the correct Marlin for your device, there is like 200 versions out there, but only one is fitted for the Ender 3 Pro, you should get them all when you download it, but when you choose to reprogram you need to pick the correct one

There's a possibility that the firmware might have the wrong screen configured, that's why I would advise you download the latest version of marlin and the configuration files and compile your own version. If you've downloaded a compiled .bin file from Creality, then you can't edit it and make adjustments. If you've never done this before, there are plenty of videos on Youtube which cover it.

I downloaded the firmware from Creality for the Touch upgrade and thats when the screen got messed up. It has something to do with 256k vs 512k. I ended up watching some Youtube videos that had links to some firmware they tuned to make the screen work right. I have the latest version of Marlin configured and on standby for when I have enough time to fiddle with the tuning.