Loading

[Cura 4.1 Bug + Workaround] Printer stalls / pauses on z-hop

Please Login to Comment

My previvious Posting about this got "flagged for moderation", probalby because I corrected some spelling errors in rapid succession within a few minutes - which is caught by the auto-mod system here (see: https://www.thingiverse.com/groups/ender3/forums/general/topic:37424).
Does this system make sense? Not a lot if it deletes postings for some quite normal editing. But that is for Ultimaker to decide. As long as you are not banned for trying to maintain readable posts... :-/

So here is the short form of it again:

If your printer stalls every few seconds on a print (depending on the type of print, it has to include z-hops on retraction) than this is your quick fix to it:

Change the deafault value of 0 in the field "maximum z-speed" in Cura 4.1 to 50mm/s (or any value reasonably a bit higher than the actual max., z-speed of the ender, which is likely about 10 mm/s) and the stalling is gone.

The reason for the bug is a very high number, that is generated in the gcode by cura (funny enough it is the speed of light im mm/min, 17987547480000), if the default value is set to 0. That kind of breaks the gcode interpreter on the printer and after a while it catches itself and goes on. Setting a max. number cuts the higher number down to it and everything is peachy again.

I guess 4.1.1. will fix this by default.

Background Link:
https://github.com/Ultimaker/Cura/issues/5753

Dude you are the master, I have a sowway sw 200 that has ran z hop from day 1 and I have been trying to get my two enders to run it too and now all is well. Bye the Bye 4.1.1 didn't fix it but you did. Thanks

THANK YOU! I have only had my printer for about 2 weeks now and I had no idea what was going on with my latest print. I thought this behavior might even be normal. Thankfully, I found your post.

thanks for the headsup, I was gettin mad about it

Thanks, I was trying to figure out what was going on. I ended up banging my head against the table until I read this post:)

Thanks I thought Cura decided to make it sound like a german techno club for some reason...

Reset my print and the german techno stopped, thanks!