Loading

Nozzle too high while printing, but perfect when levelling.

Please Login to Comment

The title say it all to be honest.

I start by auto homing, then I get a post it note and level it. The nozzle isn't too far from the bed, and it is equal everywhere. However, the moment I go to print the nozzle is quite far from the bed (enough that adhesion is a problem)

There is one reddit post on this exact issue (https://www.reddit.com/r/ender3/comments/apt7d2/nozzle_too_high_during_printing_but_height_ok/). The Top comment says it could be the z axis stepping too far. Is there anyway to check this?
It could also be some sort of offset, but I can't find any mention of this in the gui.

Is it worth resetting the EEPROM to make sure?

I have provided two images to show. The images that shows the hight while printing is approximate. I didn't want to try and capture the height while it was printing, so I went by memory. It is probably slightly lower than shown (nowhere near as low as the other image shows though).

i had same prob so i retightened every screw and havent had the problem since ....Rollers Stepper motors rails, tensioners etc i bet that will solve ur issue ! good luck! also if ur having issues with nozzle clogs i recommend calibrating ur extruder,, involves a lil math or u can do by some trial n error but the math way is fastest..what filament r u printing?

I know its been a while and i just found this post, but hopefully i can help. I had exact same issue on my cr 10... turns out that the lead screw was slipping INSIDE the coupler that attaches it to the motor. As soon as i made sure that the motor shaft was in only 5mm, then a 6mm ball bearing, then the leadscrew on top of the ball bearing, made sure it was all tight, the issue went away.

another option could be jacked up firmware. One option you can do is while its printing use the babystep feature to move the z axis down while it prints, OR in the slicer, set a negative z offset. start with -0.1mm and see if that helps, looking at your picture, you might need to set it higher, like -0.2mm. cura has this option. i think its called global z-offset. It only does the offset DURING a print. i have had to use it many times

Had the same issue and this solved it for me. Thank you!

It's been some time and I managed to get the printer running with these steps:

  1. Very "tight" levelling - the piece of paper between the nozzle and bed can barely move;
  2. Extremely clean bed - I use isopropyl alcohol and a paper towel;
  3. Printing on rafts - UNFORTUNATELY!!!

And something I always do but you may not know - always level the bed after the printer reached its target temperature.

Hi, did you manage to find a fix? I'm having the same problem as you described.

I've ordered a brand new Creality Ender 3 V2 form AliExpress. Got it within 2 days and started the assembly following this video:
https://www.youtube.com/watch?v=gokN9xNG94U
I paid attention to all the details and IMHO the printer is set up correctly.

This is my second printer after Anet A6, which I've had for a couple of years. I'm not new to 3D printing, did plenty of mods, fixed many issues with the printer (as any Anet user must have had) and allways levelled the bed manually. But this issue with the Ender baffled me totally.

I presume it's not the slicers fault because the prints I have sliced personally behave in the same manner as the example .gcode files provided with the printer on the memory card. I use Cura 4.8.0 with the default Ender 3 Pro machine settings:

; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X5 Y20 Z0.0 F5000.0 ; Move over to prevent blob squish

After levelling the bed perfectly, the print starts too high for the filament to stick to the hotbed. If I would to level the bed so that the first layer would stick, then the nozzle is too low after auto-home and hits the hot bed.

Any ideas what might be the problem? Should I send the printer back and ask for a new one?

My friend bought exactly the same printer, followed the same assembly manual and isn't experiencing any sort of issues.

I would be grateful for any suggestions, which translates to "please help because it's driving me mad".

Cheers!

Just in case you think you're seeing a pattern but the actual pattern is different, check this:

The bolts that hold the X-axis arm to the plate on the left that moves up and down in Z can loosen over time. You can test this by lifting the X-axis arm on the far right, or trying to move it up and down. If should either not move or should uniformly lift the entire X-axis arm up and down. If the bolts are loose, you'll be able to move the right end of the X-axis arm up and down a little without the left end of the arm moving.

This happened to my Ender 3 after about a year, and it caused very erratic leveling behavior. Like I said, not the pattern you described, but you might not have the pattern quite right.

You have to remove the entire X-axis arm up and off the top of the gantry in order to tighten those bolts.

At least do this check and eliminate loose bolts as a root cause.

Have you tried leveling the bed with a thinner piece of paper?

I've had minor problems in the past with bed adhesion but this is what I found out and how I fixed it.

Auto homing will help you level the bed but the bed might be too close or too far away once you actually start a print. This is because (depending on your layer height) the Z lead screw raises the nozzle up when the print actually starts. Thus, throwing off your previous measurement of the nozzle from the bed. BOTTOM LINE: Make adjustments to the bed level screws while printing!

The fix is simple:
When levelling/tramming, make sure you heat the hot end to 180c minimum. Ideally 200. (for PLA)

Here's the problem:
There is a bit of solid plastic at the tip of the nozzle throwing things off.

I used to have the same problem.

Unfortunately I have already tried this.
I always level my bed hot, and with a clean nozzle.

Dont make any drastic changes or you will mess up. Set it for a wide skirt and adjust the leveling as it prints.Make small adjustments because a little makes a big difference. I;m assuming that the printer is ok.,you have proper adhesion and a bed that works ok with the adhesion that you choose.

So I have had my Ender 3 for a year now and what I have discovered is the paper test is great for getting an approximate exactness to what it needs to be you need a test print that only prints one layer high to appropriately test the print because in machining there is no such thing as exactness and in paper production they get as close as they can with the length and width but not the depth of the paper and that's what you use to test the printer. I will attach a file that you can use to test the print it starts out with using the paper level to start it and once you have leveled it you click or rotate the button to move onto the next. After going around twice it will then start the print. If you hear a clicking that means it's too close if the filament does not lay down the head is too far away this makes it so you can accurately test your calibration. Sorry about the long paragraph but I hope this helps!

https://www.thingiverse.com/thing:2987803

Ender 3 Level Test

I have a couple things I will try first but if they don't help, I will have a look at this level test.
Thank you!

https://old.reddit.com/r/ender3/comments/ec2i9j/

I made a calibration guide that includes bed leveling. Check it out! When I do my leveling with a 0.1mm feeler gauge, I input a -0.1 Z offset.

Thanks for the guide, it will be very helpful.

I am going to try out what RexIgnis said about the Cura gcode first, mainly because it will be the fastest and simplest.
I will then follow you guide on bed levelling if that doesn't work.

I was having the same issue with Cura 4.1 and noticed that in the g-code settings they move the z-axis up in the last line. For me, that last line lifted and never went back to zero when the part file started. The test line would also work since it happened before that line of code. I fixed it by deleting the last line in the machine settings start g-code.

Unfortunately, removing both instances of that line did not work.
The nozzle was higher than it was while levelling, during printing.

Ahhh interesting. I see the line you are talking about ('G1 Z2.0 F3000 ;Move Z Axis up' this one I think)
I can't test it now, but it seems right to remove it.

It would probably be better to set it to zero than remove it since the height is changed for the test line.

I was wondering, I have the same problem and I see two of these lines. Should I set both to zero?

I tried it out and I think it worked (it didn't move really high during printing)

I'm still having some extrusion problems but I'm trying to get those fixed as soon as I can.

Ok. I will try that. Thanks!

level bed and move stop up sorry wrong about down up

if you have an manual stop lower it a hair

looking at picture I would say your off by -1.3 so go down -1.0 to start

Where should I change this offset?

change the z offset change it down by .50 go up or down tell you get it right go into to the - numbers by baby steps tell you get it right take a couple times probably

Sounds like a slicer thing not an EEPROM issue. In any case, a good way to dial in your z-axis is to do it while your skirt/brim/raft is printing. Don't be afraid to micro adjust while the first layer is being laid down. Once you do it, you should be set for a while.

A while ago I did try the freeabl system, and you do need to set some offsets. I removed the freeabl system because I did not like it. I can't remember if I cleared the offsets however.
Since then, I have reinstalled the vanilla Marlin to my printer, which I think should have cleared them.

The micro adjusting seems like a good idea. The problem is, surely if I move the nozzle down, when homed, will be below the bed since it is quite a distance away?

This is what mine looks like when homed (below the bed). Hadn't needed to adjust it for a while. The first move always clears the bed, but that really depends on your slicer (I'm using Cura 4.3.0).

What slicer are you using? There is most likely a Z offset setting in the slicer set to a positive value (not 0).

I am using Cura.

I couldn't find an offset setting while searching in the settings. I might be looking in the wrong place.

Go to the market place tab on the top right of the screen and scroll down to the bottom of the plugins tab and install "z offset setting" restart cura and you'll find the Z offset setting in the bed adhesion section. Set it to 0 and try a print.

EDIT Even better.. I created a gcode for you using known good settings and making sure the z offset is set to 0. Try printing this and see what it does. It will rule out if its slicer related or not.

Thank you! This helped a lot. I babystepped my TPU down 0.3mm below where my PLA sticks perfectly and now I am getting good TPU adhesion.

Thank for the reply.

Do I have to run the gcode from the sd card? I tried running it form Cura but it seemed too break. (The bed heated up to 60 degrees, and then just stayed there and did nothing else)

Yeah try it from the SD

Just ran it form the SD.
None of the prints stuck, but it did print at the correct height (it wasn't far from the bed). The non adhesion was probably a bad levelling job or something (it may have also been printing too fast)
The part that did stick had a very nice finish. It wasn't too squished, but there were no gaps.

I assume this means it is slicer related?

Yeah its possible.. I would suggest downloading the prusaslicer alpha (it's got support for enders now) and I can send you an INI config file with all of my profiles and printer setups. I've helped another ender owner on here get setup with prusaslicer and his prints went from absolute crap to perfect prints just by switching to prusaslicer. send me a message on here if you're interested.

I'm going to do everything I can to get it working with what I have so far (Cura). I'm trying to avoid massive changes. I will message you if all else fails however.
Thanks!