Clicky

Loading

Ender 3 pro restarts after heating.

Please Login to Comment

My issue is one i have not encountered before.
My printer goes through its start up and heating then it homes each axis like normal. As its about to extrude it goes back to the power on screen as if there was a power surge and the printer shut off. This is not the case as the screen never actually turns off.
I think its a power supply or mainboard issue.
Changes to the printer are silent mainboard and new power supply.
Trouble shooting i have done so far is to use different gcode files. I also tried unhooking the extruder motor as this was the last item before failure.

Hello,
I dig out this topic because I had the same issue of reboot after the heating / auto home and I confirm that it was the SD card which had too many files to handle. No issue after make it empty.

Hi, do you have anything connected to the USB port like a Pi when this occurs or are you printing from the SD card? It may be that the onboard 5v regulator is having some problem and not keeping up with the power demand from the board/screen/touch probe/etc. Though it seems more likely that your power supply is not working right since the power demands from the 5v should not be too much, and it drops out when you have everything firing (heater, fans, and steppers) as it starts to extrude.

I would first check the 2 pin yellow/orange connector from the power supply to the printer to see if it is fully seated and if it is getting warm, or looks like it has in the past (deformed or discolored). If that is damaged or deformed then you should probably swap the connector (IIRC some older ender3's had a problem with the connector overheating due to poor solder connections). If the connector seems OK, and if you have a multimeter and are familiar with using it (I recall that TH3D has a video on checking vref which covers checking the power supply also), I would next check the DC input voltage where the supply connects to the board to see if it reads correctly (24v for the Ender3). If that looks good then I would probably try the printer on a different mains outlet (on a different circuit breaker) to see if the problem follows.

Thanks for the troubleshooting steps. I switched to a known good supply, 24v out with same issues. I will check the xt60 and where they connect to the main board. Didn't even consider that it could be dirty power from the wall, I will make sure to switch outlets and change my surge protector.

No problem, good luck!

So another step to add to your troubleshooting guide. Check if any additional electronics have been installed. My smoother boards had taken a dive. Took them out and it prints properly.
Will definitely keep this thread handy for future reference.

Well, I had a similar event on my standard ender 3 a couple of days ago. It startet to print, then, after a few layers it homed while being in the middle of printing one layer the display said "reheating nozzle". It stayed at the home-position (only x/y, it kept the z) for about 15 sec. and then printed the rest of the object without furter disruption. Since it started again exactly where it left off, the only problem was some filament leaking going to the home-position, which did not really matter with this object and could be cleaned easily post print.
Since I was using PETG on 245°C, and the Heatbed at 90°C with a layer heigth of .3 and a print speed of 80mm/s, I thought, that maybe my heating element could not keep up supporting 245°C with that amount of PETG filament passing through. But - after this one incident, the rest of the print was printed in 245°C without problem. The display showed steady 245°C all the time, until the firmware interrupted the printing.

I don't think it is the power supply, because i once measured the power consumption at 250°C nozzle and heating up to 100°C printbed temp, and then again while printing with those temps (so about the max. load you can pull), and the printer pulled just over 200W peak power, and after heating up, while printing rather 100-130W. The standard power supply is rated for 360W, so this should not be a problem in any circumstance. I don't have any extra hardware installed that draws power from the power supply.

I think it is rather the original heater cartridge for the heating block. There are aftermarket heaters, that can go to faster / to higher temps (50W instead of standard 40W) - but then again, the 40W should be sufficient... Maybe the heater cartridge itself is not ok any more on my printer. Also possible: Some firmware-glitch with the new silent board I also use (upgraded from the standard board) if you go above 240°C.

If you got the new 32bit silent board there are known firmware problems right now. I don't have many details but the YouTube channel chep, chuck actually addressed the issue in a recent video. The new ender products and cr6 are all over the place with firmware problems.

Thanks for the update, that makes sense. The good news is that you probably aren't going to be losing any quality with the TL-Smoothers gone on the Ender3.

Actually taking the tl-smoother out brought the noise level down without any other consequences. I do want to add a MOSFET to the bed and hot end but that can wait. Need to finish a project before I go screwing with something that works.

That's even better :D

The MOSFET on the board, which is probably some mystery part like everything else, should be able to do the job for the bed. I've seen a few things about the poor quality of the MOSFETs on some of the boards for 3D printers, and I don't doubt some are, but never had any issues (knock on wood) with mine. I did at one point buy a board MOSFET for a TriGorilla board, thinking I would swap it out when the onboard one failed, but it never did :D Are you planning to swap it due to a suspected reliability issue with the onboard MOSFET?

I started with an anet a8 home fire device..... Sorry I mean 3d printer.
I am thinking from a life span perspective. Move the load outside the main board and maybe it lasts longer. With how much I use it, any little bit helps.

Damn, yeah I think after an experience like that I'd try anything. You may want to check into the TH3D EZboard offering though, they seem to be very on the ball for pointing out issues with cheap boards and made their own to address some issues.

I keep one of these above my printers as a "hope I never need it just in case" thing, along with the usual smoke detectors (have been planning a smoke detector relay cut out, but that project keeps getting pushed back).

https://stovetopfirestop.com/product/microhood/

So my gremlin is back. After a few damn good prints it has the same issue. So after checking everything over again. I'm using the SD card with nothing else. New surge protector and a different outlet. Power supply is new out of the box, checked it and 24v is the output and total wattage is 350.
I did notice something strange. When going through its heating process, the bed gets to temperature then the hot end. When the hot end is heating it will hang 3 degrees before it's target (eg. 207 if the target is 210). After about 10sec it goes up and then starts to home each axis.
I want to think it might be the extruder as that's the only new addition to the chain but I'm not sure.

Hi, since you have a pro, it should have had a meanwell supply originally. When you swapped it, did you get the same brand or something else? Asking since I recently watched a video from E3D which shows how poorly constructed some of the (non-Meanwell) supplies can be, which can in turn cause grounding problems which are also a safety problem (https://www.youtube.com/watch?v=RPxBAb7D92k). Usually the fix is simple like tightening screws, removing protective plastic films on the aluminum case or removing paint from threads where the case connects to the frame (https://youtu.be/GWL0fuHZXPY?t=8222), but damn'ed if they did not even find a problem with a cheap power cable:
https://www.youtube.com/watch?v=sqEgsZitkoo

Yup, made sure it was a meanwell with the same specs as the old one.
I don't like to have a printer go down so I have spares of the same or better of major stuff like the power supply, cables and other things that could be a long wait time.

Cool I did something similar when I found a meanwell 24v supply on sale recently (bought it to keep as a spare or eventually replace one of my non-meanwell supplies). Sucks to have something like that go out and then have to settle for something of lesser quality to get back up and running quickly.

So the problem is again that the printer will just sort'a reset just before it starts extruding?

Can you do the following manually?

  1. Heat the bed and nozzle to temp (whatever you are using for the material where it fails)
  2. turn on the parts fan (from the menu)
  3. Home X, Y, Z
  4. raise the Z to about 100mm
  5. extrude some filament

That would test each system individually when the bed and nozzle are hot. You may want to lightly giggle the cable harness while it is extruding to see if there is a failure related to some poor connection or broken wire.

It does all that just fine without issue.
Just to see if it's consistent after doing that I tried printing from SD card and had the same thing.
After clearing a nozzle jam it prints.....
Edit, I also cleared the SD card I was using and only put a few gcode files on it.

Weird, so with the latest trouble, was it doing some sort of reset thing right before it extrudes, but you cleared the nozzle and it is printing OK again?

If that is the scenario then the only thing that would make sense would be that there could be some marginal insulation or slightly broken wire on either the heater wires (unlikely since you would see a spark), or the thermistor wires, which could be making some brief contact with the block, or if they are "slightly broken" possibly just moving them may have been enough to get it working. Possibly by clearing the clog it moved those wires?

Yup same restart issue I had the first time. It would start up and do all its heating and homing like normal but reset back to power on screen the moment it starts to print.

As much as I want to think it's a hardware issue such as broken wires or something like that. Here is my hypothesis, the issue was either voltage related, but the return signal from the extruder causing a spike backwards into the system triggering a ground fault.
My reasoning, when you move any axis quick enough while most printers are off you can generate enough current to light the display. If the motor has power but can't spin, this might cause a return voltage sort of like regenerative braking maybe????
The other idea was that due to it being 8bit and not the newest, going over 2gb in files on the card was causing ram issues. Maybe to store such a large index in ram was not allowing enough for print execution.

It sounds like it is fixed so that is good, but really weird.

To summarize what happened:

  • the problem was that the printer would heat (bed+nozzle), home and then moved to start printing but reset just as it would have started to extrude.
  • the axis all move (when commanded by the firmware) independently without a problem with the bed+nozzle heated to temp
  • the extruder works without a problem independently with the bed+nozzle heated to temp
  • you replaced the PSU with another Meanwell (output confirmed at 24v)
  • you removed some TL-smoothers which resolved the problem for a while but later the same problem returned
  • the last fix was to clear a nozzle jam (and is currently printing OK now)

I re-read the thread and a question popped into my head which I forgot to ask at the beginning (if the problem comes back):

  • Did this problem only start after the upgrade to the silent board, or did you upgrade to the silent board and PSU due to the problem occurring on the stock board?

Back EMF from the steppers backfeeding voltage to the board does not seem likely, since the steppers would be driven by the board when this occurred. I'm no expert on that, but my understanding is that there is always back EMF when driving the steppers, but it only exists when they are in motion (due to the magnetic field), and is a smaller % of the input voltage (so it reduces the effective voltage driving the steppers). When they stall, the back EMF goes to zero (no motion), so it would not backfeed, but the forward current from the driver would heat the coils until the driver senses whats happening (again no expert but this is my understanding). When you move the axis by hand it is turning the steppers into generators, so they can send a much larger voltage back to the board. In any case it's not good to move the axis quickly since there is a relation between speed and voltage and that can damage the board (I move my bed regularly enough and just take my chances, but don't do it quickly) . I'm not sure about the 2Gigs of files on the board issue though. It's very hazy but I recall seeing a video recently that seems similar to that but cannot put my finger on what it was. If you are running a recent firmware, any problem like that would probably be fixed though. Easy test of course would be to just put one file on the SD, but with it fixed, hopefully there will not be an opportunity to test that :D

So I learned a very important lesson with home electrical and how those circuits work.
It's going to sound insane but I had a space heater and the fan was going bad in it. Just died a couple weeks ago. It was plugged in to the same surge protector. When the problem returned I had probably run out of outlets and plugged it back in.
When the printer would get to a point where it needs the most stable power, due to the high and unstable draw from the heater, it would hit the point where it requires the most and then crash due to lack of power or the ability to produce the required wattage.

Thanks, that makes sense, sort'a like if the lights dim a little when something like a heater comes on. I hope you have evicted all the Gremlins from your setup (just in time for Christmas) :D