Loading

Filament change (mid-print, at layer#)

Please Login to Comment

Ender Pro 3 (Marlin 1.0.3), slicing with Cura 4.10.......

I am trying to program the printer to stop at given layer # (to change filament color) then resume (after changing the filament color) with a knob press (or turn). I have tried everything I can think of and watched every applicable YouTube video.

The closest I got was inserting "Pause at Height" gcode with Cura.
The print will pause and I can change the filament. HOWEVER the LCD display reads "PRINT PAUSED" and I can not restart it with a knob press or turn.

If I use the LCD menu and choose "Pause Print" and then "Resume Print" the print will end.

On the YouTube videos, the LCD reads... "Click to resume" (I don't see this)

I've tried a plethora of settings on Cura and can't get it to work this way.

Thanks, in advance for any suggestions, tips or GCODE.

PROBLEM SOLVED!!
According to "Dr. Vax" The Ender Pro 3 does not support the 'M command's to support change filament. I ended up going the OctoPrint route to intercept the pause commands (generated in Cura) and replace it with the code to allow for a filament change. Also to add a resume gcode command to pick up where the printer left off, with a new color. Dr. Vax does all the heavy lifting, plus I now have OctoPrint which is useful is so many other ways.

The video that explains it all (gcode can be copied below the video):

https://youtu.be/P8Q3RmZWNzg

I have now successfully printed in multiple colors with my Ender Pro 3.

One thing you need to be aware of is that with the creality silent board, you cannot release individual stepper motors, so if you send the command to disable steppers then your X gantry will drop down. To avoid this you need to be able to add the gcode to unload filament and from what I remember that requires a custom marlin 2 firemware to be flashed...

Thanks, Micahjj - If nothing else works, this will be option #3!

Here ya go, you need to use the "change filament" gcode

https://www.youtube.com/watch?v=1nBnVtOEAiY

Thanks for sending this, MuzzasMSMadness.... I tried the setting in the video and they did not work. I just downloaded the 'cube' files from Thingiverse and noted a gcode file already there. I'll see if that works and respond back

This gets easier once you print via octoprint and can use the web-ui. And I noticed that prusa-slicer (which, in spite of it's name, has printerprofile for the creality machines, too) has options to insert GCODE for "colour change". Didn't research that any deeper but it may be of help for your project.

Thanks, DorianGrey - if the above approaches don't work, I will upgrade to OctoPrint. It seems like a good idea for many reasons anyway.