Clicky

Loading

Ender 3 V2 Extruder stops spinning mid print - not clogged

Please Login to Comment

Hey Guys,
I've got a fairly heavily modded Ender 3 v2, part of the mods is the Micro Swiss direct drive addon and all metal hotend. I've had it for quite a while now and all has been well.

During the last few prints my extruder has stopped spinning mid print. It always seems to be around the 1hr mark or so and I can't work out why.

First thing I thought was well, it's probably a clog.. But I can see the gear isn't spinning at all. It's as if the printer just totally loses connection to it or decides it's not needed anymore. But without touching anything if I restart the print it works 10/10 times. Out of curiosity, and once a print had failed, I spun the extruder manually by hand and it spins totally freely, like I've clicked "Disable steppers" on the printer, none of the 'clicking' you'd expect if you were to try and do it whilst the stepper was in use.

From what I can see the connections all look fine and the cable doesn't have any play, there's no tension on it and it doesn't wiggle during the print so I can't imagine it has fatigued.

I haven't printed in a few months as I've been busy. When I printed last before my break the printer was 100% dialled in and rarely had issues, I changed nothing and now I'm dealing with this. Any ideas or suggestions?

Cheers!

Sounds like it might be thermal shutdown to protect the driver. How is your controller cooling? Heat sinks on the drivers (not tiny ones, and lined up so there is airflow through the fins)?
Might also want to set up to monitor the power to the driver, in case a regulator is doing the thermal shutdown.

Have you been using the same gcode the whole time or have you tried printing different ones?

Same gcode - nothing changed. I did some diagnosing last night and I think it may be a dead driver on the mainboard :(

That would certainly be unfortunate.
I would at least try printing a couple of different models though, in case there was some kind of weird problem in that specific gcode file. Maybe try a different slicer too, just in case.

Yeah I tried about 4 different files, it appears to do it at different stages in the print but as time goes on its getting worse and worse. Yesterday it wouldn't spin it at all so I plugged the X axis into the extruder and it spins just fine confirming its not the stepper. The extruder cable into the X axis stepper wouldn't spin so I think that confirms it's an issue on the board and not with the cable or stepper.

That's really unfortunate. I just thought it would be good to make sure before having to do something as expensive as replacing the main board. It sounds like you have a good idea of what's going on though.

Absolutely. Thanks a lot for the replies! I was having a really rough time trying to work it out

Is the plastic extruder still installed..??
Take it apart & look for a crack on the bottom of the lever, also check the mount the lever sits on around the bearing.
Lastly, check where the bowden tube screws into the mount (mine cracked there).