Z Axis skipping layers

by mgadriver

I am having trouble with my Ender 5 seemingly skipping complete layers of print.
I looked at the usual suspects:

  1. Filament not unrolling properly from the spool. I have had trouble from cheaper generic spools that are badly wound and snag easily. I now only buy the same brand from the same supplier which solved that problem. I also cut off the required length of filament and let it hang freely thus cutting out the spool. However it didn't solve the skipping problem.
  2. Close observation. I just sat and watched the print process until I noticed that the nozzle was now too far from the printing surface. At that point I paused the print and tried to lower the nozzle via the Pronterface interface. However upon Resume the nozzle just went back to its previous (too high) position.

I decided to check if the Geecode was OK. I could see from the Ender display that the current height was 2.2mm. The part printed so far was also 2.2mm high. TO isolate the Z move G Code instruction, open a text editor and look for the string "G1 F600 Z". From that I can see that Z movements were in the correct order and the correct amount.

On Linux, use the grep instruction
grep "G1 F600 Z" CE3_camera_base.gcode | less

G1 F600 Z2
G1 F600 Z2.2
G1 F600 Z2.2
G1 F600 Z2.4
G1 F600 Z2.2
G1 F600 Z2.4

Where you can see the nozzle is at 2.2mm and hopping back & forth to 2.4mm.

My only conclusion is that the Z axis motor is getting wrong instruction, but why?

If the Z axis lead screw was dirty I could understand layers too thin because of binding, but mine is the opposite problem.

Any insight greatly appreciated

View Comment

Absolute beginner?

by Lee997

Just bought my daughter and Ender 5, 1st 3D printer and I know nothing!
Can anyone provide some good sites / forums to start please?

View Comment