Loading

Simplify3d Flashforge Creator Pro Left Extuder Issue

Please Login to Comment

When I print with the right extruder, the nozzle moves to the right of the bed to prime but when I use the left nozzle, it doesn't go to the left side to do the prime, it stays to the right and extrudes straight onto the bed rather than off the side. It also prints off the bed when I do large prints as if it hasn't offset the x-axis to account for using the left nozzle.

The test prints on the card work OK so it must be an issue with simplify3d?

Any ideas?

I have the original Flashforge(wood case version) and print with both nozzles all the time and have 0 problems. Follow the setup tutorial and pick the correct profile for S3D and your printer. As long as your printer firmware is still using the stock settings for axis offsets then everthing should match with S3d.

You should also check if your Flashforge firmware is relatively recent. You can check for updates using Flashprint.

I have the creator pro 2016 edition. I think they moved and end stop as now the left nozzle can't clear the bed on the right hand side, this in turn throws off the x-axis position causing the issues.

Also the profile for the left extruder has this line in it

M135 T0 ; load right extruder offsets

Which I think should be

M135 T1 ; load left extruder offsets

This is just how the Gcode is set up for nozzle priming in S3D. I fixed this by setting up different profiles for left and right extruder use (as well as dual extruder). The Gcode I use for the left profiles startup code is below. It moves the extruders to the left front to warm, then does the wipe at the left rear. I set it up this way to avoid the glass plate hold-downs that I have on the front left and rear right.

; Replicator 1 dual start.gcode
M73 P0 ; enable build progress
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; recall home offsets
M135 T1 ; load left extruder offsets
M135 T1; left tool
G1 X-145 Y-70 Z30 F9000 ; move to wait position left hand side of the table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M126 S[fan_speed_pwm]
M140 S[bed0_temperature] T0
M134 T0 ; stabilize bed temperature
M104 S[extruder0_temperature] T0
M104 S[extruder1_temperature] T1
M133 T0 ; stabilize right extruder temperature
M133 T1 ; stabilize left extruder temperature
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G92 A0 B0 ; zero extruders
G1 X-145 Y70 Z0.4 F9000 ; Position left head on other side at right height
G1 X-105 Y70 E25 F300 ; purge nozzle
G1 X-115 Y70 Z0.15 F1200 ; slow wipe in reverse
G1 X-100 Y70 Z0.5 F1200 ; lift across wipe area
G92 A0 B0 ; zero extruders
M73 P1 ;@body (notify GPX body has started)
; end of start.gcode .

At last, after 4 hours of wasted time, I have come across this golden internet gem. Thank you so much.

Have been printing with the right head for years, but the thermocouple just failed, so I need to get the left going. 34mm to the left, every single time, no matter what I changed.

One thing I notice, and I'm not sure if this is new to Simplify 3D 4.1, but now within a single profile it has separate scripts for each print head when choosing from the "Auto-Configure Extruders" list. So I can have one profile and then a script for the left and right heads. Brilliant.

Glad it helps. I use the separate script option in S3D also so that this startup sequence is invoked depending on whether I'm printing with the left or right nozzle. Or both, but I've kind of abandoned any dual nozzle printing due to quality and effectivness issues anyway.

This works excellent. I can't tell you how much I appreciate your efforts. Doing some fine tuning on a slightly older FFCP and this worked perfectly.

Perfect! I evens fixes the issue with the print going off the side of the bed. Would you mind sharing your other two scripts for the right and both please.

Glad it worked. The right extruder only is the default with S3D. The dual version is here:

; Replicator 1 dual start.gcode
M73 P0 ; enable build progress
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; recall home offsets
M135 T0 ; load right extruder offsets
G1 X150 Y-70 Z30 F9000 ; move to wait position right hand side of the table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M126 S[fan_speed_pwm]
M140 S[bed0_temperature] T0
M134 T0 ; stabilize bed temperature
M104 S[extruder0_temperature] T0
M104 S[extruder1_temperature] T1
M133 T0 ; stabilize right extruder temperature
M133 T1 ; stabilize left extruder temperature
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G92 A0 B0 ; zero extruders
G1 Z0.4 ; position nozzle
G1 X110 Y-70 E25 F300 ; purge nozzle
G1 X120 Y-70 Z0.15 F1200 ; slow wipe in reverse
G1 X110 Y-70 Z0.5 F1200 ; lift across wipe area
M135 T1; left tool
G1 X-145 Y70 Z0.4 F9000 ; Position left head on other side at right height
G1 X-105 Y70 E25 F300 ; purge nozzle
G1 X-115 Y70 Z0.15 F1200 ; slow wipe in reverse
G1 X-100 Y70 Z0.5 F1200 ; lift across wipe area
M135 T0; right tool
G92 A0 B0 ; zero extruders
M73 P1 ;@body (notify GPX body has started)
; end of start.gcode

Just had chance to try the dual version, one thing i've noticed is that the left extruder oozes a little onto the bed before doing the right nozzle wipe, meaning the 2 filaments get mixed together. Can you think of a better way to do the dual prime?

I saw a bit of the same thing. But, it's kind of the nature of the beast. I supposed it would be possible to shift the nozzles toward the back a bit before doing the wipe on the first nozzle, but that also reduces the printable area. This ended up not being a problem for me as I go directly to either a brim or ooze shield for printing and it sorts itself out.

That's fine, I usually do the same. Thanks once again!.

Comments deleted.