Filament Stops Extruding

Please Login to Comment

Hello, my filament keeps failing to extrude part way through a print. I can hold on to the filament and it pulls it through my grip so I know it's not happening because the filament gets tight.

The only way to get it to extrude again is to manually push the filament through hard by hand until it starts feeding.

Any ideas?

what model of printer do you have and what's your retraction distance set to?

I have a Flashforge Dreamer and the retraction settings are set to Simplify3D's default settings. I will have to check what they are specifically when I am able to a bit later.

Ran into an issue once when I made customizations where the retraction was actually pulling back past a "catch point" that would every once in a while not be able to get back through. So I had to figure out where that sweet spot was to keep it from pulling back too far, but not make my prints all stringy.

I was wondering on the retraction if it was causing issues, but it's set to the same settings I have always used which have never been an issue for me before. Not sure why it would just now cause problems, but it may be worth looking in to if I continue to have problems.

It appears though that this may be an issue with a particular model.

Does it only happen with that one model? Does it always fail at the same layer? The model could have a flaw.


Hello, I have tried printing other models and they seem to work fine. I am thinking it may just be a problem with that particular model.

I'm not sure what could be flawed or causing the problem in the model. It appears to fail at different layers each time, but gets an average of 1/2 to 3/4 of the way done.


If it is just happening on a single model try loading the STL file into Blender (open source 3d program) or any 3d program you prefer and take a look at the meshes for gaps or omissions (check the normals) then resave the STL file and try printing that.

It appears that it was just a flue that my printer was able to print other models fine. After further printing I got the same results on a different model. I found that the PTFE tube on my printer that directs the filament after it passes through the gear was messed up and bent and I believe causing the filament to catch. I replaced this tube and tried printing one of the models that was failing and it printed successfully.

I will have to test this further, but it does not appear to be a particular model as I previously thought.


Have you printed with any high temp filament, i.e., nylon or ninjaflex recently. When you change from a higher temp filament to a lower temp one, you need to flush all the previous filament out at the higher temp. Otherwise you can end up with previous filament particles that don't melt at the new lower temp. This can cause obstructions in the nozzle.


Never thought of that possibility, but no I've only printed with PLA lately and before that ABS.


Could be under extrusion. Check your filament diameter setting. A setting of 1.77 instead of 1.75 is enough to cause under extrusion and failed prints. Also, it is good to measure your filament diameter with a pair of calipers. Not all filament is created equal.


I checked the setting and it is set to 1.75. I haven't had the opportunity to measure with calipers yet, but I have printed quite a bit with this in the past without issue.

I did notice that when printing another model it worked fine. Not sure how a particular model would cause this though.

I think you have a small metal shaving in your nozz. I have a FFCP with 7,725 meter of filament on the odometer. PTFE tubes are just fine. I do occasionally floss the nozzle with stainless steel wire strands.

Gets things flowing nicely again.

Have you seen John Conner?

I am curious what led you to believe that specifically a metal shaving had made its way into the nozzle?
Regardless, it's not a bad suggestion to "floss" the nozzle or even just replace it. The nozzles are cheap enough to replace that I just treat them as consumables.

I am going to rephrase.

There is something clogging your nozz, thats larger than .4 mm and has a melting temp above your print temps. I assume its metal because it won't melt.
Things it could be.

  1. tiny shaving from gear that grips filament
  2. tiny piece of a wire if you were trimming wires near the machine
  3. one of the lost moon rocks
    4 cia listening device,

well it could be anything.
I don't recommend changing the nozz because its just one more thing to go wrong.

Take a 12 inch piece of stainless wire and break of a tiny thread. Then heat the nozzle up and remove extruder motor. Pass filament up the nozz then floss then always pull out the top. Do this several times. Most likely it will clear it.

I print carbon pla a lot and the nozzles still have not worn out. Thats why I love the FFCP, the parts just last if you know whats actually wrong with them.

I think it's great that you have a little experience to share with others, JMecky, but let's be careful not to be arrogant about it.

I did say I was curious why a metal shaving and your "not melting" part was answer enough. Also be aware that overcooked / residual plastic can become charred / ashed and cause a build-up over time in your extruder parts. The flossing thing is a great idea like I said, but don't be afraid to change out nozzles. This is actually another great solution.

Cooked plastic is actually much more common than moon-rocks. Inside some nozzles there can be a little reservoir where molten plastic pools while extruding. Over time this is one of the common spots where build-up occurs and changes the way your extruder works. This is actually something I've experienced that had the same results as you are describing. Plastic could still extrude through the nozzle, but it required more pressure than the feeder could give.

That makes sense, just like I said I wasn't sure if it was the nozzle considering the situation. I will change out the nozzle later this evening and try a new print to see if that helps sort out the issue. I will post back with the results.

I was thinking it may be a clogged nozzle as I've had something similar happen before. What I thought was odd though is that if I push the filament through manually it will start to feed for awhile again. This is why I wasn't sure if it was the nozzle or not.

I will try cleaning the nozzle. I may just replace it as a test since I have extra nozzles.


Probably as others have said you should try changing out the ptfe tubing. You might also want to give the teeth in your feeder a good cleaning as well. Over time the teeth collect plastic shavings that reduce its grip on the filament. This happens even faster if a clog causes it to sit there and spin on the filament.

Thanks for the reply. As I mentioned in another post I have the Flexion extruders in my setup and I don't believe they have a PTFE tube tube. I will check this out though.

It sounds like heat creep. Check the PTFE liner as the other poster said. Take your nozzle our and pull that liner out. Buy a new one from Flashforge directly. DOn't get the ebay/amazon ones or it may not fit without sanding (I found this out). Check if your extruder fan is working properly. Possibly reduce your retraction settings to no more than 2mm. Check your retraction speed, set it to default.

I'm not familiar with heat creep, but will definitely look into it. I don't believe I have a PTFE tube considering I have the Flexion high temp setup. The fan is working great from what I can tell. I will check the retraction settings, but these are set as the default settings currently.


I should of mentioned, but didn't even think about it. I have the Flexion extruders in my setup and I don't believe they have a PTFE tube tube. I will check this out though.