Recent Topics

several problems

by alan101

I have several problems that should be simple to solve but not sure how to do it. First the self level won't work so tried putting the limit switch in, not working either. Second the bed works the wrong way i.e. up is down & vice vrsa. Tried reversing it in rep host, no success. Just changed my desk top pc & now can't even connect to printer, obviously i've made a dumb mistake somewhere but ust can't seem to see it. Any help would be greatly appreciated, please keep it simple as i'm not experienced with printers yet, thanks.

View Comment

FLSUN CUBE F2 Bed leveling

by lukas_d1

Hi, i boughnt a few mounths ago a printer , but untli this day i had no time to configure it.
I have a problem becouse printer leveling z axis about 60mm below the nozzle....
when i choosing the option of leveling bed on the display, all procedure is on the same level (60 mm below nozzle) .
Leveling sensor is conected to the z limiter....

View Comment

Hotend temps swinging wildly

by doug_scott

Couple of days ago I noticed the temp being reported by the hotend thermistor was 10 degrees colder than the bed temp. Printer was sitting idle overnight. I had something to print, so I ran the job, it printed fine, no issues with temp.

Printer sat overnight again, next morning the temp was reporting at 3C, too low for the hotend heater to even turn on. It wasn't 3C in my office, it was 17C. I checked the connections by moving them around, the only reaction I got was from the thermistor right at the block, it would gain 4 or 5 degrees just by lightly touching the wires where they are at the screw. I wasn't touching them long or firmly enough to pass heat from my finger to the block, making the thermistor to report the increase.

I used my finger to get enough heat into the hotend to allow the hotend heater to turn on. I had to hold my finger there until the bed heated up, and the hotend heater turned on. Once it turned on and heated up to a point that I could remove my finger. I was waiting for it to hit 185 so I could use my pyrometer to check the temp and see if this was impacting the hot temps as well. Specifically looking to see if the hot temp was also off by 10 degrees. Something new happened, the temp was going past 185 to 191, then dropping down to 179 and repeating over and over.

I was planning on changing over to the thermistor that is inside the 3mm tube anyways, so I took it apart, changed it over, and also changed the heater as well. Put it back together, and noticed right away the temp was the same for both bed and hotend. I started it up for a print job, and saw that the temp was still swinging between 179 and 191. That prevented the print job from starting.

Since the thermistor was new, and was reporting the same numbers as the original one was, I figured it can't be that, the heater itself can't shut the power off it was receiving, so it can't be the heater, I am using a MOSFET, as well as a separate LED, and the LED on both the MOSFET and the one on a panel I have plus the one of the motherboard are all responding the same way. The LED on the panel is connected directly to the HE0 on the motherboard, along with the signal wire to the MOSFET. The only thing I could think of then was maybe the HE0 connections. Loosened the two terminal and removed the wires, inspected the wires with magnifying glass(I'm old and suffer from CRAFT). Could not see any issues, and looked at the terminal block on the motherboard. The one terminal appeared to be broken, I could not get the wire to go back into the opening. The little block inside that captures the wire wasn't moving.

I edited the pins_MKS_SGEN_L.h file and changed the "#define HEATER_0_PIN P2_07" to "#define HEATER_0_PIN P2_06", and I also changed the "#define FAN1_PIN P2_06" to "#define FAN1_PIN P2_07", simply because I didn't know if the first change would cause an issue or not. Saved the changes, rebuilt the firmware and deployed it. I sent M502, and then M500 to clear the EEPROM of the previous firmware. I moved the wires from HE0 to HE1, and ran the printer. I am now using HE1 connector and the result was the same.

Here is what I get now:

Temp is set at 185C
The LED on the MOSFET, control panel and motherboard are on steady until 183, they all start flickering rapidly, temp goes past 185, LED's goes out at 187, temp climbs to 191 before falling slowly. Once it hits 185 the LED's start flickering rapidly, temp continues to drop to 183, LED's are on steady now, temp continues to drop to 179 before starting to rise again. Cycle continues up and down, print never starts due to this.

I have tried about all I can think of. The printer was working properly up until the thermistor showed a temp too low to start the heater. That part is fixed, the temps are being reported correctly now, just not staying steady.

HE0 HE1 thermistor
View Comment

External Mosfet


Hello everyone!

I`m from Brazil and I have a FLSUN Cube, my onboard mosfet is not working...I read on other topic that a guy said that we can connect a external mosfet to an other pin on the board and modificate the marlin to works with this pin, Could someone help me? (sorry about my english)

View Comment

It Lives!

by Grievousbee

So after having the Cube off the road so to speak for about 6 months now I have finally got it back working with a few nice upgrades.

Finally got the heat bed insulation installed after having that hanging around for a year or so and while it was off I took the chance to remove the springs and replace them with some rubber bung type things.

Also installed a pei sheet thingy on the top to replace the blue (green in my case) tape. Unfortunately its self adhesive so it'll be a real PITA to remove when I have to.

Have replaced the standard and printed extruders with a couple of Bulldogs ( I'm running Chimera currently BTW) and these are a lot more accurate on the feeding now.

Now for the big bit. I have replaced the standard MKS Gen L board with a BTT SKR 1.4 32 bit board and also added the BTT 3.5" touch screen as well.
The steppers are now also DRV8825. Wanted the TMC2209 but cant afford them just at the moment.

Currently printing the first part on the resurrected thing (an x-y-z calibration cube of course ) and it all seems to be going fine. Its a lot quieter with the DRV8825's in would be quieter with the 2209 though.

It wasn't all plain sailing though as I have removed the standard inductive probe and have enabled manual bed levelling (as i want to install a glass bed at some time), and this was a real problem.

Got manual bed levelling on the Ender 3 which has been upgraded with the BTT SKR mini E3 and touch screen. Enabled and worked on that no problem.
Could I get it to enable on the SKR1.4, could I heck.

Ended up having to download the latest version of Marlin 2,, and redo everything, lo and behold it worked. No idea why the version that I used for the E3 didnt work though.

Now all I need to do is get my head around how to make 2 colour prints.

Carry on printing and be safe everyone.

View Comment