Loading

FLSUN Prusa i3+ Large print end stops not homing (SOLVED)

Please Login to Comment

Hi everyone

I'm finally reaching out regarding an issue im having with my printer among many that have with this printer, so far i've corrected many. One problem thats persists regardless of me using the marlin software provided from FLSUN. I'm using this printer as a single extruder machine, and when I request auto home on all axis they all work excluding the X axis. Even when I request only the X axis to home it moves a couple of inches towards the end stop and stops never nearing the the endstop. If any one can point out where the problem is and how to correct it, it would be much appreciated.

Thanks

Somehow my text looks all distorted, not sure why, sorry about that :-(

Not sure if your issue is the same as mine but it looks somewhat similar. Here is what I posted in another topic some time ago :

I had exactly the same issue. It took a couple of months before mine started playing up with this issue. I suspected it was the X-endstop but was not sure how to best solve it. In the end it was the wiring of the endstops. The wires are straight and run close to the wiring of the stepper motors. I noticed when I moved them away as best as I could from the wires of the stepper motors, the issue reduced but did not disappear. I found this video on youtube ( https://youtu.be/ENGq_jw1EQQ ). The video is about a different printer but has exactly the same issue as I had.

In the end the resolution is twisting the 2 wires of the x-endstop. This is a well known method in electronics to reduce interference from outside sources. Proper telephone wires are twisted and so are network cables. It resolved the issue straight away and it never returned. You can, but do not need, twist the wires of the y-stop as they do not run close to the stepper motors or their wires.

Eventually the issue I had was coming back now and then. What reduced it a lot again is that in Marlin 1.1.9 there is a setting that where the printer tries to ignore the noise it receives on the end stop switch cable. In the configuration.h file you will find :

/**

  • Endstop Noise Filter
  • Enable this option if endstops falsely trigger due to noise.
  • NOTE: Enabling this feature means adds an error of +/-0.2mm, so homing
  • will end up at a slightly different position on each G28. This will also
  • reduce accuracy of some bed probes.
  • For mechanical switches, the better approach to reduce noise is to install
  • a 100 nanofarads ceramic capacitor in parallel with the switch, making it
  • essentially noise-proof without sacrificing accuracy.
  • This option also increases MCU load when endstops or the probe are enabled.
  • So this is not recommended. USE AT YOUR OWN RISK.
  • (This feature is not required for common micro-switches mounted on PCBs
  • based on the Makerbot design, since they already include the 100nF capacitor.)
    */

    define ENDSTOP_NOISE_FILTER

By enabling the ENDSTOP_NOISE_FILTER line, you reduce the risk of falsely triggering the X (end the Y) endstop. Allthough the real solution seems to be to put a 100nF capacitor across the switch. I haven't tries that yet.

Hope this helps!

Michel

Here are some thoughts.
Have you triple verified all end stop switches work AND verified end stops are correct for each direction?
Post a link to a video so we can better understand.
Is the motor hot?
Have you swapped the cables with another motor eliminating a cable issue? (I had this on another brand, bad parallel Z cable)
If you issue move commands from the display, what happens? Does it move unimpeded (ie more than two inches)?
Can you issue a move command (toward home), then before the move is completed quickly hit the end stop on X with your finger what happens?
If you swap the wires to motors X and Y, then home Y, what happens?

Thank you for the video.
Is the extra (doubled over) x belt hitting the end stop before the extruder housing does?
Are your part cooling fans hitting the Z brace?
Is the belt getting wrapped around the pulley causing extra motor drive resistance and the "mega2560" Board senses that and stops the movement?
If you remove the belt from the motor does the situation still happen?
If none of that is happening, I'd swap the X end stop with another endstop because of your answer below. **
See ~~ below

Use M119 to check if you have the X endstop wired and configured correctly

i get no reaction from the printer when i send M119, this is my configuration.h file

I'm not sure why M119 is not working.. if it is possible to trigger the X endstop with your finger by holding it down, does homing X move the carriage farther?

i held down the end stop when i try homing x it just moves it 1 inch away and stops even when i continue holding the end stop pressed

~~ From above.
Holding the end stop closed having no affect almost has to be a bad endstop, right?
This is puzzling. Hopefully we can figure it out.
Can you swap the X and Y end stops? OR, you can even just swap the plugs on the board and Trip the Y when homing the X. If that's confusing, please just swap the actual end stops.

Good news everyone i found the problem

The situation was that the endstop switch and wiring was 100% ok, BUT i checked the Board and the pin out was loose (cold sauder), once I got out my trusty saudering iron and heated up the lead for that pin out, I did a homing on the X and it started to work correctly. (THANK GOD).

Thanks everyone for your input!!!

Now back to printing

So glad you figured it out!!

I wonder if you could add the word [Solved] to the title