Loading

Nonfunctional y- axis connection

Please Login to Comment

I just got my printer finished assembling it all the motors work I tested each one and the wires all work but for some reason my y-axis when I send a command it turns on and locks up until I turn off the machine I've tried the wire and motor on the X-axis part of the board and it works fine not sure if it's a hardware or software problem any guesses?

edit oh.. yes.. exactly like those videos no doubt explain :)
/me punches the thingiverse forum format in the face several times
The other thing it might be is a stepper motor that has it's voltage "pot' turned outside of a useful range.
They each have a tiny potentiometer on them that controls currernt and thereby how they respond to signals. If they are outside the useful range for whatever they are trying to push they may not move, or may move badly and be very noisy.
Typically this happens when you put two nemas on one Z driver channel. In that case you increase the current till it's roughly twice normal, or until both work as expected... very few people probably ever use a voltmeter till after the fact. You typically just move the carriage by menu or gcode while adjusting the pot until it sounds right.
The gcode M906 tells you what is currently set too btw.

A NON METALLIC screwdriver is the only thing you should use on these 'pots' unless you like smoke and fires.
Print something or cut a little bit of wood/match and taper one end like a screwdriver.

Any other ideas?

I'll try that but I tried using a diffrent driver maybe the y axis needs higher voltage I have no clue at this point

The driver trimpot being mis-adjusted seems like the most probable cause.

The pot is not the problem I tried it and adjusted the driver any way I could with 0 response

I'll try it today and keep you posted thanks for all the help guys it's been a 2 weeks and customer support has yet to anwser lol

how did you test it? did you switch the stepper motor controllers? maybe the voltage is under/over powered? you can check this video i made. its kind of long but... it might help
https://www.youtube.com/watch?v=dQyZyFBXcsE&index=8&list=PLc-laZ82tODxofx1yxAmfjMta09U3DK3J

I tested the motor by using it on the X and z axis and it hasn't worked I have yet to test if the driver chip is faulty

I thought I wrote it here, but evidently not.
On the i3 mega's trigorilla board, the second Z axis motor is wired into the E1 channel. This is normal for this printer, and firmware is set to make it work.
So for the Z axis to work it has to have one cable in E1 and the other in Z on the mainboard (Z being the only axis that uses 2 motors).

I only have 1 motor for Z I didn't get the upgrade and thanks for the picture of the chip I will see if it's properly seated and test if it works in another slot if not it will be a huge time and money saver so thank you I will have to check when I get out of work

DOH
I thought I was posting in another group, about another printer. My bad. Disregard anyhting I said about the i3 mega.

The direction of travel can be reversed in firmware as well as by flipping the connection at the board, or (less easy, but possible) at the nema connector.
....So depending on what firmware you have, and who did your wiring, there can be 3 ways a motor can run the wrong direction. You just need to check them :)

The problem isnt the direction it won't move at all it turns on and locks up won't move at all

Nobody has mentioned the possibility of a fried driver yet (I thought they had), so if the motor works on another channel, like E1 or X or whatever, then try swapping the driver chip into that working channel.. if it fails then just go and buy a new $2 driver chip.... or three.

I tried switching the driver chip it did nothing at all the y still didn't work and X did even tho I swapped the chips

No clue what a driver chip is I'll look into it also I did all the wiring and have tried diffrent wiring and "channels" X-axis it works perfectly so I will try to figure out if that's the case tech support hasn't replied at all and it's been 4 days I'm quite dissapointed in them

So like I say: check your wiring. The supplied diagram may be backwards due to firmware differences.
Check, test, check, test.
It's a printer, they are fairly robust, so if it locks up and sounds ugly just hit the power switch and try something else.

Same thing happened with mine. The wiring was reversed in the wiring diagram. Try flipping the connection on the board end (red, blue, green black instead of black, green, blue, red, for example). The polarity is reversed so it's going in the opposite direction (I'm no electrician but I think that's what's going on). I've even had some wires that weren't the same on each end (blue on one end of the connector, green on the other end) so I've had to pull the wires out of one end connector and rearrange them.

Comment has been deleted

I have and the order is red blue green black I have tried using another motor and wire and they don't work but the wire and motor work on the X-axis control slot but somethings wrong with the y-axis