Loading

A novice and a printer:

Please Login to Comment

Recently I purchased and assembled the FlyingBear P902 printer. I have, however, run into a series of problems that are preventing it from achieving functionality. They are as follows:

Issue #1: Upon completing the construction identical to instruction I've found that the Z-axis motor is positioned so that it prevents the build platform from raising to meet the nozzle, instead there is a few centimeter gap. Raising the motor out of the way would appear to be the best solution, but this would mean the drive belt becomes to large for the relative distance. Another alternative could be to attach the motor to the front leg of the frame, having done the wiring already this is not a preferred option though. Any thoughts?

Issue #2: I've had issue with the movement of the axes. Especially the Y-axis. I attempted to move the print bed through the menu but limits the amount to 220mm, which is far from the correct amount as the plate doesn't even get above the midpoint. Think that it was perhaps a firmware issue I uploaded an alternative from this site, it hasn't however fixed the problem.

Issue #3: Lastly, (for now) the extruder fails to extrude. Using again the menu interface I tested the ability for it to extrude and though the filament shook nothing came out the hotend.

Regardless of these issues I'm excited to get this printer running! Any comments, suggestions, and (best yet) solutions would be appreciated! With profuse thanks in advance, Alexander.

pictures would help. do you know how to set the sizes in the firmware? can you see what the default numbers are on the firmware you uploaded? why did you change the firmware?

the firmware i was told to use back in november of 2016 is
https://www.thingiverse.com/thing:1870021
but you need the old arduino. 1.06 i think.

but it is the default firmware with thermal runaway disabled. so you will have to modify it. or you can use the alvares modified firmware.

Flyingbear-P902 Firmware
by xbqllc

Hi! Let's get started:

Issue 1: Re-check the assembly instructions, compare with assembled pictures (the instructions can be easy to missunderstand, happened to me)

Issue 2: (Make sure Issue 1 has been solved) Upload this firmware https://www.thingiverse.com/thing:1897437/#files (Marlin 1.1.3) and make sure to restore EEPROM and then save EEPROM.

Issue 3: After issue 1 and issue 2 are fixed; check if your hotend is over 160 C BEFORE trying to extrude, the firmware won't let you extrude if the hotend is cold. If this doesn't fix the problem check this topic https://www.thingiverse.com/groups/flyingbear-p902/topic:18535

Hope it helps!

Marlin 1.1.9 & Repetier v92.9 Firmware FlyingBear P902 Multilang

Greetings! Thank you for the response(s). I have made some progress on some issues and none on others. Allow me to address them in order.

Issue 1: I did recheck the instructions, consult internet pictures, and applied as much common sense to the motor problem as I could, alas I got nowhere. In the end I've moved the motor up out of the way and adjusted the size of the belt accordingly.

Issue 2: I downloaded the firmware (Marlin 1.1.3) provided by your link. Praise to the developer for that one. I believe I've followed the directions accurately, but still fail to figure out how to restore and save to EEPROM. The only option related to it I can find is "Initialize EEPROM" and upon selecting it nothing happens. Perhaps it's just not a visible or audible reaction?

Issue 3: Embarrassingly I must admit that this issue arose purely because I wasn't inserting the filament far enough into the extruder. Since discovering this and shoving the filament in with slightly more aggression, the filament comes out the nozzle in a melted state. I have yet to figure out how to extrude without pushing it through though

I appreciate the support and advice a ton! Also, for putting up with my slow learning curve. Once again, profuse thanks.

re: 2) yeah really. Very few people actually tell us this, but one of the single most useful things to know about a new firmware is that you need to "restore failsafes" in order to pull the new numbers out of firmware, and then make the machine remember them by saving them to eeprom.

3) use 180 for PLA, just to be sure it extrudes.