Loading

Smothness of STL output

Please Login to Comment

Can anyone tell me, if there is a way to refine the freeCad drawings.
For example if i create a circle shaped object the circle itself is parted in kinda even segments. Many sliced notches or bevels in a circle, for example, result in zigzag slice result. See link.
The only compromise i figured out, is to import it in blender and smooth it by increasing the faces. At least lot of additional work :(

https://www.dropbox.com/s/7xncx7thj6yy7vh/Bildschirmfoto%20vom%202016-09-28%2019%3A36%3A18.png?dl=0

Comment has been deleted

This effect is called tessellation and is part of translating a shape into a mesh (STL file). You can setup how fine or course your result should be and it affects greatly the resulting file STL file size. No need to use an external program like blender to post process the mesh.

In FreeCAD you can control this in two ways:

1) When your document is open in Part Design got to FreeCAD settings and select Part design/Form View/Max deviation. I believe the default is set to 0.1%. You can set it to a tighter deviation e.g. 0.01%. When exporting to STL this value is used for the tessellation.

2) Another method is that you explicitly translate your shape into a mesh within FreeCAD: select your shape and go to the Mesh Design workbench. Select in the main menu under Mesh/Mesh from Form ... then you can choose different tessellation strategies and settings. After the mesh in generated export this mesh to STL.

It is easier to go with 1) but if you have more designs with different needs it is better to set it up like 2). With 2) you can save different meshes for prototyping or manufacturing, Some people like to use a corse tessellation as a design effect etc...

I see #1 this is the most simple method. Also all inside freeCad. i just played with it.
Am i wrong that in #2 there is a conflict between tessellation in Mesh design workbench and later export? First i set a "resolution" in Mesh Design and than i overwrite it with the export settings IMHO. As i see Mesh design workbench can't produce a stl for later slicing.

2) is no issue, since you can directly select the Mesh part and export to STL from the Menu (Alt-E). Since it is a mesh the Part design settings are not applied. There is no conflict :) and it works for me like that.

Comment has been deleted

In the part Workbench, part menu their and option call "Refine Shape" which would try to simplify your selected model, also you could re-import your exported stl and used a bigger tolerance.... but it seems more related to the design... did you produce this circle using a polar array? I've made a lot of curve object(look at my design) using free cad and never hit this issue... if your part is really small (mean really small) it could be related to the precision decimal.... if freecad see it really as a circle, one option is using draft wb's clone option, size x 2 export stl.... and print it scale at 50%....

The easies way to help us to help you, is (if you can) sharing the freecad project file, on which version you are working, platform, etc.

You can also decrease the deviation value in view settings inside combo-view panel.
Just mark the object or body and klick the view tab.
This works for export also.

Perhaps trying your luck with netgen mesher and playing with the parameters ?
http://www.freecadweb.org/wiki/index.php?title=Mesh_MeshFromShape

This is fine too, but at the point i export it to stl, the export settings described by sey7278 will overwrite the outputs resolution.

you have to go into the "Mesh Design" workbench, then go to File -> Preferences -> Import-Export -> Mesh Formats and decrease the deviation.

it takes the same print time according to my slicer, although the STL file is almost 3x the size when i change 0.1mm to 0.01mm

Thank you for this quick and useful response :) Sure setting finer than the printers/slicers resolution makes no sense.