Loading

Cura not printing with second extruder

Please Login to Comment

Ok so whats happening.

I slice my file in Cura,

right click and select what part for which extruder, than merge the files.
Prime tower is enabled and in correct position
I check layer view and it only shows as extruder 1 printing everything.
sure enough this is what happens when I try a print, Entire print is done on extruder 1.

both extruders work because test prints that cam on sd card worked fine

What am I missing here ? any help would be appreciated

Thanks

Yes,I had the same problem. I put a few lines in the startup code to fix this problem:

M163 E0 P1.00; Set Left to 100%
M163 E1 P0.00; Set Right to 0%
M164 E0; Save Mix

M163 E0 P0.00; Set Left to 0%
M163 E1 P1.00; Set Right to 100%
M164 E1; Save Mix

It's working fine now. Make sure all the calibration numbers are the same for each extruder and it should work fine.

where did you put this gcode?in the left extruder and right extruder tab?or in the printer setting tab?
and what do you mean by calibration number?

I found that Cura 3.4.1 works best for this situation. I have attached some screen shots of my settings. The calibration numbers I am referring to are on the main screen. I ensure that the settings are identical for both extruders by selecting each one and running down the list. I change settings so often that I might have the wrong speed or infill setting from one extruder to the other.

thanks man,but im using the latest cura,i tried your setting on 4.4.1 cura,see if it can get ir right.thanks man again.

Since your using the latest Cura, watch the series of videos on setting up for the A10M.
https://www.youtube.com/watch?v=N9x9de4nYI8

Since your using the latest Cura, watch the series of videos on setting up for the A10M.
https://www.youtube.com/watch?v=N9x9de4nYI8

thanks again.im really frustrated using cura, so now im using repetier host, its away better than cura.i dont know why my E1(second etruder) cannot extrude normally,its like been underextrude, even though they share the same hotend,

Just out of interest, check the settings for the Standby Temperature in Cura. This sometimes defaults to 175. Cura will think there are 2 separate hot ends and will lower the temp for the 2nd extruder while not in use. Then once it receives the command to flow, its not up to temp and can cause all sorts of issues.The standby Temp should be set to the normal operating temperature to avoid this issue.

yeah maybe this is the problem because i realised that the temp got down when it change to another extruder.thanks!i already change the value of standby temp in 2nd extruder tab.yeah,this is the cause of my failure.

Did you figure this out? I don't have my machine yet but I have been playing with CURA 3.6 using the A10M profile and it appears that I am seeing the same thing. I have made the adjustment so, that each extruder has it's own independent material but again it appears from the slicer view that only one extruder is really being used. Thanks!

I just played with 3.6 and loaded a 3 color benchy. for each of the segments choose one of the extruder icons on the left to assign to that segment, 2nd part to next extruder and so on.

I know this is an old thread but I wanted to thank DarkTreader for the info. Your screenshots helped me get going with my A20M printer. I also did not realize that you could add a combination of extruders with color mixes for as many colors as they could make between the two input colors. This also solved my one extruder problem I was having using Octoprint - now it works fine!

If you are still out there (or anybody who uses these printers) what is the best setting for a prime tower? I can't seem to get that just right.

not 100% sure on the settings, at the moment I'm trying to get things set up to use a prime bucket/chute to eliminate all the wasted filament since with a tower you still have to print it while using the same color during layers that don't have multiple colors.

Yes I get that, but now go to layer view and select each extruder separately, this will show you what it's actually going to print with.

I'm guessing thats the key, is selecting a pre-set machine that already has multiple extruders.

well its the only thing that worked for me anyways.

what Printer did you select ? when I made custom spot for A10M it was not working.
So I selected Raise 3D dual.... and now it works.... so not sure why its not working when creating my own

I created the A10M printer with following settings

@DarkTreader, if possible can you please put some more pictures for Cura slicer configuration for the Geeetech A10M. (Virtual Extruders like you created. (Extruder 1, 2, 3, 4 and 5 and main configuration screenshot)
Thank you

greeting DarkTreader, can i see you left and right extruder setting for the gcode. I had a problem with multi color printing, maybe its gcode start code for left and right extruder

Thank you for your effort again.
Regards

OK I'll play with it. Everything looks good until you look at the layer view when I can see both extruders work on the skirt but the actual print looks like it is just prints from extruder 1.

Layer View vs. Solid View:

This is the same thing I am getting,

BTW, I have been using Cura for about 6 years, I know this software inside out, This is why it's so puzzling.

Just select one of the preset Dual extruder printers from the list and adjust profile and be done with it like I did, I know it's frustrating and it should work with using a custom set printer.
I have spoke with Ultimaker and they have acknowledged there is some type of glitch or something going on with the software.
I'm not sure where on there priority list this sits, but I wouldn't get your hopes up.

best case for now is just choosing another dual extruder printer from the list.

un-select the nozzle you don't want to see. the yellow might be selected as the outer layer

Everything aside, I am curious why you have set yours up with 5 extruders ?
doesn't seem like something that was created for a A10M.

1 & 2 are their individual colors, and 3-5 are blends, 3 is 25/70, 4 is 50/50, and 5 is 75/25 since we have a mixing nozzle were not limited to just 1 or 2.
M163 S0 P0.25 25%
M163 S1 P0.75 75%
M164 S2 assign this as extruder 2( 0,1,2,3,4) since the first extruder is #0

Oh that is frickin' cool. I'll give that a try as well. Thanks!

Nope... I tried that. This is what you get:

is your model comprised of two parts or just 2 colors? try this and select all three models then merge. if it was two parts you might have combined them vs. merging them

Yes, it is 2 separate parts that were loaded separately into CURA, assigned different extruders and then merged together.

https://www.thingiverse.com/thing:2801124

This evening I'll load in a different dual extruder printer profile and see if that changes things. Thanks for your help.

Calibration Cube (DUAL EXTRUDER)
by maus3d

hope I helped, I'm fairly new to having to set all the settings myself, had a plug n play before and that got too limiting and boring. So hopefully I'll get over the bump and get some great prints soon.

I've been using CURA for over a year now with my other (2) 3d printers so, I'm fairly confident using it. The A10M is new to me (in fact I still don't have it in my hands) so, I was trying to see how CURA works with the dual extruder. I was fairly sure what I saw in the Layer View was incorrect that is when I ran into this post.

I just received the machine, have it built and it's printing the included lizard file. Once, I get past the testing I'll start playing with CURA again. I also need to upgrade the firmware to allow the Geeetech's version of the BLTouch. I've always upgraded firmware via CURA and USB but it appears upgrading the FW is a bit more complicated.

BTW: The build quality is decent but not stellar. Also on my machine the quality control is probably average from the factory. I had several things that need adjustment but with 1/2 hour or so of tinkering everything is adjusted and tight. There was aluminum shavings from when the extrusion was drilled/cut. Some of the holes were not drilled perfectly and need to be reamed out a little to get things bolted up. The electronics box had dust in it, like it has been run for quite awhile at some point. Also, the electronics case fan is shot right out of the box and again has dust on the fan blades like it had been run.
None of this is earth shattering and probably is to be expected on most of these import machines.

I'm not a wiz at Arduino but it wasn't hard, you'll want to load up the BLTouch file into the FW update, find and adjust the offset for the left corner, and set bed to 235x235 vs the default listed, there are a couple other settings you'll want to adjust including the steps for the extruders.

OK I'll holler if I get lost along the way. :-)

if wanted I could also post the modified file that I updated with the changes

That would be awesome and would save me some time/hassle.

On a side note, I'm not sure why my other post is "flagged for moderation". I added some pics of the printer working on the lizard so, maybe that's the problem??? In any case, I've got the machine up and running and the initial lizard print looks decent.

coolness, I'm waiting for a couple warranty repair parts to come in tomorrow so mine will be up and running. My cooling fan didn't work so the lizard nose kept curling up and getting snagged on the extruder messing up the print.

This thing is cool! I've been printing the lizard and dog files that came on the SD card most of the day. The prints are VERY good quality coming off of the machine and the dual color of the lizard and gradient of the dog certainly add the WOW factor.

Got a couple mods printing on my other machines and will dive into CURA settings, BLTouch and firmware in the next day or two.

looking very cool, DHL shows my parts are between Ohio and Texas...lol keeping fingers crossed

OK I updated the firmware and got the BLTouch set-up properly. Pretty straight forward once you jump in and get going on it.

I'm playing with Cura and somehow between loading, creating and deleting various profiles along with machines, I now have something that looks like it is slicing correctly. It's vanilla right now with the (2) extruders and I'll leave it that way until I make sure everything works as it should. As suggested above, I'm looking forward to adding extruders for the various blending ratios to customize some colors down the road.

Comment has been deleted

Sorry, didn't see your post till now, What file did you try to print? if you go into materials you can duplicate the material you are using and assign different colors to each filament then when you designate which extruder is which piece you can visually see the difference. what probably happened is you assigned the same extruder to both but hard to tell when the program only shows one color.

Comment has been deleted