Loading

Hi,

Please Login to Comment

I thought i'd just say hi, i was about to startup a group for my new 301 and it recommended this, i've been using 3d printers for nearly 2 years and have a lot of knowledge with cartesians but this is my 1st delta and i'm struggling to find much online about problems and solutions.

It'd be nice to share what problems we have and how we come to fix them, Ill be doing a lot of testing over the following weeks and will document anything i find.

Damien

Hello I buy geeetech Rostock 301printer but it not printing well. I have questions 1 how to level endstop because my nozzle is not moving in perfectly linear motion

Hi,
I am a Newbie on the Geeetech Rostock 301, but not a newbie on 3D printing. I own a Flashforge Creator Pro, with which I get really good results. My desire for 3 colour printing brought me to the Rostock 301.
The assembly went smooth, but then the success story stops. When trying to home the printer one of the carriage does not hit the end stop and then the other two continue until I either switch it off, or trigger the missed end stop. The carriage is just not going high enough. Is this also an issue, that the stepper motor voltage could fix? I have not played with that yet. Where do I measure the actual voltage?
I have also heard about counter weights on the belts, opposite to the carriages, to reduce the stree for the motors. Is that something you had tried, yet?

Thanks,
Frank

Comments deleted.

Yes increase the voltage to the Potentiometers that control the motors, this allowed me to print without the steppers skipping anymore, i didn't actually measure mine i just started a test print and increased the voltage one by one until it stopped working then reduced it down a little and they've been great since.

I agree with D4M, as i had an issue where one rail could not get to the top. I used a voltmeter, it is awkwsrd but i turn the printer on its side (no filament) leave it disconnected from the computer but turned on, and use a voltmeter on a scale that will read up to 2 volts. I touch the negative lead to the usb connector metal shell and touch the tip of the positive lead to the potentiometer where you would stick the screwdriver to turn it. Right now my 3 carriage steppers are set to 0.85 volts and the 3 extruder voltages are the max i could get which is around 1.09 volts but i have seen some folks report the max they can get is a bit less than that, like 1.04 volts or so.

Comments deleted.

I can never print faster than 10mm/sec. i added an oiled foam thing at the top of each extruder as my printer is in the garage and dust was a pronlem. The filter snd a little olive oil helped a lot (high smoke point oil). The prints seem just fine even with the lubrication. I set retraction to 5mm and a very fast speed. It helps a lot but does not completely eliminate the stringing i alwsys have to do some cleanup.

Regards,
Chris

Comments deleted.

I have them at the max i could get on the potentiometers which is about 1.09V. I might be able to extrude faster and go at 20 especially now with the olive oil lube and dust filter but i am being cautious. I also need to get a better slicer, slic3r gives non intuitive and kinda stupid paths that have too many moves for no good reason. This is not a serious printer but i look at it as a learning opportunity. Good suggestion on the filament bearings i will do that next

Thank you all for your comments and advice so far.
I've now managed to get a print completed (if a little ropey, lots of stringing and over extrusion), i adjusted the voltages on all the pots to the maximum i could this resolved the issues with the steps skipping on the axis and the inability to drive the filament through( i also changed the extruders to all metal designs with adjusters for the tension) I've modified belt holders for a better more adjustable version that i printed on my other machine.

i'm not sure if i have a 0.4mm nozzle or if it's different, and i'm not sure how to check ( i'm guessing i could just heat the nozzle up and push a length of filament through then measure the output size for a rough idea)

i guess i just need to put some time and effort into printing and testing now knowing it's just small settings tweaks to make rather than and hardware issues,

on a side note, i've had a small issue with my gcode, i've never experienced this before but on the 301 i have failed prints where it just stops and using http://jherrm.com/gcode-viewer/ it's the gcode itself, now i've never had this issue with my CTC, does anyone know if this is a problem with simplify3d or if its an inherent problem with Deltas in general?

Maybe try a different flavor of gcode generator, i used slicr with the reprap "flavor" or style. Gcode has a ton of variations and so there was probably a command that got sent to the geeetech that made its gcode parser barf. What was the last status message you got before it stopped? That may tell you what the offending command was. This is just my guess...

No status message it just stopped, I've had smaller, i'd rather not have to change slicer after paying for Simplify 3d, all of my knowledge on settings are with this program (i'll give ti a try mind as it'd be nice to know if it just a simplify 3d issue or something deeper).
once the printer stops it just won't do anything, i can't even issue a stop printing command, i have to turn off the machine via the power switch and then turn it back on and home it.
i'm at a loss but like i said if you put the code into that website i linked it shows it stopping also. if i then change the machine to my other and reslice and print it works without fail.

Interesting, so there must be a command that geeetech crashes on. Your CTC must be more robust. I would like to see that gcode.

Hi Chris, Sorry for the delay in replying i've been busy with work and not had time to work on this crappy machine i've spent a few hours on it today and after calibrating everything i tried to print a large print again, same things happens as with any larger print it just stops randomly, i'm at my boiling point with this thing, so i can print a 20mm calibration cube with no issues ( apart form the quality) but i tried to print an upgrade to add a fan to it (this part https://www.thingiverse.com/thing:2253022) but again even before the 1st layer has put down it fails, i restarted and it failed again, this time a little further along. this is the code i created with S3D for you to look at http://jmp.sh/v/9ZF7MAfXVvlw2GSuGg6f any ideas?

Geeetech Rostock 301 fan
by MB3Y

I will take a look later today, it will be an interesting mystery to try to solve. I will run it on my printer too to see what happens

Thanks, I've been working thorough the problem with Phr3d13 over the last hour and still not closer to finding out what's going on, i've even tried using a benchy he sliced himself and has used before, that print failed at 1/4 into the 1st shell on the 1st layer, then i ran a larger print i sliced last week of the mother child figurine thats been making its rounds on thingiverse and i'm currently at 7% printed and it's looking good. i guarantee it will fail before it finishes tho.
Edit, it failed at 13%.

It runs on my printer but the extrusion is so anemic...almost non-existent. But it does not stop, for the first layer

Oh ok i will try running your gcode again to see how it goes up through 13% right now i am running the part from the stl sliced with slic3r

I'm thinking i have a dodgy board, I've contacted the seller to see what he recommends, the fact that it's random where it stops and sometimes fails points me in the direction of an intermittent fault possibly memory based, I have tried a new SD card just incase it was an issue with that but that didn't help, it kind of reminds me of faulty memory on a pc when it sometime uses weird hangups and even BSOD's on windows machines. I'll keep you posted on any response i get.

I tend to agree, it may be your board. Here is the gcode I ran from that stl pretty successfully except for the annoying stringing which I will have to clean up. http://jmp.sh/DORLWlr

Also, I had to rotate the original stl to get it oriented right for printing 90 deg on x followed by 60 deg on y to get it to sit like your on the bed. Here is the print image: http://jmp.sh/cv7nncz

Thanks for taking a look at that Chris, I'll try your gcode tonight once i get home and let you know the outcome, I'm leaning towards faulty hardware at this point, I know i'm new to deltas but i've 2 years of experience with my cartesian and have rebuilt and extended it with problems that have been resolved, this is just something that seems too intermittent to be anything i'm doing wrong.

I have not used the sd card interface. Is that how you print? Maybe the sd card interface is what is messed up? In any case a new main board may be warranted. Let me know where you find a replacement i am looking to buy a spare but 6 axis controllers are not common.

I don't plan on paying for a replacement, i've only had the printer 2 months and as far as i'm concerned it was defective upon arrival, i've been patient with keeping trying but i'm going down the route where they replace the board. I'll keep you updated.
on a side note there are a few 6 stepper controller boards out there, the only issue with them is cost http://www.ebay.com/itm/RepRap-Rambo-1-2G-3D-Printer-Control-Board-/112369141917 is one i've been looking at as a potential replacement for my makerbot clone which i want to convert to the diamond hot end.

I reran your original gcode and i know one problem is it tries to print too fast. My xyz axes jumped steps and that screwed up the print, on the second layer. Also the first layer is at 0.175 mm but that makes repetier show the coordinate in red which means the printer reported back a position different from what it was commanded. That is probably not a big deal but the speed is too fast at least for my printer. Here is a picture of what happened.... https://jumpshare.com/v/0CJk3cFCiFgYMWf2xCQn

Note how it shifted in y about a half inch due to the loss of steps.

Interesting, What speed do you run your models at, i used to get shifting when i first set the machine up but upon increasing the voltage on the pots it resolved this issue, i wish mine would print even that, on that print it doesn't even finish the 1st shell before just freezing and having to be reset.
on a side note, i've requested the seller contact me over the weekend but no reply, so yesterday i initiated a return on eBay ( i don't want a return just for the seller to respond with a solution,) the good thing is now after 13th june eBay will get involved if i'm still not having and contact from the seller.

I hope you can get it resolved. I print at 10mm/sec. i might be able to go a little faster. I did put a UPS to ensure power glitches did not interfere. I have had that happen and also even one time i turned on the work light at my work bench and it made the printer stop. That was odd but it only happened once.

That's interesting, i never considered any fluctuations in power ,mainly due tot the fact my other printer runs perfectly well without any issues and i prototype on that with 48+ hour prints a lot of the time, it could be a issue with the psu being faulty too, i never considerd that being an issue, i have a spare psu i can try this evening.
additional info, the seller has now been in touch and looks like he's prepared to replace parts if i can offer some additional info to him. luckily i have pictures and videos of the machine failing. i'll keep you informed of the outcome.

That's great that the seller will work with you. Good luck! The power where i live is subject to frequent brownouts blips etc so i added an UPS to remediate the issue. The sensitivity to EMI may be an issue as well especially if the power supply is marginal to start with. The fact that sometimes the display comes up with bad characters tells me the electronics are not particularly robust.

My unit went together pretty well, one of the pins would not go through the ball joint so I had to file out the hole a bit and then use a vise carefully to press it on. the ball itself was OK and moved relatively freely. The motor drivers were all not set to a high enough voltage. I had to set my axis motor drive to 1 volt (voltmeter leads - on USB connector metal outer shell, + on the potentiometer dial on the controller itself, measure with the unit on but of course not doing anything. I had to lay it on its side to get to the board since I had already mounted everything. I set the extruder voltage to the max (about 1.09 volts) and even then those crappy plastic extruders with the fine toothed wheel would not push the filament. I even tried pushing the filament through by hand and even trying that plunger tool to clear out the nozzle while hot. I think the hotend was either defective or was a 0.2 mm model, I could not push filament through and even at 230 degrees c. That is when I bought a new 3-in 1-out hot end from ebay, and also bought MK8 Aluminum extruders from banggood. I replaced the hotend and those extruders (needed some longer M3 screws than what came with them to mount the extruder) and was able to get it to print pretty well. The mainboard is buggy, sometimes it boots up with funny characters on the screen. I use Repetier Host to run the printer and had to customize the final gcode to just move up to 200mm and leave the x y z motors on otherwise unattended, the head drifts down onto the part and marks it. I set the print speeds to all be 10mm per sec. Take your time getting the leveling right, the mechanics or the bed may seem slightly bowed but it may be the "radius" in the printer settings, but it was close enough so I did not mess with it. The mixer acts funny, it does sorta work but sometimes one color or the other seems to stop extruding. I print PLA at 202 0r 203 degrees c and that seems to work OK. Yeah I wish they would release the firmware source so we could fix it. I may look into a new controller entirely but that is a crap ton of work.

Good Luck!
Chris

So far, the list of problems are: Instability, under-extrusion, no part cooling, and closed source firmware/board.

I wish that was my only problem, i love the concept of this printer but i cannot even get a decent 1st layer down, the motors skip so much, i've tightened the belts and loosened them to no avail, i'm getting to the point where i wish i'd spent my money on a prussia i3 with quad colour than spend money on this thing.

I had to dial the pots on the stepper drivers to the max the driver would reach.

I'll give that a try, do you know what voltage that was and do the pots themselves just keep turning or is there a physical limit they will turn to?

They just keep spinning, you gotta make small adjustments, or else you wrap back around to the low end

Thats my tonight sorted then I'll let you know how i get on, i really want to get something to print on this thing even if the quality isn't that great to start with, i can work with something the issue is i'm getting nothing at the minute.