Loading

Hypercube Evolution Z Axis problem

Please Login to Comment

Z axis moves up and down perfectly when homing. When I load a file to print and press print, it warms up the heated bed and once that is up to set temperature, it moves Z axis down a bit and thats when it goes haywire. It almost looks like it is not sending enough voltage to motors on slow move or something. I have the Z motors connected in series and that seems to work very good when I send manual move commands. I have a 300x300 bed and am using Marlin 1.1.9 Firmware because I couldnt get the Marlin 2 version to work with my Full Graphics Smart controller. Attached is my Configuration file. Can someone help or tell me what my problem could be ?

I may not be able to help you with the "Haywire" problem, but I think I know why you are having problems getting Marlin 2 to work with your Full Graphics Smart Controller. I had the same problem. I assume that you are using the Arduino IDE to compile Marlin. If youare, that is the problem. When the Arduino has finished compiling the various parts of Marlin, it then links them using a DOS command. The DOS command is limited to 32KB, the command Arduino is sending is around 45KB. Too long to work. Download Visual Studio Code (https://code.visualstudio.com/) and then download the Auto Build Marlin extension (https://marlinfw.org/docs/basics/auto_build_marlin.html). You will be able to compile Marlin 2.x.x with the Full Graphics Smart Controller with no problem.

On most boards dual Z motors need to be connected in parallel not serial. By connecting the motors in series, each motor only gets half the voltage.

Voltage doesn't matter. The voltage you adjust does not set the voltage that the stepper gets. That is the setting for the current. Connecting them in parallel is not good. You cannot balance the motors to get the same current. If you connect them in series, you get the same current through both.

I am using the Mega 2560 Board. It has 2 pin groups to connect both motors but it seems i cant get enough torque when I connect them that way. Ive tried anywhere from 1.5 volts to .6 volts. What else could I try?

The .ino file you sent does not have any programming in it. You should upload Configuration.h and Configuration_adv.h, which will show your configuration

What, exactly, do you mean by "thats when it goes haywire"?

I starts making funny noises and doesnt move like it should. Motors seems to lose their power. Attached is my config files

Bearing in mind that I haven't used Marlin for a couple of years, and that my comments may or may not be relevant...

You have two Z axis endstop plugs defined.

define USE_ZMIN_PLUG

define USE_ZMAX_PLUG

Normally, you would only define one, and in your case, you are homing to ZMAX (would not have been my choice, but to each his own).

You have

define Z_MAX_POS 100

Is that the max Z height? The standard HEVO is 400mm Max Z height.

You have both

define MIN_SOFTWARE_ENDSTOPS

and

define MAX_SOFTWARE_ENDSTOPS

These are normally set to the other extent of your endstops.
In other words, if you are using a hardware MIN endstop, you would set the MAX_SOFTWARE_ENDSTOP for that axis, and if you are using a hardware MAX endstop, you should set the MIN_SOFTWARE_ENDSTOP for that axis.

You say that when the temperature is up, your Z axis moves down a bit, but you have the Z homing direction set to ZMAX, so when you home, it should move the bed down to the Z endstop. Remember, a Z UP move, moves the bed down, and a Z DOWN move moves it up. In other words, when your bed is up near the nozzle (at or near Z=0), and you tell it to move to Z 100, it should move down 100mm.

I think there is something wrong in the configurations I pointed out.

It would be worthwhile reading the docs as they pertain to these entries.

Here are some troubleshooting tips.

Home the Z axis.
Does it go to ZMax (all the way down) or ZMIN (all the way up), and is it going in the direction you expected?

Use the terminal in your control program to command some moves.
G28 ; should home all three axes.

If your bed is up near the nozzle, issue
G1 Z10 F50 ; should move the bed down slowly, 10mm
G1 Z0 F50 ; should move the bed up slowly, 10mm

If your bed is down near the bottom, issue
G1 Z0 F500 ;should move the bed up to near the nozzle

If these don't go in the directions indicated, that's the first thing to fix. If they do, get back here with the results, and an idea of what you did.

Hi there. Can you check config file again. I see my endstops set up like this:

define USE_XMIN_PLUG

define USE_YMIN_PLUG

define USE_ZMIN_PLUG

define USE_XMAX_PLUG

Just one Z endstop and that is used as min. I home at the top close to Hotend.

Just copied this from configuration.h starting at line 635

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.

define USE_XMIN_PLUG

//#define USE_YMIN_PLUG

define USE_ZMIN_PLUG

//#define USE_XMAX_PLUG

define USE_YMAX_PLUG

define USE_ZMAX_PLUG

not sure whats going on. This is different than my file. Are you getting that from just below where header is that says Endstop settings? In Configuration.h file ?

Hmmm... I just downloaded your configuration.h file, and you are right. I must have had a previous configuration.h that I looked at. I'll take a further look later, as I'll be busy for a while. Sorry about that.

Ok. No worries.

Went over your configuration.h, and I don't see anything that looks suspicious. Sorry I can't help.

What do you think the ideal voltage would be connected in parallel on these motors? 17HD48002H-22B

You said you connected them in series, which is the right way to do it, and the voltage setting on the driver should be the same as it is for a single motor.