Loading

Retraction Settings for PETG?

Please Login to Comment

Hello. I plan on printing in some PETG today but need the correct retraction settings because PETG jams are hard to undo. Thanks for the advice!

I had problems with the printhead dragging along the print surface making a very rough print. I began using Slic3r with 0.02 z-offset instead of Cura and the problem disappeared. With printspeeds over 50mm/s the PETG filament has a hard time extruding at enough fast pace, best print quality is achieved with 40-45mm/s printspeed (stock hotend, no print-head mods). I use Prima Select PETG at 240-245C, I have been using 5-7mm retraction at 40mm/s retraction speed. Used both 0.20 and 0.10mm layer height with excellent results. First layer hight 0.20-0.25. Only use the fan if the object is small, lager prints don't need a fan unless overhangs or bridging.

I'm using the all metal hotend (no ptfe tube). My retraction setting is 1.6 mm. ,temp is 215 C and feed 98%. However take care if you're using CURA because at the "default" end g-code it will retract an extra 5 mm. This could block your extruder when the filament cools down.I limited the extra retraction to 1.5 mm. and until now it prints perfectly with very limited stringing .
Good luck!

My retraction is 1.9mm. I printed my first PETG prints this weekend and had awesome results. I don't have the all metal hotend installed right now. Inland PETG printed perfectly at 235C. https://imgur.com/a/9zUnQ

I can post my simplify3d fff later tonight if you'd like.

Nearly done that edge pairing.

Comment has been deleted

The retraction settings tend to vary between the many types of PET-G available, but generally spoken a value twice as big as the one for PLA should be ok as long as you stay below the maximum retraction lenght (<4-5mm with the stock-hotend, <2mm with the all-metal-hotend).

If you're printing without the all-metal hotend there's a chance that your PTFE-Tube has already degraded (due to the high temps which PET-G usually needs for a constant flow) which could also be a reason for your jams.

Here's the top bit of my CURA profile settings...
I only use PET-G, and have had no issues with retraction or jams using this profile...

[profile]
layer_height = 0.2
wall_thickness = 0.8
retraction_enable = True
solid_layer_thickness = 0.8
fill_density = 20
nozzle_size = 0.4
print_speed = 40
print_temperature = 250
print_temperature2 = 0
print_temperature3 = 0
print_temperature4 = 0
print_temperature5 = 0
print_bed_temperature = 60
support = Touching buildplate
platform_adhesion = Brim
support_dual_extrusion = Both
wipe_tower = False
wipe_tower_volume = 15
ooze_shield = False
filament_diameter = 1.75
filament_diameter2 = 0
filament_diameter3 = 0
filament_diameter4 = 0
filament_diameter5 = 0
filament_flow = 100.0
retraction_speed = 25
retraction_amount = 2
retraction_dual_amount = 16.5
retraction_min_travel = 1.5
retraction_combing = All
retraction_minimal_extrusion = 0.02
retraction_hop = 0.0
bottom_thickness = 0.3
layer0_width_factor = 125
object_sink = 0.0
overlap_dual = 0.15
travel_speed = 90
bottom_layer_speed = 15
infill_speed = 0.0
solidarea_speed = 0.0
inset0_speed = 20
insetx_speed = 0.0
cool_min_layer_time = 15
fan_enabled = True
skirt_line_count = 1
skirt_gap = 3.0
skirt_minimal_length = 150.0
fan_full_height = 0.5
fan_speed = 100
fan_speed_max = 100
cool_min_feedrate = 10
cool_head_lift = False
solid_top = True
solid_bottom = True
fill_overlap = 15
perimeter_before_infill = False
support_type = Lines
support_angle = 60
support_fill_rate = 15
support_xy_distance = 0.7
support_z_distance = 0.15
spiralize = False
simple_mode = False
brim_line_count = 40
raft_margin = 5.0
raft_line_spacing = 3.0
raft_base_thickness = 0.3
raft_base_linewidth = 1.0
raft_interface_thickness = 0.27
raft_interface_linewidth = 0.4
raft_airgap_all = 0.0
raft_airgap = 0.22
raft_surface_layers = 2
raft_surface_thickness = 0.27
raft_surface_linewidth = 0.4
fix_horrible_union_all_type_a = True
fix_horrible_union_all_type_b = False
fix_horrible_use_open_bits = False
fix_horrible_extensive_stitching = False
plugin_config =
object_center_x = -1
object_center_y = -1